Aller au contenu
Support de Zwii et Yocto

Messages recommandés

Bonjour,

 

Nous venons de terminer 2 sites qui viennent remplacer 2 autres sites. Ces 2 nouveaux sites ont été construits, non pas à la racine de leur hébergement web respectif, mais dans des sous répertoires, ceci afin de ne pas interférer avec les deux anciens pendant la phase de construction. L'heure est maintenant venue de les mettre en ligne.

Pour le 1er site, l'ancien est effacé, le nouveau est copié collé à la racine de l'hébergement. Le test de la mise en ligne est positif, le site de travail est effacé, les seules corrections faites pour le nouveau site en ligne sont pour les liens absolus mis par erreur, ces liens étant vite remplacés par des liens relatifs. Le site est ok.

Pour le 2ème site (hébergé chez ovh aussi), même manœuvre, l'ancien site est effacé, le nouveau site est mis à la racine. Problème, la page d'accueil de la racine de l'hébergement s'affiche bien, mais les autres liens du menu donnent sur le site de travail, quelques répertoires plus bas.

Si le répertoire à la racine du site de travail est renommé en old, la page d'accueil à la racine de l'hébergement s'affiche toujours, mais plus rien de marche y compris le fait de vouloir se connecter, ce qui m'épate tout de même.

A noter, je pense que c'est l'origine du problème, que dans les options avancées, la case réécriture d'URL était cochée, contrairement au premier site.

Avez-vous des pistes pour détecter l'origine du problème ? Le site de travail fonctionne toujours normalement.

Très bonne journée

J

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @jean17. As-tu modifié l'URL de base dans le fichier ".htaccess" à la racine de ton installation ?

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting
<ifModule mod_rewrite.c>
	RewriteEngine on
	RewriteBase /nouveau répertoire/
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule ^(.*)$ index.php?$1 [L]
</ifModule>

Ce qu'explique @Xav7800 dans son excellent tuto sur la mise en ligne d'un site depuis une installation locale s'applique aussi à ton cas de figure.

 

PS : Je ne vois pas bien comment le premier site pouvait fonctionner dans un sous-répertoire sans réécriture des URL...

 

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci beaucoup Peter pour le lien sur le tuto et mes excuses pour ne pas l'avoir consulté !

Le site est revenu et j'ai corrigé l'ensemble des liens absolus dans le bon fichier.

Donc ça marche.

Par contre si je fais la modif

RewriteBase /nouveau répertoire/

C'est à dire dans mon cas

RewriteBase  /

puisque je suis à la racine, j'ai une erreur system à la connexion.

 

Bon appétit

J

  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 25 minutes, jean17 a dit :

C'est à dire dans mon cas

RewriteBase  /

puisque je suis à la racine, j'ai une erreur system à la connexion.

 

Tu as essayé de vérifier ton fichier .json ("site/data/data.json" pour une 8 ou "site/data/core.json pour une 9) ?

Je te renvoie à nouveau aux tutos que nous avons créés avec @Xav7800. Regarde le dernier (la petite voiture jaune avec le capot ouvert).

Mais je "suis ton ticket" 😄 N'hésite pas.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci pour tout mon "ticket" 😄,

Je me suis certainement mal exprimé :

Comme dit sur le tuto, le premier,  j'ai modifié le fichier data.json de façon à ce que tout marche ... si le .htaccess est viré.

L'erreur sytem (générale pour tout le site) ne survient que quand je remets en place le .htaccess, modifié comme sur le premier tuto.

Du coup, je pense que le data.json n'y est pour rien et que j'ai uniquement un problème de htaccess ....

 

Amicalement

J

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 40 minutes, jean17 a dit :

[...] le premier,  j'ai modifié le fichier data.json de façon à ce que tout marche ... si le .htaccess est viré.

 

Sans ".htaccess" ? Je crois que c'est moi qui ai du mal à comprendre : ce fichier assure la première protection de ton site.

 

Fais une copie de "data.json" — renomme-le simplement "data.json0", par exemple. Remplace le fichier ".htaccess" par un modèle d'origine — il suffit de peu pour le corrompre — et refais l'installation.

Une fois que ton nouveau site sera gaillard, fais la manip inverse pour le "data.json", et rectifie les liens le cas échéant.

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci ...

Je ne dis pas que c'est bien sans le fichier htaccess mais que le site marche ; effectivement, je préfère aussi être protégé ...

Je viens de faire un test dans un autre espace web, voici l'intégralité de mon htaccess :

 

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

 

Il n'y a que cela c'est un peu étonnant non ? De plus il n'est même pas à la racine de l'hébergement.

Bonne après-midi

J

 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 42 minutes, jean17 a dit :

Il n'y a que cela c'est un peu étonnant non ? De plus il n'est même pas à la racine de l'hébergement.

 

Non non : le contenu du ".htaccess" minimum suffit pour une installation à la racine de l'hébergement.

Après, tu peux le mettre où tu veux, le renommer ou le supprimer, c'est pareil : ça n'empêchera pas ton site de fonctionner malgré un avertissement éventuel... mais tu n'auras plus de protection, et sans d'autres ".htaccess" dans les répertoire sensibles, tout serait aussi accessible que ça :

 

htaccess.png.3dcf8f7c8ca68d45632bdf30c46a1f69.png

 

Je t'ai expliqué ce que je ferais pour reprendre la main sur ton site. Mais, sauf à interpréter que tu me remerciais de t'avoir donné la solution à ton problème, je ne sais pas grand chose de la suite... 🙄

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites

Mes excuses, j'avais des obligations.

Le deuxième site est à la racine, le htaccess mini suffit à le protéger si je comprends bien ? en tout cas quand j'essaie de me loguer sur core, module ou site, j'ai un beau forbidden ...

Maintenant, j'ai bien compris la manœuvre pour générer un htaccess nouveau et plus propre, mais j'ai peur de ne pas avoir le temps maintenant, à cause de la correction des liens et il y en a une tonne ... mais aussitôt qu possible je fais la manip.

Je te remercie beaucoup pour toute cette aide et te souhaite une très bonne soirée

J

Partager ce message


Lien à poster
Partager sur d’autres sites

Je comprends, @jean17.

Le .htaccess mini suffit pour une installation à la racine : il fait ce que les commentaires expliquent, ce qui empêche entre autres qu'on puisse explorer tes répertoires comme je l'ai fait pour les besoins de la copie d'écran ci-dessus.

 

Par rapport à la manip que je t'ai expliquée pour avoir un .htaccess tout neuf, ça ne prend pas vraiment pas beaucoup de temps : comme je t'ai expliqué, il suffit de le remplacer par le modèle d'origine pour une installation à la racine.

 

Pour ce qui est des chemins dans "data.json", ça ne prend pas beaucoup plus de temps avec la fonction "Remplacer" de ton éditeur (CRTL-H).

Pour une installation à la racine d'un site préparé dans un sous-répertoire, voici ce qu'il faut faire :

  • Éditer "data.json".
  • Avec CTRL-H mettre le nom du répertoire d'origine dans la case "Rechercher" (avec le slash et l'antislash), comme ceci :
/nom de ton répertoire\
  • Ne rien mettre dans la case "Remplacer par".
  • Lancer le remplacement.

Même si on peut revenir en arrière (CTRL-Z), travaille sur une copie pour ne pas tout perdre bêtement. 😉

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 8 heures, PeterRabbit a dit :

PS : Je ne vois pas bien comment le premier site pouvait fonctionner dans un sous-répertoire sans réécriture des URL...

 

Je me permet d'intervenir car j'installe tout mes zwii dans des sous répertoires (obligation quand on en a beaucoup à gérer ou tester) 

j'ai 7 noms de domaine déposés et chacun ont à la racine de l'espace web du nom de domaine un site sans aucun rapport avec les zwii; et cela me semble important donc de préciser qu'il n'est pas obligatoire de placer un site à la racine de son serveur.

 

Donc que ce soit sans redirection d'url ou avec la redirection d'url activée, et bien tout les zwii s'affichent correctement dans le sous dossiers où il ont été placés.

 

Voici trois captures d'écran qui montre sur le nom de domaine où je fais mes principaux tests, l'architecture de la racine de cet espace web chez mon registar Ionos (anciennement 1&1)

 

ndm.png.2b9a9a7e455e3bdaf88880ba7f43e0eb.png

 

ndm1.png.696771a7015b5d7a70ce990bb91d613a.png

 

ndm2.png.dcc7e549374f0655cef4949cb76c0914.png

 

Il est même parfaitement possible de renommer le site zwii comme on le désire...sans que celui ci soit en quoi que ce soit inaccessible depuis un navigateur.

 

Voir ici l'adresse de ce site au dessus qui servi pour les captures d'écran, celui ci sert de test;

  http://www.desforges-roger.fr/ZwiiCMS-859/accueil

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@roger En effet, j'ai dit une connerie : pour moi, la non activation de la réécriture des URL a fini par s'associer à Free et à son impossibilité d'activer cette fonction que j'active systématiquement.

Mais ça ne change rien (enfin, j'espère tout en craignant le pire) au conseil que j'ai donné.

Modifié par PeterRabbit
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

@PeterRabbit je pense que notre ami s'il suit tes conseils pour tenter une réparation de son data.json devrait normalement pouvoir rétablir comme il faut son second site. C'est en effet la seule façon de rétablir les chemins quant on à cloner un site depuis un autre data.json.

Après comme tu le précises bien dans ton aide, ce sera à @jean17 de bien mettre les nouveaux lien du site (à la racine ou non dans son espace web de son nom de domaine) dans ce fameux fichier data.json.

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...