Aller au contenu
Support de Zwii
  • 0
Seb

Probléme à l'installation (Unable to read data file)

Question

Salut à tous,

 

Un petit moment que je ne suis pas revenu ici (problèmes de santé et autres joyeusetés). Content de voir que le projet est toujours debout et plus que jamais (je m'étais inquiété suite au départ de Rémi). J'ai mis récemment à jour deux vieux sites et ça a marché impec. J'en profite pour vous féliciter du boulot accompli et pour vous souhaiter à tous une belle année 2019.

 

Bon, passons aux choses pénibles...

J'ai souhaité procéder à une fraîche installation d'un Zwii sur un de mes domaines. Et là, bing, je reçois ça à l'écran :

 

Unable to read data file. 

J'ai zieuté le forum et j'ai vu que ce bug était reporté pour des mises à jour automatiques, pas pour une install neuve.

 

Quelqu’un a-t-il une idée ? Je suis chez o2switch, j'ai d'anciennes Zwii en place, tout fonctionne, y compris les MàJ auto.

 

Merci d'avance pour votre aide !

Partager ce message


Lien à poster
Partager sur d’autres sites

14 réponses à cette question

Messages recommandés

  • 0
Il y a 3 heures, sebguillet a dit :

J'en profite pour vous féliciter du boulot accompli et pour vous souhaiter à tous une belle année 2019.

 

Merci, @sebguillet, meilleurs vœux à toi aussi ! :)

 

Ceci dit, tu veux une bonne, ou une mauvaise nouvelle ? 

— La bonne, c'est que Zwii (version 8.55) n'y est pour rien.

— La mauvaise, c'est que o2switch n'y est pour rien non plus : je viens d'installer une 8.55 dans un sous-répertoire (nom-de-domaine/855) d'un site installé chez eux. Et ça fonctionne — de façon étonnante, moins bien que chez d'autres hébergeurs alors que WP tourne très bien chez eux — mais ça fonctionne sans erreur.

 

Et si tu recommençais ?

Modifié par McGregor

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Réessayé deux fois. Idem.

 

Mes deux autres install Zwii fonctionnent parfaitement sur mon serveur o2switch.

 

Y'a-t-il une page d'archive des versions antérieures de Zwii ? Je n'ai pas trouvé.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Voilà. J'ai testé l'install avec la 8.2.5 trouvé sur le Github. Toujours la même erreur. :( Cette version je l'ai pourtant installée déjà chez o2switch. Ils ont dû modifier un ou plusieurs paramètres serveur entre temps.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 12 minutes, sebguillet a dit :

Voilà. J'ai testé l'install avec la 8.2.5 trouvé sur le Github. Toujours la même erreur. :( Cette version je l'ai pourtant installée déjà chez o2switch. Ils ont dû modifier un ou plusieurs paramètres serveur entre temps.

 

As-tu lu ma réponse ? Et si tu essayais plutôt avec la version 8.55 ? https://zwiicms.com/public/archive/ZwiiCMS-855.zip

Ceci dit, si tu veux des versions particulières, j'en ai un certain nombre.

 

Modifié par McGregor

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

La version 8.5.5 c'est celle que j'ai utilisé dès le départ. Quand j'installe un logiciel ou un CMS, j'utiilise toujours la dernière version stable.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 21 minutes, sebguillet a dit :

La version 8.5.5 c'est celle que j'ai utilisé dès le départ. Quand j'installe un logiciel ou un CMS, j'utiilise toujours la dernière version stable.

 

D'accord, d'accord. o.O

Dans ce cas, je ne comprends vraiment pas comment j'ai pu installer cette version chez o2switch.

Je te suggère de t'adresser à eux en leur expliquant que tu ne comprends pas comment j'ai pu le faire et pas toi.

 

 

Modifié par McGregor

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

A priori un problème de paramétrage de transfert Filezilla (ASCII au lieu d'auto). Il faut dire que j'ai changé d'OS, je n'y avais pas pensé.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'ai encore des soucis d'affichage d'images et d’icônes. Je repars pour des tests en apnée...

 

Merci Peter

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@sebguillet Avant de nous refaire Le Grand Bleu, une question : essaies-tu d'importer un ancien "data.json" ? 

Si oui, dis-le moi, j'ai une méthode.

PS : Cite-moi ou mentionne-moi (@PeterRabbit) stp pour que je sois prévenu par courriel : quand le forum est actif, les sujets disparaissent aussitôt de la première page.

Modifié par McGregor

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

En effet j'avais testé l'import de data.json, en vain.

 

Finalement, j'ai réglé le problème : c'est mon certificat Let's Encrypt qui bousillait tout. J'ai réinstallé ce dernier et tout a marché nickel.

 

Ouf ! J'ai évité Le Grand Bleu (ma génération, j'adore).

 

Merci @PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 17 minutes, sebguillet a dit :

Finalement, j'ai réglé le problème : c'est mon certificat Let's Encrypt qui bousillait tout. J'ai réinstallé ce dernier et tout a marché nickel.

 

Bien content pour toi !

 

il y a 16 minutes, sebguillet a dit :

Ouf ! J'ai évité Le Grand Bleu (ma génération, j'adore).

 

Petit jeune, va ! Moi, c'est La grande illusion. xD

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à cette question…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • Contenu similaire

    • Par mickaelgutt
      Bonsoir à tous,
       
      Pour ceux que cela intéresse j'ai travaillé cette après midi sur la sauvegarde de données de module.
      Je m'explique :
      je prends l'exemple du livre d'or, actuellement il existe le fichier module.json qui enregistre toutes les données du module mais également de tous les autres modules.
      pour les personnes qui désirent sauvegarder uniquement les données propre à leur module ( comme pour moi le livre d'or ) j'ai mis en place un bouton upload dans la config :

       
      afin d'avoir une sauvegarde indépendante dans un répertoire data du module,
      ce fichier contidra uniquement les données du module livred'or :

       
      je travaille également sur la possibilité de faire une restauration vers le fichier : module.json
       
      Dites moi ce que vous en pensez !!
       
      Cordialement
      Mickael
       
       
       
    • Par mickaelgutt
      Bonjour, @Fred
       
      j'ai remarqué depuis quelques mises à jour sur le Zwii, qu'il y avait des modifications sur la structure du module.json
      Est ce que vous avez décider d'une nouvelle structure pour l'organisation des enregistrements de données dans le json si oui laquel ?,
      c'est surtout pour avoir une structure de module homogène
      exemple sur le blog avant il y avait :
      module=>blog=>posts, or maintenant posts n'est plus présent donc sur une edition ou ajout on a :
      <div class="col6"> <?php echo template::date('newsEditPublishedOn', [ 'help' => 'La news est consultable à partir du moment ou la date de publication est passée.', 'label' => 'Date de publication', 'value' => $this->getData(['module', $this->getUrl(0), $this->getUrl(2), 'publishedOn']) ]); ?> </div> et plus une value =
      'value' => $this->getData(['module', $this->getUrl(0), 'posts', $this->getUrl(2), 'publishedOn'])  Pour la mise à jour des modules actuels et des nouveaux modules futur pour le zwii comment doit on procéder ?
       
      Car même si les modules sont indépendants des un des autres, il est plus simple un model de structure du json pour mieux si retrouver.
       
      Je pose la question mais c'est peut être pas le moment, donc pas de soucis si c'est pas le moment.
       
      Allez bon courage à tous 
       
      Cordialement
      Mickael
    • Par pduchemin
      Bonjour,
       
      Après réception du mail .....
       
      J'ai  hélas l’impression que ça tourne  en boucle  ,   il me redemande la page d'installation ???
       
      Que se passe  t il  ?
       
      Patrick
×
×
  • Créer...