Aller au contenu
Support de Zwii et Yocto

Messages recommandés

C'est vrai que c'est quand même mieux comme ça.

Par contre, j'aurais 1 ou 2 questions, si tu peux m'aiguiller...

Au niveau du référencement, mon site en français et accessible avec ces 2 adresse:

 

https://www.leutransporteur.com/ et https://www.leutransporteur.com/accueil

 

y a t-il un moyen d'éviter ça ? apparemment, il y a une histoire de lien canonique pour éviter les liens identiques mais j'avoue ne pas trop comprendre...

 

Et quand je regarde via la search console google, au niveau "ciblage internationale", ça m'indique :

 

Citation
Votre site ne contient aucune balise "hreflang".
Nous utilisons les balises "hreflang" pour afficher la variante linguistique de vos pages qui correspond à la langue de préférence de l'internaute.

 

J'essaye d'être référencé le mieux possible car il y beaucoup d'autres sites mais comme la plus part paye, moi je suis loin.

 

Mais je suis bien content d'avoir fait mon site de A à Z avec ce CMS et grâce à toi aussi.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, francky_974 a dit :

Est ce qu'il ne serait plus logique de créer un sous répertoire /fr dans www comme pour la version anglaise ?

Fais comme tu l'entends, mais à mon avis non, le fr est le site de référence dans ta propre langue, l'en étant sa traduction

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, francky_974 a dit :

Par contre, j'aurais 1 ou 2 questions, si tu peux m'aiguiller...

Au niveau du référencement, mon site en français et accessible avec ces 2 adresse:

 

https://www.leutransporteur.com/ et https://www.leutransporteur.com/accueil

 

y a t-il un moyen d'éviter ça ? apparemment, il y a une histoire de lien canonique pour éviter les liens identiques mais j'avoue ne pas trop comprendre...

Sauf indication contraire, le fichier index.(php|htm|html) est le fichier par défaut d’un site web, son nom n’est pas ajouté à l’url, sauf si il est appelé directement par un lien.

Ainsi quand tu te connectes à un site http://exemple.com c’est la page index que tu affiches dans ton navigateur mais seul exemple.com est écrit dans la barre d’adresse.

 

Dans Zwiicms la page index.php inclut un code contenu dans un autre fichier : core.php

Ce code lit les informations contenues dans encore un autre fichier : data.json, interprète ces informations et les affiches, le tout étant mis en page par le fichier main.php

C’est donc toujours index.php qui appelle et affiche les différentes pages virtuelles de ton site réalisé avec Zwiicms.

 

Comme je le précise ci-dessus, l’affichage de index.php n’est pas obligatoire, ainsi afficher :

exemple.com

est équivalent à :

exemple.com/index.php (ou html, htm, asp…)

Php est un langage de programmation qui permet d’écrire des sites dynamiques, un point d’interrogation dans une url est une requête (query), et de la même manière que ci-dessus,

exemple.com/?

est équivalent à :

exemple.com/index.php?

Donc les adresses des différentes pages de ton site sont appelées par le nom que tu leur a donné de cette façon :

index.php?ma-page

ou

?ma-page

 

Puisque facultatif, dans Zwiicms le nom de fichier index.php n’apparaît jamais dans les liens inscrits dans son code, seul est écrit : ?

 

Pour que les urls soient plus lisibles, et possiblement mieux vues par les moteurs de recherches, il est possible de les réécrire avec une directive Apache, contenue dans le fichier .htaccess, c’est ce que l’on appelle la réécriture d’url (urlrewriting in english), si tu choisis cette possibilité, alors le point d’interrogation ne s’affiche plus dans l’url de tes pages, et quand l’hébergeur de ton site le permet, il est recommandé de choisi cette option.

Ainsi réécrite tes pages s’affichent ainsi :

exemple.com/ma-page

 

Concernant le lien canonique, il ne concerne que les sites générant du contenu dynamique, ZwiiCMS génère des sites à contenu statique.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, francky_974 a dit :

J'essaye d'être référencé le mieux possible car il y beaucoup d'autres sites mais comme la plus part paye, moi je suis loin.

Ce n'est pas un cas isolé, nous sommes des millions sur le web et chacun voudrait apparaître à la première ligne des résultats de recherche.

Pour être connu il faut se faire connaître, laisse tomber le foutoir de Google qui de toutes façon et quoi que tu indiques dans ton site pour orienter l'indexation, fait ce qu'il veut sur ton site.

Pour te faire connaître, il faut que ton site soit visible et accessible sur et depuis d'autres sites susceptibles d’intéresser ta clientèle potentielle, offices de tourisme, villages vacance, hôtels, restaurants, agences de voyage... Choisi, bien sur, les sites les plus vus, ce sont ceux qui sont dans les 3 premières pages des résultats de recherches, procède avec eux à un échange de liens, et quand un robot "crawlera" leur page le lien vers ton site sera indexé, puis à son tour "crawlé"

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, francky_974 a dit :

quand je regarde via la search console google, au niveau "ciblage internationale", ça m'indique :

 

Citation
Votre site ne contient aucune balise "hreflang".
Nous utilisons les balises "hreflang" pour afficher la variante linguistique de vos pages qui correspond à la langue de préférence de l'internaute.

 

Ton site vient tout juste d'intégrer ces balises, attend avant de faire ce type de test, comme l'indique son nom "search console google" les test sont fait sur la BDD de Google, mais si tu n'y est pas, dans cette BDD, tu ne peux pas y apparaitre

 

Dernière chose, tu peut t'inscrire sur google webmaster et y demander de crawler ton site

 

Et une dernière fois, te prends pas la tête avec Google, tous les moteurs de recherches crawlent tous les sites... visibles !

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour CroqueWeb,

 

Je viens de lire avec intérêt toutes tes explications

.

Je vais suivre donc tes conseils et laisser donc mon site comme il est au niveau des répertoires.

 

Pour les histoires d'adresses idem, le principal c'est que tout fonctionne !

 

C'est sur que niveau maintenance, il faut bien faire attention au niveau du contenu, mais comme mon site ne change pratiquement pas et ne contiens pas des centaines de pages, ça devrait aller.

 

Pour les histoires de google, je vais donc laisser les choses se faire d'elles même, j'ai parmi mes partenaires un lien vers son site qui lui est très bien référencé, je vais donc patienter.

 

De toute façon, pour l'instant, je fonctionne beaucoup avec le bouche à oreille.

 

Encore mille merci pour tout tes conseils...

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci Thispy !

 

J'ai fais au mieux.

Par contre, j'essaye de bidouiller sur la version anglaise, j'essaye de changer le titre "Plan du Site" en "Site map".

 

J'ai trouvé dans le module "sitemap", l'endroit du titre, par contre sur la version anglaise, le module sitemap n’apparaît pas.

 

J'ai fais une copie de la version "fr" sur la version "en" et modifié la partie dans le module pour mettre le titre en anglais mais le résultat ne change pas.

 

Une idée ?

Partager ce message


Lien à poster
Partager sur d’autres sites

https://www.filautolavage.re/partenaires.php

Voila exactement le type de partenariat que tu dois développer, ceux que tu références sur ton propre site devraient te rendre la pareille :

https://www.leutransporteur.com/partenaires

 

Il y a 8 heures, francky_974 a dit :

j'essaye de bidouiller sur la version anglaise, j'essaye de changer le titre "Plan du Site" en "Site map"

=> Lignes 27 de core/module/sitemap/sitemap.php et 1783 de core/core.php

Modifié par CroqueWeb

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir Croque,

 

C'est ok, en fait je chercher le dossier "sitemap" dans le dossier "modules" mais pas dans "core".

 

il y a 41 minutes, CroqueWeb a dit :

=> Lignes 27 de core/module/sitemap/sitemap.php et 1783 de core/core.php

 

Par contre, j'ai pas eu besoin de modifier la ligne 1783 de core/core.php

Le résultat est totale, je crois que tout est traduit, j'ai même renommé toutes les images en anglais dans la version anglaise...

 

Merci !

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

C'est pas bien compliqué et tu aurais pu trouver seul la solution.

Il semble que tu utilises la version 8.3.0, dans ce cas les n° de lignes ne correspondent plus avec la version actuelle, pour traiter ton cas particulier, recherche dans core.php ces 6 occurrences :

$items .= '<img src="

et ajoutes y ceci :

alt="'.$this->getData(['page', $parentPageId, 'title']).'"

en laissant un espace devant et derrière, tq :

$items .= '<img alt="'.$this->getData(['page', $parentPageId, 'title']).'" src="

@cybertaf Ceci est à ajouter à la version en cours

Partager ce message


Lien à poster
Partager sur d’autres sites

Pas bien compliqué ? pour moi si, j'ai pas vraiment compris comment ça va ajouter une balise "alt" à mes icônes de menu...

C'est parfait, j'ai un peu de mal à toujours trouver les choses....

Je comprends un peu mieux le fonctionnement, je suis pas encore au top mais ça avance bien.

Il faut que je trouve le moyen qu'il y ait un minimum de script ou je ne sais quoi qui s’exécute, il y a plein de choses qui ne me servent pas, je vais voir par exemple pour les polices de caractères...

Encore mille merci à toi Mr Croque 

Modifié par francky_974
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a une heure, francky_974 a dit :

je vais voir par exemple pour les polices de caractères

Fais une recherche sur le forum, ce sujet a déjà été abordé, il y était question de dégooglisation, or something like that

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, francky_974 a dit :

Pas bien compliqué ? pour moi si, j'ai pas vraiment compris comment ça va ajouter une balise "alt" à mes icônes de menu...

Ben tu vois, après avoir ajouté le bout de code, les balises alt, recommandées par le W3C, sont présentes et renseignées ;)

T'as gagné la validation :

https://validator.w3.org/nu/?doc=https%3A%2F%2Fwww.leutransporteur.com%2F

 

L'inconvénient de ces modifs ponctuelles, est que tu les perds si tu mets à jour ton ZwiiCMS, sauf si elles ont été ajoutées à la nouvelle version, ce qui devrait être le cas pour cette balise dans les images du menu

 

Il y a 3 heures, francky_974 a dit :

Il faut que je trouve le moyen qu'il y ait un minimum de script ou je ne sais quoi qui s’exécute, il y a plein de choses qui ne me servent pas

As-tu modifié autre chose dans le code ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 19/09/2018 à 15:52, CroqueWeb a dit :

@cybertaf Ceci est à ajouter à la version en cours

C'est pris en compte dans la 8.3.14 en cours de développement.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

×