Aller au contenu
Support de Zwii et Yocto
  • 0
Invité

[ Terminé ] Tinymce

Question

Invité

Les utilisateurs qui pourraient m'aider

@Rémi

@cybertaf

@MAllus

@PeterRabbit

@micka260

et bien entendu ceux qui veulent bien m'aider :)

 

Voilà j'expose mon soucis :

il y a deux jours j'ai pondu une nouveau module pour le zwii adapté à la dernière version 8.2.5 , ce module se nomme " Livre d'or V2 "

Un utilisateur l'a téléchargé et l'utilise sur son zwii avec grand bonheur;

Ce module est basé sur le code du module " News " du zwii  et permet à un visiteur de poster un message dans un livre d'or.

 

Si un administrateur du site poste une nouveau message, il bénéficie de l'interface complète du tinymce pour le faire ( éditeur en mode complet ) :)

 

Si c'est un membre ou un simple visiteur, là ils n'ont droit qu'à un simple textarea ( donc impossibilité pour eux d'avoir leur texte formaté comme il le serait si l'éditeur avait été le même que pour un administrateur du site :(

- donc les retour à la ligne, la possibilité de mettre du texte en gras ou même tout simplement d'utiliser les " petits plus " d'un tinymce normal ne leur sont pas accessibles.

 

****   Ma question est donc la suivante :

Où peut on dans les fichiers du Zwicms autoriser les visiteurs ( groupe minimum ) à pouvoir utiliser Tinymce comme un administrateur

Quel serait le code à injecter et à quels endroits l'écrire.

 

Cela fait maintenant 4 jours complet que je penche sur la question et ne trouve pas la moindre solution, pourtant j'en ai essayé des trucs mais aucuns n'a marché.

merci pour l'aide éventuelle que vous me porteriez pour résoudre mon petit problème, car là vraiment je n'arrive pas à trouver malgré ma persévérance :(

 

ces sujets pourraient vous intéresser pour que vous vous rendiez un peu compte de l'avancée de mon travail sur une première version puis ensuite sur cette autre version pour laquelle je fais appel à vos compétences à tous.

 

Première version en pas deux page un membre heureux --> http://forum.zwiicms.com/index.php?/topic/547-livre-dor/

Seconde version le même membre encore plus heureux --> http://forum.zwiicms.com/index.php?/topic/696-module-livre-dor-v2/

 

 

Modifié par Invité

Partager ce message


Lien à poster
Partager sur d’autres sites

Messages recommandés

  • 0

@Roger nounours Avant que la connexion se coupe — conséquences de travaux dans ma rue —, vu ce que j'ai compris des explications que tu donnes sur ton module, et vu que tu ne précises pas ce que tu as déjà essayé, je répondrais rapidement que c'est sans doute dans l'équivalent du fichier "module/news/news.php" qu'il faudrait que tu baisses les droits permettant d'ajouter l'équivalent d'une "news" :

	public static $actions = [
		'add' => self::GROUP_MODERATOR,
		'config' => self::GROUP_MODERATOR,
		'delete' => self::GROUP_MODERATOR,
		'edit' => self::GROUP_MODERATOR,
		'index' => self::GROUP_VISITOR
	];

J'essaierais donc en réglant les droits de "add" (et éventuellement d' "edit") sur "GROUP_VISITOR".

 

J'ai été confronté à ce problème lorsque j'ai entrepris de réécrire ton module d'inscription d'un membre pour en faire un module d'auto-inscription, ce qui correspond à la situation que tu décris qui oblige à augmenter les droits du simple visiteur.

 

Ceci dit, j'en parle sans avoir installé ton module... :/

 

 

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
il y a 5 minutes, PeterRabbit a dit :

Ceci dit, j'en parle sans avoir installé ton module... :/

 

Ce n'est pas grave tu sais, si tu avais téléchargé a seconde version pour laquelle je demande de l'aide, tu te serais aperçus de suite que les autorisations avaient été mises dans le fichier livredor.php :)

class livredor extends common {

	public static $actions = [
		'add' => self::GROUP_VISITOR,
		'config' => self::GROUP_MODERATOR,
		'delete' => self::GROUP_MODERATOR,
		'edit' => self::GROUP_VISITOR,
		'index' => self::GROUP_VISITOR
	];

 

Mon problème est juste que je veux que mes membre inscrits tout comme mes visiteurs puissent utiliser le tinymce quand il postent un message dans le livre d'or.

 

Seuls les modérateurs et les administrateurs d'un zwii eux ont tinymce en entier pour poster un message dans le livre d'or.

Donc j'ai besoin de savoir où se cachent les autorisations de visibilité pour l'usage du tinymce afin d'y ajouter aussi le groupe des visiteurs.

 

Merci PeterRabbit tout de même pour ton info en espérant qu'ils ne durent pas trop en temps les travaux dans ta rue pour que tu puisses avoir l'usage de ta connexion web :(

 

Je vais donc attendre tout en continuant à chercher de mon coté ( je sais maintenant aussi pourquoi le module " Form " lui n'affiche pas non plus le tiny dans les boites de texte que doivent remplir les visiteurs s'il veulent contacter l'admin ), là c'est une viariable qui indique de ne pas tenir compte de tinymce dans core.js.php

var inputsDOM = formDOM.find("input, select, textarea:not(.editorWysiwyg)"); // Ignore TinyMCE car il gère lui même le message

ce qui montre que je cherche vraiment partout :|

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité

Pour illustrer mon problème voici ce qu'à comme éditeur un visiteur et un membre inscrit comme tel

 

cone1.thumb.png.d2ad072518052a9e9fb178b58ab2cf37.png

 

et l'éditeur dont bénéficie un modérateur ou un administrateur du site

 

cone2.thumb.png.9b0b92203a3eb7ce1861ace8f4b53c88.png

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Roger nounours Puisque la connexion semble tenir depuis que je suis rentré, j'ai téléchargé et installé ton module.

Mais pour moi, le problème est plus important. : j'ai beau suivre tes instructions à la lettre...

1° Envoyer le dossier module à la racine de votre Zwicms ( le plugin " livredor" contenu dans le dossier module doit se trouver dans le dossier " module " à la base de votre zwiicms sur votre ftp, dossier juste entre celui nommé core & celui nommé site )

IMPORTANT:

2° Pour activer votre livre d'or vous devez impérativement quand vous crée sa page y inclure un premier message en cliquand sur la roue crantée de réglage du module et " + Nouveau message "
 

Et puis c'est tout..

... je ne peux pas inclure un premier message (en tant qu'admin), le bouton "Publier mon message" ne répondant pas. Le module ne peut donc pas fonctionner — je précise que je l'ai installé sur une 8.25.

On peut bien sûr incriminer l'hébergeur, mais je ne vois pas pourquoi ce qui marche chez 1&1 ne marcherait pas chez PF, qui n'est tout de même pas comparable à IE8 à l'époque.

 

:(

 

Suggestion : supprime "mon message" qui désorganise l'affichage pour des sites réglés sur 750px. "Publier" suffit.

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

PS : Dernière réflexion naïve, mais sait-on jamais...

 

Puisque tu as adapté le module "News", j'essaierais de tout adapter : toutes les fois que @Rémi réutilise des codes, il prend soin de distinguer les variables en modifiant la première partie de leur nom.

Ne serait-ce que par cohérence, il me semble qu'il ne devrait pas subsister la moindre trace du module "News" dans le code du livre d'or.

 

Pour être parfaitement clair, "news" devrait être remplacé par "livredor" pour rester conforme à ce que tu as fait dans tous les fichiers *.js.php comme celui-ci :

 * Soumission du formulaire pour enregistrer en brouillon
 */
$("#newsAddDraft").on("click", function() {
	$("#newsAddState").val(0);
	$("#newsAddForm").trigger("submit");
});

Ce qui supposerait sans doute de remonter plus haut dans le programme, jusque dans core.php peut-être, pour donner une légitimité à ton module, puisque c'en est un.

 

:|

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
il y a 11 minutes, PeterRabbit a dit :

Suggestion : supprime "mon message" qui désorganise l'affichage pour des sites réglés sur 750px. "Publier" suffit.

 

peu de gens utilisent cette résolution mais par contre étant donné que j'ai fourni dans les dossiers du plugin deux fichiers ( add.css et edit.css ) pour garder cet agencement qui me plais bien, il suffira alors soit à l'utilisateur de par lui même d'aller modifier l'un des deux css fourni ( en l’occurrence add.css ) et d'y ajouter ceci :

.col3 {
	width: 30%;
}

pour le gros bouton à droite

.col1 {
	width: 9.33333333%;
    float: right;
    margin-right: 0px;
    padding-right: 0px;
    padding-left: 0px;
}

pour le bouton retour sur la gauche

soit alors s'il le découvre et n,e vient pas dans ce sujet où je te donne la solution pour être plus précis dans mes explications, il ira sur le support du plugin et je me ferais dans ce cas un plaisir de l'expliquer pour lui et tout ceux qui par la suite verront alors comment le faire.

 

Au final, avec un minimum de travail ceux qui adore les toutes petites résolutions en largeur de site web, auront alors ce résultat pour les satisfaire entièrement.

rab2.thumb.png.b7e1f5426cabed06d0736288fa2b5f9c.png

 

rab1.thumb.png.0e92374c739f9bbdddd89621fc8927d5.png

 

il y a 19 minutes, PeterRabbit a dit :

je ne peux pas inclure un premier message, le bouton "Publier mon message" ne répondant pas.

 

 as tu créer ton premier message depuis l'interface d'administration du plugin et pas depuis la page me où l'on envoie le premier message? Car déjà deux autre personnes l'on testé ce plug et tous ont réussi à le faire fonctionner avec la procédure expliquée.

 

il y a 29 minutes, PeterRabbit a dit :

Ne serait-ce que par cohérence, il me semble qu'il ne devrait pas subsister la moindre trace du module "News" dans le code du livre d'or.

 

comme il est bien précisé , le module et celui qui est basé sur celui des news, donc aucune obligation d'en changer les variables dedans sauf celles qui font reconnaître le module ( tu sais trés bien que certain de mes modules, d'ailleurs il en est même un que tu as adapté ainsi et ce sont bien les codes du module form qui sont utilisé dedans comme le mien qui t'a fourni cette inspiration ( module inscription en date de décembre2017 ;) )

il y a 22 minutes, PeterRabbit a dit :

Mais pour moi, le problème est plus important.

 

Tandis que pour moi c'est trouver la solution pour laquelle j'ai crée ce sujet à savoir permettre l'utilisation du tiynmce à mes visiteurs, aurais tu quelque chose à me proposer à ce sujet s'il te plais afin de ne pas nous égarer dans d'autre directions?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
il y a 16 minutes, PeterRabbit a dit :

Pour être parfaitement clair, "news" devrait être remplacé par "livredor" pour rester conforme à ce que tu as fait dans tous les fichiers *.js.php comme celui-ci :

 

j'avais oublié de préciser que le *.js.php fonctionne parfaitement vu que puisque le modérateur et l'admin eux peuvent poster un message dans le livre d'or alors que celui ci n'est déclaré que dans son propre dossier et nul par ailleurs dans le core.js.php ni dans le core.php.

 

Si la fonction citée dans le js, était valable pour les uns elle le serait aussi pour les autres ( modérateurs et admin d'un zwii ) ce qui n'est pas le cas B|

il y a 20 minutes, PeterRabbit a dit :

* Soumission du formulaire pour enregistrer en brouillon */ $("#newsAddDraft").on("click", function() { $("#newsAddState").val(0); $("#newsAddForm").trigger("submit"); });

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

La largeur que j'utilise n'est pas une maniaquerie personnelle.

Si je te dis que je n'ai pas réussi à faire ce que tu dis, c'est que je n'ai pas réussi.

Je n'ai pas adapté ton module, je l'ai totalement réécrit. Rien de comparable donc, et c'était sur la 8.10.

Et il me semble que je cherche à être constructif.

 

Merci pour ta réponse, @Roger nounours, je m'en souviendrai.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité

S'il te plais peux tu me donner par mp l'adresse du site où tu as installé le plugin avec un accès modérateur au minimum ou admin que je vérifie ce qui peut " buguer " chez toi.

 

Je sais que tu cherches à être constructif et je ne met pas ceci en cause ni me tes talents, j'essaie juste d'expliquer que ce que tu écris et déjà fait ou n'est pas incompatible avec ma façon de faire pour un plug donné ( je ne suis d'ailleurs pas le seul à ne pas réécrire toute les variables en relation avec une librairie du zwii ).

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Dans ce cas, il suffit de dire que merci, mais non ce n'est pas ça, que tu as déjà essayé mais que ça ne marche pas. Ça tient en deux lignes, et ça ne risque pas d'être mal interprété ou d'égarer les visiteurs. 

 

Il y a 2 heures, Roger nounours a dit :

j'avais oublié de préciser que le *.js.php fonctionne parfaitement vu que puisque le modérateur et l'admin eux peuvent poster un message dans le livre d'or alors que celui ci n'est déclaré que dans son propre dossier et nul par ailleurs dans le core.js.php ni dans le core.php.

Si la fonction citée dans le js, était valable pour les uns elle le serait aussi pour les autres ( modérateurs et admin d'un zwii ) ce qui n'est pas le cas B|

 

Pour info, "News" s'installe et fonctionne chez moi, pas le livre d'or. Que peut-on en déduire ? o.O

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
il y a 21 minutes, PeterRabbit a dit :

Que peut-on en déduire ?

 

la v2 s'installant sur une version 8.2.5 de zwii et t'ayant fait une demande à laquelle tu n'as pas encore répondu ( même par la négative ce que je peux comprendre )

==> http://forum.zwiicms.com/index.php?/topic/701-tinymce/&do=findComment&comment=10225

Citation

S'il te plais peux tu me donner par mp l'adresse du site où tu as installé le plugin avec un accès modérateur au minimum ou admin que je vérifie ce qui peut " buguer " chez toi.

Je déduirais simplement que tu es le seul à ne pas pouvoir l'installer mais aussi le seul à ne pas te rendre dans son forum de soutien où un membre totalement novice à installé les deux versions et ce sur deux versions de zwii et vient tout juste de remarquer un " ultime " désagrément " dans la V2;

 

 

 ==>  

 

Je t'invite si tu le veux à regarder depuis ce message là, tout ce que le membre à reporter comme désagréments chez lui et les solutions ( testée avant d'être proposées comme fonctionnelles ) au me membre qui de suite les as mise en application avant de venir y rapporter dans ce forum de support à mon plugin si cela marchait où pas, et que tu positif pour le moment.

 

Au besoin je peux réaliser une vidéo depuis une install de la version de zwii en 8.2.5 chez Free ou chez 1&1 pour montrer que l'incorporation se passe sans problèmes et aussi montrer au passage sur cette vidéo comment créer le premier message ( d'ailleurs je ferais cette vidéo et l'ajouterai là où l'on télécharge les deux versions de mon plugin, ainsi un visuel sera mieux en plus de cette phrase pourtant bien indiquée dans l'installation des deux plugs )
 

Citation

 

IMPORTANT:

2° Pour activer votre livre d'or vous devez impérativement quand vous crée sa page y inclure un premier message en cliquant sur la roue crantée de réglage du module et " + Nouveau message "

 

 

je m'y mettrai des demain matin ¬¬

Modifié par Invité
un lien et une citation pour la demande par précision

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bon j’avoue ne pas avoir tout lu ... je suis un peu fainéant, et je sors également d’une grosse journée d’astreinte avec 14h de travail continue ... 

@Roger nounours est ce que tu as pensé à faire comme sur la tchatbox de Simon ? Je sais pas si tu te rappel mais on avait modifier les textes d’emoticon en HTML ... je pense qu’il faut partir de la même base ;) si tu veux je peu essayé de regarder un peu ça demain si je ne suis pas appelé d’astreinte

Modifié par micka260

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Roger nounours Et le seul aussi à avoir une connexion internet qui se coupe toutes les cinq minutes. :naughty:

 

Je réponds donc ce matin, puisque je n'ai pas pu le faire hier soir : quand je dis que j'ai suivi les instructions, ce n'est pas la peine de me les rappeler en caractères gras, je les ai vues. Je suis donc le seul pour qui ça ne fonctionne pas. Si je peux refaire des tests et qu'il sont à nouveau négatifs, je t'enverrai un lien.

 

Tests négatifs. Lien en MP.

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
Il y a 16 heures, micka260 a dit :

Bon j’avoue ne pas avoir tout lu ... je suis un peu fainéant, et je sors également d’une grosse journée d’astreinte avec 14h de travail continue ... 

@Roger nounours est ce que tu as pensé à faire comme sur la tchatbox de Simon ? Je sais pas si tu te rappel mais on avait modifier les textes d’emoticon en HTML ... je pense qu’il faut partir de la même base ;) si tu veux je peu essayé de regarder un peu ça demain si je ne suis pas appelé d’astreinte

 

Ce n'est pas le même problème Mickaël, là ça fonctionne nickel c'est juste le fait que je veux que dans mon plug un visiteur/membre ai les me droits d'utiliser le tinymce dans son interface complète comme c'est le cas pour un modo/admin d'un site construit avec zwii..

Vraiment rien à voir avec l'ancien sujet concernant le plugin de Simon ( pour info, Simon ne fait plus parti des membres :cold_sweat: )

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
Il y a 9 heures, PeterRabbit a dit :

Je suis donc le seul pour qui ça ne fonctionne pas.

 Je ne vois pas de où tu tire cette affirmation là car tu es bien le seul à ne pas avoir réussi à l'installer mon plugin.

Christian lui une fois son installation faite à demandé des améliorations, illico réalisées et validées par celui ci. >:(

 

J'ai donc reçu ton lien et vais voir chez toi pour les tests.

Modifié par Invité

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
à l’instant, Roger nounours a dit :

 Je ne vois pas de où tu tire cette affirmation là car tu es bien le seul à ne pas avoir réussi à l'installer mon plugin.

Christian lui une fois son installation faite à demandé des améliorations, illico réalisées et validées par celui ci. >:(

 

Lui c'est lui, moi c'est moi.

Ceci dit, je ne vois pas non plus d'où tu tires cette affirmation que je suis bien le seul à ne pas avoir réussi à installer ton plugin.

Le plus drôle serait en effet que je n'aie pas su appliquer les instructions.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
Il y a 9 heures, PeterRabbit a dit :

Tests négatifs. Lien en MP.

 de même que pour moi avec une interrogation :

 

Sur le lien que tu m'as donné, j'ai donc crée une page nommée " livre2 ", or sans créer quoi que ce soit, aucune alerte au minimum si je ne met pas une message dans le livre2....en cliquant sur ton bouton poster mon message...

 

Aucune modif non plus appliquées au regard de ce que je t'ai donné comme explication ici

Il y a 21 heures, Roger nounours a dit :

 

peu de gens utilisent cette résolution mais par contre étant donné que j'ai fourni dans les dossiers du plugin deux fichiers ( add.css et edit.css ) pour garder cet agencement qui me plais bien, il suffira alors soit à l'utilisateur de par lui même d'aller modifier l'un des deux css fourni ( en l’occurrence add.css ) et d'y ajouter ceci :

 

Suite aux remarques que tu m'a signalé par mp, effectivement l'installation du pligin n'est pas térs clair dans le tuto, j'ai donc mis à jours celui ci et y ai précisé ceci :

Citation

INSTALLATION

1° Dézippez le dossier nommé livredor.zip  et envoyer son dossier  " livredor " dans le dossier module à la racine de votre Zwicms ( lle dossier " livredor" contenu dans le zip " livredor" doit se trouver dans le dossier " module " à la base de votre zwiicms sur votre ftp, dossier juste entre celui nommé core & celui nommé site ).

N'ayant pas eu le temps hier soir d'uploader vidéo et script mis à jour, je le fais donc maintenant, je pense donc que l'isntall foire chez toi soit à cause de mes mauvaises explication sur l'install, soit à cause de pingfile ( auquel cas je préciserai qu'il ne sera pas possible d'installer chez ce fournisseur mon livre d'or en V2, tout de me bizarre vu que sa version pour une 810 de zwii fonctionnait chez ce fournisseur là );

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité

Je clos mon sujet car j'ai bien peur  de ne pas obtenir la réponse attendue pour celui ci, donc une visiteur ou un membre inscrit dans un site web construit avec le cms zwii devront se contenter d'une simple boite de texte pour laisser un message dans un livre d'or et seuls donc modérateur et administrateur pourront eux bénéficier d'un éditeur de texte complet intégré au cms pour poster leur messages.

 

Je remercie ceux qui auront essayé d'apporter leur aide ( peterRabbit & micka260 ) de même que ceux qui m'ont prévenu par d'autres moyens qu'ils ne pensaient pas m'être d'une grande aide dans ce cas bien précis.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
à l’instant, Roger nounours a dit :

je pense donc que l'isntall foire chez toi soit à cause de mes mauvaises explication sur l'install

 

ldo.jpg.4c2ef9222622d423e800cd4126a10126.jpg

 

PF a toujours fait un bon punching-ball. :| 

 

PS : Je n'avais pas vu ta réponse. Les déconnexions m'empêchent de suivre. @Rémi devrait savoir : c'est peut-être en relation avec sa modification de la façon d'appeler TinyMCE.

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Roger nounours N'abandonne pas ! on va y arrivé :)

Je ne fais qu'un passage rapide aujourd'hui car j'ai encore fais une grosse journée de taff et je suis à 54h de travail donc je t'avoue que j'ai plus envie de me reposer que de bosser ...

 

Essais de faire un tour sur les scripts de livre d'or disponible sur ce site :

http://scripts.toucharger.com/scripts/php/livre-d-or/

 

Tu veux que ce livre d'or soit uniquement sur une page dédier au livre d'or ?

 

On va reprendre du début :P (comme à mon habitude) qu'elle est ton objectif, quel est le résultat attendu ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Invité
Il y a 1 heure, micka260 a dit :

Tu veux que ce livre d'or soit uniquement sur une page dédier au livre d'or ?

 

Mickael, je possède un sacré paquets ( 5 je crois de script de livre d'or et qui sont installable sur les zwii depuis les versions V7.5;

 

Je ne veux justement pas implémenter dans le zwii un script extérieur mais utiliser ( ce qui est impossible avec les scripts extérieurs qu'ils soient hébergés ou non ) le style du zwii, c'est à dire son css et la mise en forme du cms.

C'est pour cela que je pars d'un module de zwii car ils sont eux paramétrés pour fonctionner avec l'interface du zwii ainsi qu'avec son thème ;)

 

Il y a 1 heure, micka260 a dit :

On va reprendre du début :P (comme à mon habitude) qu'elle est ton objectif, quel est le résultat attendu ?

 

Là c'est très facile à comprendre et expliquer, l'objectif est celui ci et il est déjà réalisé hahahahahha : Faire un plugin livre d'or pour le zwii et aussi téléchargeable depuis quelque jours ici;

 

Mon objectif est UNIQUE pour ce plugin fonctionnel à 100%  c'est uniquement ce qui est expliqué ci dessous :

 

Comme un visiteur peut poster des messages dans ce livre d'or, j'aimerais tout simplement qu'il bénéficie lui aussi pour rédiger son message de la me interface du tinymce que peut bénéficier un modérateur ou un administrateur  quand lui poste un message dans le me livre d'or;

 

d'ailleurs j'ai remarqué une aberration dans zwii : le groupe nommé Membre !!!!, bin c'est bien qu'un membre qui est enregistré comme un modérateur ou un administrateur dans un zwii cms puisse voir les pages qui sont autorisées, mais ce me membre accueilli les bras ouverts par l'admin d'un zwii bin lui non plus n'a pas le droit à bénéficier s'il redige un message dans le livre d'or de la me interface complète du tinymce!!!!

 

Donc mon objectif et faire en sorte que " TOUT LE MONDE PUISSENT UTILISER DANS UN ZWII TINYMCE  " ce qui n'est pas le cas alors que les autorisation d'ajouts pour poster leur sont accordé à mes visiteurs et mes membres....

 

class livredor3 extends common {

    public static $actions = [
        'add' => self::GROUP_VISITOR,
        'comment' => self::GROUP_MODERATOR,
        'commentDelete' => self::GROUP_MODERATOR,
        'config' => self::GROUP_MODERATOR,
        'delete' => self::GROUP_MODERATOR,
        'edit' => self::GROUP_VISITOR,
        'index' => self::GROUP_VISITOR
    ];

 

add il peut poster le visiteur et le membre inscrit

edit il peut aller donc sur la page ou on édite les messages et le membre inscrit

 

Mais les deux sont des parias car ils n'ont droit qu'a un simple textarea pour écrire leur textes alors que le modérateur ou l'admin lui sont des rois car eux ils ont droit au tinymce dans toute sa splendeur...

 

Merci en tout cas @micka260 pour ton message de soutien, et je pense qu'avec ce que je viens de t'expliquer ce n'est pas un livre d'or que je cherche mais faire profiter de l'éditeur du zwii cms à tout mes utilisateurs et pas seulement à une catégorie d'entre eux ;)

 

 

Modifié par Invité

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à cette question…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


  • Contenu similaire

    • Par Marie-Anne
      😂😂 Hello les amis traqueurs de boulettes 😂😂
       J'ai une petite erreur avec le validateur HTML 5  du W3C.
      Lien : https://validator.w3.org/nu/?showsource=yes&doc=https%3A%2F%2Fwww.lafermedupaquisfleury.fr%2F
       
      Ce n'est pas la mort hein 🧐
      Juste un petit espace qui a sauté
      <span id="footerDisplayVersion"class="displayNone"> Voili voilou, au passage la fonction ajouter du code dans le head ou body est top 😍 
    • Par roger
      Un autre "inconvénient" pour moi: Avant nous n'étiuons pas obligé de devoir retapper un mot de passe pour changer simplement nom et prénom dans la config de l'utilisateur d'un zwii, aujourd'hui ce n'est plus le cas car l'on se retrouve alors avec une page d'erreur si on veut le faire depuis son propre compte
       
      identité à la création du site

       
      nouvelle identité désirée

       
      au clic sur le bouton Enregistrer

       
       
    • Par roger
      Dans le gestionnaire d'image du Zwii j'ai crée un dossier pour y importer des images (soit par glisser/déposer soit en écrivant l'URL de l'image à importer)
       
      ✅ Seule la fonction glisser/déposer (ou choisir le fichier sur le pc) fait le job;
      ❗  Si je désire importer une image depuis une URL, cette fonction ne marche pas du tout:
       
      Conditions de téléchargement d'une image depuis la fonction prévue pour dans le RFM:
       - que ce soit une images téléchargeable depuis une URL en http ou Https libre de droit (lien de téléchargement direct de l'image)
       - une image que j'héberge moi même et qui peut être téléchargée par d'autre cms  n'a pas plus de succés si je veux la télécharger par son lien direct;
       
      En rafraîchissant la page ou en utilisant un autre navigateur que le mien au cas ou, rien n'y fait le Responsive file manager refuse de télécharger des images depuis une URL.
       
      📊 le dossier sur ma version officielle:

       
      🙂 Là où ça marche nickel:

       
      😞 l'endroit où j'entre l'URL directe de l'image sur son serveur et où ça ne fonctionne pas:

       
      Une idée pour résoudre ce problème ou bien la fonction n'est plus compatible à ce jour dans le zwii V9.1.xx alors que celle ci fonctionnait avant dans les anciennes versions.
       
      💡 Pour info, j'ai juste découvert ce "petit inconvénient" en voulant télécharger une image libre de droit sur un site de partage (habituellement je dépose les images directement dans le rfm) , et donc par acquis de conscience j'ai aussi vérifier sur une version 9107 la me fonction, pareil impossible d'importer une image depuis une URL, donc c'est un "petit inconvénient" non découvert malgré les nombreux tests effectués avant la sortie de la version officielle précédente.
       
       
       
       
       
×
×
  • Créer...