Aller au contenu
Support de Zwii
  • 0
augras

[RESOLU]custom.css réinitialisé

Question

Bonjour,

En début de semaine j'ai constaté que sur un site le custom.css était revenu à son contenu par défaut !

Comme la semaine a été très chargée je viens juste de restaurer le fichier et tout est rentré dans l'ordre.

Pas de connexions en admin au site avec mauvaises manipulations à la clé depuis pas mal de temps, le fichier en lui-même a été modifié la dernière fois en décembre.

Mystère !

Modifié par augras

Partager ce message


Lien à poster
Partager sur d’autres sites

22 réponses à cette question

Messages recommandés

  • 0
Il y a 4 heures, augras a dit :

Bonjour,

En début de semaine j'ai constaté que sur un site le custom.css était revenu à son contenu par défaut !

Comme la semaine a été très chargée je viens juste de restaurer le fichier et tout est rentré dans l'ordre.

Pas de connexions en admin au site avec mauvaises manipulations à la clé depuis pas mal de temps, le fichier en lui-même a été modifié la dernière fois en décembre.

Mystère !

Bonsoir,

Comme il n'existe pas de réinitialisation dans le CMS, c'est que le fichier a été effacé ou bien qu'à un moment il n'a pas été lu et donc régénéré. Tout cela est très étrange ! Première fois que cela survient, il me semble.

À suivre...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Et bien je constate à l'instant que le custom.css a été réinitialisé hier soir à 22h15 !

Bizarrement le fichier de log ne remonte que jusqu'à hier 23h30 et core.json ainsi que core.back.json datent de hier à 00h38.

Je ne me suis pas connecté au site depuis plusieurs jours.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 7 heures, augras a dit :

Et bien je constate à l'instant que le custom.css a été réinitialisé hier soir à 22h15 !

Bizarrement le fichier de log ne remonte que jusqu'à hier 23h30 et core.json ainsi que core.back.json datent de hier à 00h38.

Je ne me suis pas connecté au site depuis plusieurs jours.

Voilà qui est vraiment bizarre.  En attendant de trouver une solution, et surtout une explication, tu devrais changer les droits et supprimer les permissions d’écriture.  Ton htaccess est bon dans le dossier ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Le .htaccess est bon pour moi

# Bloque l'accès aux données
<FilesMatch ".(htaccess|json|log)$">
	Order deny,allow
	Deny from all
</FilesMatch>

Par contre si je le comprends correctement les .css ne sont pas protégés.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour @augras,

 

Et non, pas possible ! si on les ajoute dans le htaccess ils ne seront plus envoyés au client et suite à une requête on obtiendra une page sans styles.

 

Bonne journée

 

Sylvain

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 16 heures, augras a dit :

Peut-être mettre en place le système custom.back.css ?

Toujours pas compris ce qui déclenche ça !

J'avoue mon non plus..

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je viens de recevoir un message pour un autre site m'indiquant que j'avais demandé la réinitialisation de mon mot de passe... ce qui n'est absolument pas le cas. Et le custom.css est maintenant également réinitialisé sur ce site !

Est-ce que lorsque l'on clique sur Mot de passe oublié il serait possible de mettre la captcha ?

Manifestement je suis attaqué ! Pas trop grave pour le moment...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 18 minutes, augras a dit :

Je viens de recevoir un message pour un autre site m'indiquant que j'avais demandé la réinitialisation de mon mot de passe... ce qui n'est absolument pas le cas. Et le custom.css est maintenant également réinitialisé sur ce site !

Est-ce que lorsque l'on clique sur Mot de passe oublié il serait possible de mettre la captcha ?

Manifestement je suis attaqué ! Pas trop grave pour le moment...

C'est une piste sérieuse à suivre, quelle est l'adresse de ton site ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

augras.eu/zwii91dev59 :) c'est vieux ça :) 

 

Je crois que tu as trouvé un bug,  regarde ton site par ftp.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 3 minutes, Fred a dit :

augras.eu/zwii91dev59 🙂 c'est vieux ça 🙂

Le site est dans la dernière version mais quand j'ai commencé à publier les tests c'était avec cette version !

 

Sur le ftp je vois que le custom.css a été modifié à 19h14 !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
à l’instant, augras a dit :

Sur le ftp je vois que le custom.css a été modifié à 19h14 !

Ben voilà :) c'est une faille csrf , j'aurais dû la voir avant  !

J'avoue avoir oublié le bouton de réinitialisation. Maintenant tu es certain que quelqu'un joue avec tes sites et ce n'est pas moi.

La faille sera corrigée dans 10.4, je suis sur le correctif.

Bien vu Philippe !

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 1 minute, augras a dit :

J'ai subi plutôt que vu venir !

Mais tu l'as signalé ! Et c'est ce qui compte.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 13 minutes, augras a dit :

sinon j'aurai pu jouer longtemps à remettre mes custom.css !

Ben carrément !
La faille touche potentiellement la réinitialisation du thème admin, du custom et du theme :

image.png.77497874ec1a2209385878c29785d158.png

 

Désormais, la clé csrf protège les trois boutons, tu as été victime de la ligne unlink.

 

10.4 est actualisée, tu peux mettre à jour ton site avec, ça calmera les amusettes.

 

Tu vas pouvoir  éditer le titre de ton sujet :) 

 

Bonnes vacances ;) 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Avec un camping car, ça ne te dérange pas la conduite en montagne ?

J'ai des souvenirs de la route entre Cahors et ST Cirq la Popie le long du Lot, à flanc de falaise, les conducteurs galéraient bien :

image.png.b3a07bac566341beb08c293a696bfd24.png

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

On n'est pas loin de la route que tu à mise en photo et on l'a emprunté cet été : dis toi bien qu'il y a des bus qui y passent tous les jours alors un camping-car... mais on peut se faire des frayeurs tout de même. Il y a des routes de montagnes très escarpées où ça peut être chaud, des fois ça passe au cm ! J'ai souvenir de la route des neiges en Norvège où on a récolté plusieurs litres d'huile tellement madame serrait les fesses !

Départ pour l'aventure après le repas.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...