Aller au contenu
Support de Zwii
  • 0
Gilux

v10.3.13 .htaccess data cause erreur 500

Question

Bonjour,

Le fichier .htaccess nouvellement rédigé du dossier data n'est plus compatible avec free.fr et cause une erreur 500

Pour le rendre à nouveau universel il devrait contenir ceci :

<Files ~ "\.(htaccess|json|log)$">
Deny from all
</Files>

Pour versions d'Apache < 2.4

  • Merci 2

Partager ce message


Lien à poster
Partager sur d’autres sites

13 réponses à cette question

Messages recommandés

  • 0

Je confirme ce fait et donne mon astuce pour le contourner

 

Volontairement j'ai envoyé la dernière version officielle dans un dossier nommé "Z10-3-18" sur mon espace free.... et bien entendu j'ai plusieures versions du cms chez ce fournisseur pour effectuer les tests de toute versions Zwii.

 

Premier point, les htaccess écrits par la dernière mouture et qui ne fonctionne pas:

 

A la racine du zwii:

# Active la compression GZIP - option Apache
<IfModule mod_gzip.c>
    mod_gzip_on Yes
    mod_gzip_dechunk Yes
    mod_gzip_item_include file \.(html?|txt|css|js|php|pl)$
    mod_gzip_item_include handler ^cgi-script$
    mod_gzip_item_include mime ^text\.*
    mod_gzip_item_include mime ^application/x-javascript.*
    mod_gzip_item_exclude mime ^image\.*
    mod_gzip_item_exclude rspheader ^Content-Encoding:.*gzip.*
</IfModule>

# Active la compression DEFLATE - option Apache
<IfModule mod_deflate.c>
    AddOutputFilterByType DEFLATE text/plain
    AddOutputFilterByType DEFLATE text/html
    AddOutputFilterByType DEFLATE text/xml
    AddOutputFilterByType DEFLATE text/shtml
    AddOutputFilterByType DEFLATE text/css
    AddOutputFilterByType DEFLATE application/xml
    AddOutputFilterByType DEFLATE application/xhtml+xml
    AddOutputFilterByType DEFLATE application/rss+xml
    AddOutputFilterByType DEFLATE application/javascript
    AddOutputFilterByType DEFLATE application/x-javascript
</IfModule> 

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Désactive l'option de substitution automatique
<IfModule mod_negotiation.c>
    Options -MultiViews
</IfModule>

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

Dans le dossier data:

# Bloque l'accès aux données
<FilesMatch ".(htaccess|json|log)$">
	Order deny,allow
	Deny from all
</FilesMatch>

en image et bien c'est logique:

free.thumb.png.534371a907b38406da970f29347cdbae.png

 

j'ai donc en ligne une ancienne version (10304) qui fonctionne....et bien pas compliqué donc la comparaison des htaccess...

 

à la racine du zwii:

<ifDefine Free>
 PHP56 1
</ifDefine>
<Files ~ "\.(htaccess|json|log)$">
Deny from all
</Files>

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

dans le dossier data:

<Files ~ "\.(htaccess|json|log)$">
Deny from all
</Files>

free1.png.29b1b91e0831859bc58553a951e21261.png

 

Donc fort logiquement j'ai remplacé sur la dernière mouture les deux fichiers htaccess non fonctionnels par ceux de ma version qui elle marche parfaitement chez free, le résultat est cette fois ci une erreur page 404 qui est pour moi habituelle car il manque un ? dans l'adresse où l'on paramètre et installe le zwii.... le fichier install qui doit être recherché mais sans la redirection d'url que Free ne permet toujours pas!!!!

free2.png.a2b5eab2ec98e4c67f90754bcb44ff27.png

Ajoutez simplement le ? avant install comme ceci : /?install.php et roule ma poule (ne pas oublier comme dab depuis des années de se rendre ensuite dans la config du zwii pour y désactiver la redirection d'url par le même procédé afin de finaliser l'installation du tout dernier Zwii en date chez ce fournisseur détestable qu'est Free et ses multiples restrictions...

free3.png.e602ace7d5ff6afeaf5be1a6c001c203.png

 

Enfin je peux installer la dernière mouture du Zwii....

free4.png.8a421b6cdb4ee8a4c46104b1561deca5.png

 

Le résulta le voilou.....

free5.thumb.png.e7a05c6b58955ac92ce00441eef84d99.png

 

Site visible à cette adresse ==>  http://lechti64.free.fr/Z10-3-18/?accueil

 

Modifié par roger
  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Ce n'est pas un BUG mais une incompatibilité de certains serveurs Free !

Sujet déplacé.

Il y a 18 heures, Gilux a dit :

Pour le rendre à nouveau universel il devrait contenir ceci :


<Files ~ "\.(htaccess|json|log)$">
Deny from all
</Files>

Pour versions d'Apache < 2.4

Tu es certain de ça ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 2 heures, Fred a dit :

Tu es certain de ça ?

 

Oui, à 100%, et comme je le signale par ailleurs, c'est mieux de mettre cette instruction dans le .htaccess à la racine, permettant de protéger tous les .htaccess du site, dont celui-ci, ce qui n'est actuellement pas le cas, et ça protège aussi du même coup tous les .json du site, pas seulement ceux du data, mais aussi les inc.json de vendor qui appellent des fichiers executables

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 11 heures, Gilux a dit :

permettant de protéger tous les .htaccess du site, dont celui-ci, ce qui n'est actuellement pas le cas,

Tu l'affirmes sans le démontrer.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Pour Apache 2.2

<Files ~ "\.(htaccess|json|log)$">
	Order deny,allow
	Deny from all
</Files>

 

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 31 minutes, Fred a dit :

Pour Apache 2.2


<Files ~ "\.(htaccess|json|log)$">
	Order deny,allow
	Deny from all
</Files>

 

 

Super ! Merci @Fred

ça permet de maintenir la compatibilité de ZwiiCMS avec l'hébergeur gratuit free.fr 😉

Order deny, allow n'est pas utile dans le sens ou il n'y a qu'une seule instruction, et donc pas d'ordre à établir

 

Le 13/01/2021 à 09:57, Fred a dit :

Tu l'affirmes sans le démontrer.

 

Je ne pensais pas que c'était utile, ce que j'évoque est simple à concevoir par ceux qui, comme toi, connaissent le fonctionnement de ce fichier spécifique à Apache, mais c'est sans grande importance vu que l'accès aux fichiers .htaccess est protégé par défaut par la configuration d'Apache, pour la version 2.4 :

<FilesMatch "^\.ht">
	Require all denied
</FilesMatch>

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a une heure, Fred a dit :

Pour Apache 2.2


<Files ~ "\.(htaccess|json|log)$">
	Order deny,allow
	Deny from all
</Files>

 

Je confirme (et après avoir recopier dans un premier temps le code de gilux sur les tests d'une V10400  son code qui fonctionne sur le même serveur Free chez moi une 10.3.13 et là pour cette version 10400 cela ne marchait pas)

 

En utilisant le code que fourni Fred pour une version apache 2.2 et bien la future mouture de zwii en 10.4.013 que j'ai en ligne marche correctement (alors qu'avec l'autre htaccess c'était une véritable catastrophe au point que j'avais supprimé totalement le htaccess pour pouvoir installer cette version chez Free)

 

@Fred je continue les tests de ce matin pour FREE et te les rapporte comme actuellement par mp.

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Citation

Je confirme (et après avoir recopier dans un premier temps le code de gilux sur les tests d'une V10400  son code qui fonctionne sur le même serveur Free chez moi une 10.3.13 et là pour cette version 10400 cela ne marchait pas)

 

En utilisant le code que fourni Fred pour une version apache 2.2 et bien la future mouture de zwii en 10.4.013 que j'ai en ligne marche correctement (alors qu'avec l'autre htaccess c'était une véritable catastrophe au point que j'avais supprimé totalement le htaccess pour pouvoir installer cette version chez Free)

 

Pour information, un fichier .htaccess contient des instructions visant à modifier le comportement du serveur Apache, pas du site web, donc ceci, ci-dessus, est juste impossible, dans le cas présent si la protection des données est effective avec une version du CMS, elle l’est pour toutes les versions, d’autant plus que le code est exactement celui que j’ai proposé, je rappelle que Order deny, allow n'est pas utile dans le sens ou il n'y a qu'une seule instruction, et donc pas d'ordre à établir entre refus et permissions, cet ordre est à préciser lorsqu’il y a au moins 2 instructions, comme :

 

Order Deny,Allow

Deny from all

Allow from site-web.com

Allow from 186.192.0.0/11

 

Le fait donc, dans le cas précis de la protection des données du dossier data, qu’il y ait ou qu’il n’y ait pas d’ordre donné na strictement aucune incidence sur l’unique instruction passée au serveur.

  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 3 heures, Gilux a dit :

Pour information, un fichier .htaccess contient des instructions visant à modifier le comportement du serveur Apache, pas du site web, donc ceci, ci-dessus, est juste impossible, dans le cas présent si la protection des données est effective avec une version du CMS, elle l’est pour toutes les versions,

Comme tu me cite et bien moi JE T'AFFIRME que le code du .htaccess qui se trouve sur ma version chez Free (la 10.3.13 que j'ai mis dans un dossier Z10-3-18)

==> http://lechti64.free.fr/Z10-3-18/

ne fonctionne absolument pas avec une version 10.4.013 elle dans un dossier nommé Z10400 chez free...

==> http://lechti64.free.fr/Z10400/

Cette version 10400 est activée là bas pour vérifier des tests multilangues.

 

Les deux versions sont sur le même serveur et il m'a été impossible de faire fonctionner la 14000 avec simplement la copie du .htaccess de la 10313 !!!

 

htaccess de la 10.3.13:

<ifDefine Free>
 PHP56 1
</ifDefine>
<Files ~ "\.(htaccess|json|log)$">
Deny from all
</Files>

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

 

htacess de la 10;4.0013:

<Files ~ "\.(htaccess|json|log)$">
	Order deny,allow
	Deny from all
</Files>

Une capture d'écran de mon filezilla te montrera que mes versions sont bien sur le me serveur chez Free

fresh.thumb.png.7009c05b31704920145c181ddd48911d.png

 

 

 

Quand j'affirme quelque chose dans mes remontées et que l'on me dit "impossible" et bien je le prouve, Free est pour ma part considéré comme un registar merdique et je n'ai chez eux que des comptes pour tester gratos....bin vi quand on est débrouillard on arrive à obtenir ce que l'on veut et Zwii demande à être testé si possible chezz la plus grosse majorités des fournisseurs d’accès web.

 

Au cas où il faudrait justifier que j'ai bien un compte chez Free, juste un tiot paramètre de mes comptes dans mon Filezilla....

fresh1.png.d2e279b88cfd7c49f212739f9bb6254c.png

 

J'espère que cette mis au point sur ce que j'affirme ne pourra souffrir d'autres contestations....je n'ai pas la science infuse mais je suis d'une honnêteté sans faille, sinon je la ferme tout simplement pour ne pas "faire mousser" un soi disant égo que l'on pourrait me prêter...

 

@Gilux juste pour ton info, je teste justement à la demande de  @Fred les versions ZwiiCMS chez Free et donc c'est ainsi que je lui fais mes remontées à la demande pour vérifier si tel ou tel "truc" marche. je faisais aussi la même chose à la création du cms pour Rémi, et crois moi on en a essayé un paquet de htaccess chez free, tous avec plus ou moins de succès.

Roger

Modifié par roger

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

roger, c'est de la mauvaise foi caractérisée, je maintiens que ce que tu prétends est impossible, mais je ne vais pas épiloguer davantage, l'important est que le CMS reste compatible avec tous les hébergeurs, dont free.fr, et que la réécriture de ce fichier soit la bonne !

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Le problème est que vous avez tous les deux raisons, il est évident que Free ne gère pas de manière identique la configuration de ses baies de serveur et que vous soyez sur une baie plutôt qu'une autre change la configuration.

 

De plus je trouve stérile de perdre de l'énergie pour cet hébergeur qui apporte bien plus de contraintes que d'avantages. Un hébergement sérieux compte dans les 15€ en prix de base, domaine compris, à un moment si on publie on le fait correctement.

  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 23 heures, Fred a dit :

il est évident que Free ne gère pas de manière identique la configuration de ses baies de serveur et que vous soyez sur une baie plutôt qu'une autre change la configuration.

 

On a effectivement constaté que certaines librairies, dont notamment MB, étaient présentes sur certains serveurs Free.fr et pas sur d’autres, ceci n’ayant pas d’effet sur la protection de fichiers ou de dossiers

Deny et allow sont natif d’Apache, ils ne dépendent pas d’une librairie, donc quels que soient les paramétrages du serveur, avec ou sans certaines bibliothèques, l’ordre passé au serveur sera interprété, et ceci, évidemment, de façon totalement indépendante de la version du CMS installée sur ce serveur, vu qu’à ce sujet précis il ne peut être fait aucune relation d’interdépendance entre le code du CMS (ou de tout autre site web) et celui d’Apache

 

Modifié par Gilux
MB pas MD

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à cette question…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...