Aller au contenu
Support de Zwii

Messages recommandés

Bonjour à tous,

 

Zwii 10.4.00 rentre en phase de test. Cette version a été concoctée par @Fred avec l'aide de votre serviteur.

 

https://github.com/fredtempez/ZwiiCMS/archive/10400.zip

 

Pensez à re-télécharger cette archive avant tout nouveau tests !

 

La 10.4.00 apporte des nouveautés dans la gestion des utilisateurs et dans le module de blog.

 

      Gestion des utilisateurs

  1. Importation de nouveaux utilisateurs par fichier csv (transférable par Filemanager), avec possibilité de notification par courriel aux nouveaux utilisateurs,
  2. Création d'un nouveau paramètre utilisateur : le pseudo,
  3. Choix de la signature des articles et des commentaires de blog par identifiant, pseudo, prénom nom ou nom prénom.

Module de blog

  1. Options de publication d'un article : les droits d'édition et de suppression peuvent être réglés sur 'Tous les groupes', 'Groupe du propriétaire' ou 'Propriétaire',
  2. Commentaires d'un article : choix du nombre maximal de caractères des commentaires, approbation possible du commentaire par un modérateur,
  3. Configuration du module : la gestion des commentaires se fait par article, un affichage renseigne sur le nombre de commentaires publiés/à approuver,
  4. Edition d'un commentaire : une mise en forme du commentaire est possible.
  5. Gestion des commentaires : on peut approuver ou rejeter un commentaire, le supprimer, ou supprimer tous les commentaires d'un article.

Nous vous remercions par avance des tests pointus que vous allez réaliser. Pour faire remonter les bugs ou améliorations possibles soyez précis dans leur description.

A bientôt donc

Sylvain

Modifié par sylvainlelievre
  • Merci 2

Partager ce message


Lien à poster
Partager sur d’autres sites

J'y go de suite, la procédure de remontée se fera comme dab....  @sylvainlelievre j'ai eu l'occase de faire connaissance avec 400, donc remontées seront faites de ma part comme spécifiées par @Fred pour certaines choses. 😉

 

Pour le reste se sera ici bien entendu. 😀

Roger

Partager ce message


Lien à poster
Partager sur d’autres sites

@sylvainlelievre a passé beaucoup de temps sur cette version et son débogage, c'était un chouette travail d'équipe.

 

D'ailleurs je viens de corriger un dernier petit point de détail. Merci de télécharger la version du dernier commit 0562fbe

 

Bon we.

  • Merci 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour

je viens de télécharger la version 10.4.00 , et je n'ai plus dans le pied de page le raccourcis de connexion une fois l 'installation faite

je suis obligé de passer par son lien  /?user/login/

suis-je le seul ?

 

image.png.5759d1c41d4e265f937f3aa611389178.png

 

pourtant le lien de connexion est coché

 

image.png.f9843a4565ddef4cf69c9f85d9cb6ea9.png

Modifié par omega

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 2 heures, omega a dit :

Bonjour

je viens de télécharger la version 10.4.00 , et je n'ai plus dans le pied de page le raccourcis de connexion une fois l 'installation faite

je suis obligé de passer par son lien  /?user/login/

suis-je le seul ?

 

image.png.5759d1c41d4e265f937f3aa611389178.png

 

pourtant le lien de connexion est coché

 

image.png.f9843a4565ddef4cf69c9f85d9cb6ea9.png

CTRL-F5 ?

 

Le lien de connexion est une icône désormais.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Importation de fichier Csv  essayé (ras)

création manuel d'un nouvel utilisateur essayé

Question:

le nouvel utilisateur reçoit bien le message ci dessous , mais comment fait il pour se connecter à son compte , ne connaissant pas son mot de passe ?

Bruno

 

 

image.png.b62c801e485a3525b9cfd7c72e0d87a7.png

Modifié par omega
  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, omega a dit :

Importation de fichier Csv  essayé (ras)

création manuel d'un nouvel utilisateur essayé

Question:

le nouvel utilisateur reçoit bien le message ci dessous , mais comment tait il pour se connecter à son compte , ne connaissant pas son mot de passe ?

Bruno

 

 

image.png.b62c801e485a3525b9cfd7c72e0d87a7.png

En cliquant sur mot de passe oublié. 
On va le préciser dans le corps du mail. 

  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Je me disais aussi. C'est précisé dans le corps du mail reçu par le nouvel inscrit :

'<strong>Identifiant du compte :</strong> ' . $userId . '<br>' .
'<small>Un mot de passe provisoire vous été attribué, à la première connexion cliquez sur Mot de passe Oublié.</small>'

Partager ce message


Lien à poster
Partager sur d’autres sites

j'ai créer plusieurs utilisateurs , et je ne reçois que le message ci dessous en aucun moment j 'ai l 'invite "Un mot de passe provisoire vous été attribué, à la première connexion cliquez sur Mot de passe Oublié"

en cliquant sur le lien "votre site en quelque clic!" du message ci dessous je tombe sur la page de la création du site

il serait plus judicieux de tomber sur la page mot de passe oublier/user/forgot/accueil

je n 'ai peut-être pas  tout compris ?

 

il y a 44 minutes, Fred a dit :

image.png.b62c801e485a3525b9cfd7c72e0d87a7.png

 

Partager ce message


Lien à poster
Partager sur d’autres sites

L'inscrit reçoit ce message :

image.png.9da18a6c108f5c33bd495dc3f65aa45e.png

Tout est donc ok. Il manque juste l'enveloppe plutôt que le check dans le tableau de confirmation.

check : compte créé

Bulle : mail envoyé

croix : compte non créé (doublon d'id)

 

C'est corrigé, il faudra télécharger le correctif :

 

image.thumb.png.edf20956d6f2e5044192869ee7a394c6.png

 

Partager ce message


Lien à poster
Partager sur d’autres sites

je viens d 'installer la version 10400 de dix minutes , j 'ai bien reçu le message de l 'installation du site qui  s'est bien déroulé , j'ai créer un nouvel utilisateur , mais je ne reçois plus (en tant que nouvel utilisateur) le message de l ' Admin

bizarre .... ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 8 minutes, omega a dit :

je viens d 'installer la version 10400 de dix minutes , j 'ai bien reçu le message de l 'installation du site qui  s'est bien déroulé , j'ai créer un nouvel utilisateur , mais je ne reçois plus (en tant que nouvel utilisateur) le message de l ' Admin

bizarre .... ?

Le message est un message qui apparaît lors d'un import lorsque la notification est cochée et que le mail du compte est actif.

Partager ce message


Lien à poster
Partager sur d’autres sites

tu veux dire qu'il n 'y plus de message envoyé au nouvel utilisateur  lorsque l 'admin crée un nouvel utilisateur manuellement ?

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Citation

Importation de nouveaux utilisateurs par fichier csv (transférable par Filemanager), avec possibilité de notification par courriel aux nouveaux utilisateurs,

par erreur j 'ai omis dans le fichier Csv de renseigner le groupe , le nouvel utilisateur dans ce cas aurait tout les droits , c'est peut être dangereux ?

voir utilisateur top ci dessous qui n'est ni éditeur , ni administrateur ni membre.

 

image.png.331431b8b0085d9e8266b604a0c8f3d3.png

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonsoir @omega

Si mais il faut cocher à  la création du compte la case qui permet d'envoyer und notification au nouveau.

 

Merci pour tes retours

Bonne soirée

Sylvain

 

Bien vu ton dernier post !

Modifié par sylvainlelievre
  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 22 minutes, sylvainlelievre a dit :

Bonsoir @omega

Si mais il faut cocher à  la création du compte la case qui permet d'envoyer und notification au nouveau.

 

Merci pour tes retours

Bonne soirée

Sylvain

Oups j'avais oublié de cocher cette case, désolé pour le dérangement (à mon sens il faudrait quelle soit coché par défaut non ?)

image.png.c6b485e85754a65a7411362dfa3883b6.png

 

Modifié par omega

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, omega a dit :

tu veux dire qu'il n 'y plus de message envoyé au nouvel utilisateur  lorsque l 'admin crée un nouvel utilisateur manuellement ?

 

Je n’ai pas dit ça, les deux choses n’ont strictement rien à voir : création et import csv. 
Mais si tu crées un user, la problématique est la même : soit il connaît le mot de passe qui n’est plus envoyé par e-mail, cause Rgpd, soit il clique sur mot de passe oublié.  
Si tu n’as pas compris cela c’est qu’il faut que la même consigne soit dans les deux e-mails.  

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, omega a dit :

voir utilisateur top ci dessous qui n'est ni éditeur , ni administrateur ni membre

Ok c’est à contrôler, mais je pense que la modification de notification de l’enveloppe doit en même faire le filtrage. 
 

Mercu de ton retour. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour tout le monde.

Bien, vu les changements apportés depuis le lancement du test et pour rester cohérent avec mes propres remontées, je vais tout reprendre de zéro en téléchargeant la toute dernière version corrigée ce matin même par  @Fred

 

Je pense pouvoir donner dans la journée mon retour d'expérience sur cette 10400 en  cours d'évaluation .

Bien à vous.

Roger

Partager ce message


Lien à poster
Partager sur d’autres sites

A @Fred et @sylvainlelievre

Coucou, court et très simple, tout est dans les images.....

Modifications : sur une future version....

    • Module User
      • Pour les articles de blog et de news, choix de la signature, nom+prenom ; nom+prenom ; id ; pseudo
      • z4.png.108e9b97d123cdf0f2efb415a75ed3ac.png
      • Importation d'un liste d'utilisateur dans un fichier plat (CSV).

.

  •  Module Blog :
    • Texte du commentaire enrichi.
    • Nombre maximal de caractère par commentaire.
    • Gestion des commentaires article par article.
    • Suppression des commentaires en masse.
    • Limiter l'édition des articles et des commentaires à l'id de l'éditeur
    • Approbation des commentaires

En vert ce qui fonctionne à 100%

En rouge ce qui ne fonctionne pas

On  ne peut pas choisir non pas son  login de connexion ou tout autre chose de notre profil

z1.thumb.png.bbc43e01cdcb7968e02e6619c4ae4d0b.png

 

z2.thumb.png.2e23f740c7575469edc632a8a9403175.png

En orange ce qui pourrait être amélioré juste l'envoi du mail qui mériterait esthétiquement un peu de bleu dans le haut du corpd du mail reçu.

x.thumb.png.ed26d14bfed5d9e1df4a5eb0d427ac33.png

 

z3.png.11eb370749a3f5411d3b5d7866b387f8.png

 

y.png.6d5af5ac9e8fe309361583477bebd824.png

 

le reste en images

z.png.df6e44a72b78b820852fbc3dbaab302d.png

voila voilou elle me plais cette version là moderne et tout....

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci @roger 

 

En dehors du bouton vert, j’avoue ne pas tout saisir. @sylvainlelievre est en congés mais je jetterai un œil demain sur la signature. Pour le mail, à voir. 

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 18 minutes, Fred a dit :

En dehors du bouton vert, j’avoue ne pas tout saisir.

Bonsoir Fred;

Ne te fais pas de soucis je t'expliquerais en détail le seul truc qui a pas fonctionné par le 'canal habituel" que nous utilisons tout deux 😉

La version telle que ne provoque aucuns bug chez moi  et n'a qu'un seul truc qui n'a pas marché, le reste n'est que possible amélioration .

Il y a 3 heures, roger a dit :

Module User

  • Pour les articles de blog et de news, choix de la signature, nom+prenom ; nom+prenom ; id ; pseudo

 

Je viens de tester dans tout les sens et n'ai pas pu lui trouver le moindre défaut.

Good job que vous avez produit tout les deux , vraiment elle est top cette bêta là avec ses nouvelles fonctionnalités.

Bonne fin de soirée à toi Fred, je file mettre les panards devant la cheminée 🙃

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...