Aller au contenu
Support de Zwii
roger

Codage UTF8 et les dates FR

Messages recommandés

il y a 26 minutes, Gilux a dit :

sur ton serveur mac,

C'est XAMPP, la config doit être identique sur PC.

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 12 heures, Gilux a dit :

Une fois encore, si les dates sont en anglais sur ton serveur mac, c'est que l'UTF8 n'y est pas activé, tu le dis toi-même :

plutôt que le setlocal n'a pas été pris en compte, tu confonds la fonction du setlocal qui est de fournir une localisation avec UTF8 qui permet l'encodage des accents.

d'ailleurs

 

echo setlocale(LC_ALL, 'fr','fr_FR','fr_FR.utf8','fr-FR','fra');

Affichera le codage retenu par le système.

 

La ligne devrait d'ailleurs plutôt être :

 

setlocale(LC_ALL, 'fr.utf8','fr_FR.utf8','fr_FR.utf8','fr-FR.utf8','fra.utf8');

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 6 heures, sylvainlelievre a dit :

Ce qui marche sur mon serveur c'est avec 'fr_FR.utf8' ET sans 'fr_FR'. Ceci avec LC_TIME ou LC_ALL ce qui est normal.

Et ce sont bien l'un des deux codes LC_TIME ou LC_ALL "accouplés à 'fr_FR.utf8','fra' qui effectivement tout les deux afficheront les caractères accentués partout dans le zwii (les mois et les textes)

Mes affichage zwii fonctionnent nickel avec ses deux code dans index.php:

Le plus récent

/*
 *Localisation
 */
date_default_timezone_set('Europe/Paris');
setlocale (LC_ALL, 'fr_FR.utf8','fra');

/**

Celui que j'avais donné il y a quelque temps

/*
 *Localisation
 */
date_default_timezone_set('Europe/Paris');
setlocale (LC_TIME, 'fr_FR.utf8','fra');

/**

Le serveur lui se contente d'envoyer à la demande de l'utilisateur le fichier à afficher sur son navigateur, donc c'est ensuite le navigateur qui interprète le codage de langue imposé dans le document fourni par le serveur où qu'il se trouve.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 11 heures, roger a dit :

Le serveur lui se contente d'envoyer à la demande de l'utilisateur le fichier à afficher sur son navigateur, donc c'est ensuite le navigateur qui interprète le codage de langue imposé dans le document fourni par le serveur où qu'il se trouve.

On parle bien de la config d'Apache ou de Nginx plus rarement, et si celle-ci est stockée. D'après mes lectures, l'OS joue un rôle mais aussi la compilation du php selon le compilateur et l'OS !

 

Pour tenter de solutionner le problème en évitant de copierb êtement des paramètres trouvés sur le net, j'affiche le paramètre accepté par le serveur Apache (XAMPP) de mon mac book air avec un echo devant setlocale, c'est 'fr_FR' en seconde position, cela signifie qu'il n'accepte par la déclaration .utf8 tout en affichant les accents normalement.

Le paramètre

setlocale (LC_ALL, 'fr_FR.utf8','fr_Fr');

Fonctionne également chez Obambu, sauf que ce n'est pas si simple !

Chez Free cela ne fonctionne pas, j'ai donc repris un index installé sur un serveur Free, le paramètre valide est french alors que fr_FR.utf8 est accepté mais pas interprété !

 

Le setlocale "universel" deviendrait donc :

/*
* Locales :
* french : free.fr
* fr_FR : XAMPP MacOs
* fr_FR.utf8 : la majorité
*/
setlocale (LC_ALL,'french','fr_Fr','fr_FR.utf8');

J'invite donc les membres qui ont des problèmes d'affichage des accents à tester différentes locales parmi

echo setlocale(LC_ALL, 'fr','fr_FR','fr_FR.utf8','fr-FR','fra');

et à nous faire une remontée de leur RETEX.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @Fred, @roger, @Gilux,

 

Oui le problème avec setlocale c'est que le serveur peut rencontrer un paramètre valide mais qu'il ne sait pas interpréter... et il s'arrête au premier paramètre valide.

 

J'ai fait les essais, en ligne sur mon serveur phpnet, avec

il y a une heure, Fred a dit :

setlocale (LC_ALL,'french','fr_Fr','fr_FR.utf8');

 

En permutant les 3 paramètres et en faisant un echo :

  • french, en premier rang, est reconnu mais non interprété (pas d'accent dans les dates d'article de blog),
  • fr_FR idem,
  • ça ne fonctionne qu'avec fr_FR.utf8 placé en premier, c'est reconnu et interprété.

Rémi avait sans doute identifier ce problème d'où l'encodage utf8 des dates dans les scripts !

 

A moins de demander au serveur ce qu'il attend comme paramètre pour passer en fr et en utf8 ça va être compliqué (comme on dit maintenant) de trouver une solution valide sur tous les serveurs !

 

Bonne journée confiné(e)

 

Sylvain

 

PS : LC_TIME, peut être suffisant , donne exactement les mêmes résultats.

Modifié par sylvainlelievre

Partager ce message


Lien à poster
Partager sur d’autres sites

Hello @sylvainlelievre

 

Ton constat confirme le résultat que j'obtiens, selon a configuration des web servers on va obtenir une réponse différente et effectivement c'est très compliqué (😂 j'avais aussi noté, tout comme les "voilà" à profusion).

 

il y a 9 minutes, sylvainlelievre a dit :

PS : LC_TIME, peut être suffisant , donne exactement les mêmes résultats.

 

C'est bien normal, ALL s'appliquera à tous les formats, monétaires par exemple, ce qui ne mange pas de pain.

 

@Gilux que je salue également avait noté un problème de double encodage de l'UTF-8, il faudra donc tester la non existence de cette encodage AVANT de l'appliquer.

<?php
    $str = 'áéóú'; // ISO-8859-1
    mb_detect_encoding($str, 'UTF-8'); // 'UTF-8'
    mb_detect_encoding($str, 'UTF-8', true); // false
?>

 

Juste pour info, je voudrais traiter ce problème au niveau 10.3.04.

Partager ce message


Lien à poster
Partager sur d’autres sites

@Fred,,

 

On pourrait ce servir de cette fonction mb_detect_encoding dans index.php pour vérifier la bonne interprétation du paramètre setlocale(), sinon on passerait au paramètre suivant (tableau de paramètres) ???

 

edit : des essais n'ont rien donné de probant.

 

A suivre..

Modifié par sylvainlelievre

Partager ce message


Lien à poster
Partager sur d’autres sites

  

Il y a 1 heure, Fred a dit :

Fonctionne également chez Obambu, sauf que ce n'est pas si simple !

Chez Free cela ne fonctionne pas, j'ai donc repris un index installé sur un serveur Free, le paramètre valide est french alors que fr_FR.utf8 est accepté mais pas interprété !

Bonjour Fred.

 

je suis désolé de te contredire sur l'affirmation que chez Free cette instruction ne fonctionne pas:

 

Adresse d'un zwii en ligne chez free depuis Juin 2019 (Une version V9.1.09)) pour que vous puissiez constater ce que j'affirme concernant cet encodage utf8....

==>      http://lechti64.free.fr/ZwiiCMS-9109/?accueil

 

👉 Son serveur fourni bien les instructions sur la façon d'afficher les caractères de la langue qui sont paramétrés dans le fichier index.php de l'époque à la racine du site.

💡 Et il est à remarqué que ce n'est pas "fra" qui est utilisé à la fin mais bien "french" qui universellement....sera reconnu même sur un PC  chinois (plutôt le navigateur utilisé sur le pc qui affiche tout en chinois) comme devant être  affiché à son propriétaire, il montrera sur l'écran du "mandarin de Shangai"  du texte écrit en français avec sa propre accentuation 🤓

<?php

/**
 * This file is part of Zwii.
 *
 * For full copyright and license information, please see the LICENSE
 * file that was distributed with this source code.
 *
 * @author Rémi Jean <remi.jean@outlook.com>
 * @copyright Copyright (C) 2008-2018, Rémi Jean
 * @license GNU General Public License, version 3
 * @link http://zwiicms.com/
 */

/**
 * Vérification de la version de PHP
 */
if(version_compare(PHP_VERSION, '5.6.0', '<')) {
	exit('PHP 5.6+ required.');
}
/* Set locale to French */
date_default_timezone_set('Europe/Paris');
setlocale (LC_TIME, 'fr_FR', 'french');
/**
 * Initialisation de Zwii
 */
session_start();
require 'core/core.php';
$core = new core;
spl_autoload_register('core::autoload');
echo $core->router();

En cinq images prises ce matin sur mon pc (filezilla et accès à mon espace "gratos" free) et capture dans mon Firefox du site en ligne chez ce FAI Free (que je déteste pour de multiples raisons!!!!)

Pour une fois au format gif, temps entre deux diapo 3 secondes

signes.gif.fa07eec9fa62b12c15975b5c53ff0fa7.gif

👉 @sylvainlelievre @Fred Je vais y envoyer une version officielle 10.3.04 et vous mettre ici ensuite le lien vers celle ci chez Free afin de voir à ce jour si les caractères accentués y sont toujours bien interprétés tels qu'écrits dans le nouvel index.php des V10.3.xx qui n'a plus rien à voir avec les anciens index des versions précédentes (V8 & V9) c'est le moins que je puisse faire pour ceux qui adorent ce FAI bien précis....

Partager ce message


Lien à poster
Partager sur d’autres sites

Hum, je peux aussi te contredire :

image.png.4154ac853cfe3dc1e2eca61d2d970c57.png

En effet tous les serveurs Free ne sont pas configuré de la même manière.

 

Si on lit la RFC

Citation

La liste des noms de locales/catégories peut être trouvée en consultant la » RFC 1766 ainsi que l'» ISO 639. Les différentes plates-formes possèdent des conventions de nommages différentes.

dans https://www.php.net/manual/fr/function.setlocale.php

il y a une heure, roger a dit :

ce n'est pas "fra" qui est utilisé à la fin mais bien "french" qui universellement.

france ou french n'est pas normalisé et ne marchera pas à chaque fois.

 

Bref c'est le b...l

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

@roger et bien j'ai écrit cela concernant Free, il faut "french" et non ceci

 

Le 02/10/2020 à 12:14, roger a dit :

La valeur fr_FR.utf8 étant la clé de la traduction des dates à afficher dans notre belle langue.

 

que tu indiquais pourtant comme la solution universelle et qui ne marche pas chez Free

 

@sylvainlelievre merci de tester ceci https://github.com/fredtempez/ZwiiCMS/commit/f863b69a4daa5dda554660798ef045efa33c092c

 

l'encodage UTF est appelé de manière conditionnelle. ce commit fonctionne chez Free, en local,  chez Obambu sur mon mac Book.

 

setlocale (LC_ALL,'french','fr_Fr','fr_FR.utf8');

Mais :

<?php echo mb_detect_encoding(strftime('%d %B %Y - %H:%M',  $article['publishedOn']), 'UTF-8', true)
	? strftime('%d %B %Y', $article['publishedOn'])
	: utf8_encode(strftime('%d %B %Y', $article['publishedOn']));  ?>

Si l'encodage UTF-8 est détecté sur la chaîne on l'affiche sinon elle est convertie.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Fred Free est un cas à part dans notre univers, le seul hic c'est qu'ils ne font pas comme tout le monde et pire ils ne paramètre pas TOUT LEURs serveurs de la même façon. il suffit de lire sur leurs différents forums de soutient et partout sur le web les plaintes de leurs propres clients.

 

C'est pour cela que JAMAIS je ne prendrais ou migrerais mon FAI chez lui;

Idem mon fournisseur web est ORANGE....chez lui c'est pire tu ne peux même pas installer un Zwii car il ne tolère pas un site web sur ses serveur en PHP!!!! Un site en total HTML oui mais pas les autres...

 

Il y a 2 heures, Fred a dit :
Le 02/10/2020 à 12:14, roger a dit :

La valeur fr_FR.utf8 étant la clé de la traduction des dates à afficher dans notre belle langue.

 

que tu indiquais pourtant comme la solution universelle et qui ne marche pas chez Free

 

Pour le utf8 que ce soit "french" à l'époque ou "fra" maintenant je le saurais dés que j'aurais installé une version récente chez eux (en 2019 et avant les version zwii n'avaient pas cette instruction utf8 codée dans le index.php) comme il est de rigueur aujourd’hui  mais le code que l'on voit dans le gif à savoir :

 

Celle ci : setlocale (LC_TIME, 'fr_FR', 'french');  est elle affichait à l'époque les caractère accentués...depuis le code  beaucoup changé dans le développement du cms au point de rendre obsolètes "nos vieux code du temps de Rémi avec ceux actuels qui se sont mis aux normes qui ont évoluées au fil du temps.

<?php

/**
 * This file is part of Zwii.
 *
 * For full copyright and license information, please see the LICENSE
 * file that was distributed with this source code.
 *
 * @author Rémi Jean <remi.jean@outlook.com>
 * @copyright Copyright (C) 2008-2018, Rémi Jean
 * @license GNU General Public License, version 3
 * @link http://zwiicms.com/
 */

/**
 * Vérification de la version de PHP
 */
if(version_compare(PHP_VERSION, '5.6.0', '<')) {
	exit('PHP 5.6+ required.');
}
/* Set locale to French */
date_default_timezone_set('Europe/Paris');
setlocale (LC_TIME, 'fr_FR', 'french');
/**
 * Initialisation de Zwii
 */
session_start();
require 'core/core.php';
$core = new core;
spl_autoload_register('core::autoload');
echo $core->router();

 

@Fred donc dés que tu veux tu mets ce que tu juges le mieux comme code utf8, moi je teste chez ce fournisseur particulier (Free) et sur les autres serveurs.

Par contre les eux premiers code utf8 LC_TIME & ALL_TIME eux fonctionnaient parfaitement partout il me semble avant que qu'un ne soulève cette hypothèse (plausible ou pas je ne juge pas) que les caractères n'étaient pas correctes en français chez lui..

 

Je ne peux apporter plus dans cette contribution que ce que j'ai déjà expliqué pour le utf8 qui fonctionnait à 100% chez moi ainsi que les tests que j'ai effectué pour d'autres propositions de codages et qui eu ne fonctionnaient pas.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Fred j'ai pas eu le temps du tout (je suis bénévole dans ma commune et donc..me suis dévoué pour ce jour bien précis) je viens juste d'allumer le pc y'a pas une heure puis répondre comme tu le sais...

👍 je vais installer la dernière version comitée d'ici 15/20 mn et aussitôt te donner les infos sur...

(ca me "burine" cette histoire de caractères et comme toi j'aimerai bien voir que la solution est enfin trouvée pour passer à d'autres tests qui sont aussi demandés 😉)

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 29 minutes, Fred a dit :

@roger tu as installé la dernière version commitée ?

fait actuellement chez Free et chez Ionos.

 

Chez free la sanction est immédiate!!!!

Free.thumb.png.97b25e67263b4048bbb6afa4451fe05a.png

Chez Ionos.fr ton codage pour les caractères accentués c'est nickel chrome!!!!

Ca doit donc marcher chez toi et chez d'autres en principe;

J'ai bien raison, FREE c'est de la daube qui vaut rien, incapable de mettre à jour leur serveurs!!!!!

 

ULTIME ESSAI pour moi chez Free:

Je vais maintenant "injecter" chez eux un ancien .htaccess pour voir si, puis voir  le reste, si ça marche pas je laisse tomber pour free, je pense que ceux qui sont chez ce fournisseurs auront à cœur de venir donner un coup de main pour résoudre ce bug chez leur fai.

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Ultime essai!!!!

DES CONNARDS CHEZ CE FOURNISSEUR M;;;;;;;;;DIQUE

 

Changement du .htaccess par un "vieux"

<ifDefine Free>
 PHP56 1
</ifDefine>

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

Une alerte ensuite qui me dit:

free2.thumb.png.31d562b39c48100264ed77a6afac4e93.png

 

Tu rafraîchis juste la page et....

free4.png.edf81ef7eb9f53b764eba7394aac95a5.png

 

Affichage "dégueulasse "du nouveau site en place mais bon je clique sur le lien pour me connecter et régler le blème...

free3.thumb.png.f4a85a07149f26c49d42d3169fa93a58.png

 

Ensuite je peux te dire que je connais mes identifiants par cœur, je sais faire une addition soustraction multiplication et division de tête, impossible de me connecter au site car il n'aime pas un zwii codé sans leur foutu ? dans les chemin!!!! idem si je clique sur mot de passe enregistré oublié, là c'est pire il ne me reconnaît même pas comme user alors que...je découvre avec stupeur celui qui y est enregistré.....

{
    "user": {
        "bob": {
            "firstname": "bob",
            "forgot": 0,
            "group": 3,
            "lastname": "bob",
            "mail": "oui@oui.oui",
            "password": "$2y$10$hpmmbDMmxw65qj6oQQ.t8uI8xygl5qJAdApUsyYwo5enQVqEkL8oy",
            "accessCsrf": "aeca035812091f185b149ecd1380fe3e5ea576b95d3daee844de776e754d908b",
            "accessUrl": "blog-2",
            "accessTimer": 1604249680
        }
    }
}

@Fred si tu sais comment expliquer tout ceci je te paye une bière.

 

Moi pour accéder à ce nouveau site je sais comment le faire et vais donc virer ce malpropre qui à pris ma place comme administrateur de mon site 10304 chez free 😋

 

Bref je laisse "le bébé" aux aficionnados pour proposer leurs solutions pour les versions actuelles et futures qui sont vraiment sexy elles en regard de l'horreur que ce FAI Free 😄

 

free1.png

Free.png

Partager ce message


Lien à poster
Partager sur d’autres sites

On me vole pas impunément mon identité et surtout MON ZWIICMS ADORÉ m'enfin!!!!

free5.thumb.png.52cc6e2eed1307185afae7ed51332412.png

 

 

@Fred  tu pourras faire le ménage ici dans mes essais concernant le dernier commit chez free, moi je ne cherche pas midi à quatorze heure pour ce fournisseur là, je l'aime po et on me changera pas dans ce sentiment A choisir en Free et ZwiiCMS je vire le free non de diou!!!!

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 1 heure, Gilux a dit :

 Bonjour à tous,

 

La date est ok mais l'heure ne s'affiche plus

 

Avant :

1225226554_Capturedcrandu2020-11-0117-04-35.png.4b13ba6207bd1302079a9f197c20ca06.png

Après :

1376474727_pasdheure.png.29d17a78d350563923dd37883ba5ae0a.png

oups, un mauvais copié collé.

Partager ce message


Lien à poster
Partager sur d’autres sites

Test du dernier commit : https://github.com/fredtempez/ZwiiCMS/commit/9a2274a71631a8a5d399276038bc9ece09ddafd3

Sur Win Xampp et Linux Apache server, la date et l'heure est correctement affichée dans les 2 tests en local

 

J'avais testé la précédente version, il apparait que fr_FR.utf8 code correctement les dates sur un serveur Apache sous Linux, mais pas ailleurs :

 

/* Set locale to French */
date_default_timezone_set('Europe/Paris');
//setlocale (LC_ALL, 'fr_FR.utf8','fra');//Win Xampp : f�vrier, Linux Apache server : février
//setlocale (LC_ALL, 'fra','fr_FR.utf8');//Win Xampp : f�vrier, Linux Apache server : février
//setlocale (LC_TIME, 'fr-FR','fr_FR.utf8'); //Win Xampp : f�vrier, Linux Apache server : février
//setlocale(LC_ALL, 'french','fr_FR.utf8');//Win Xampp : f�vrier, Linux Apache server : février

//setlocale(LC_ALL, 'fra','fr-FR','french','fr_FR.utf8');//Win Xampp : f�vrier, Linux Apache server : février

//setlocale(LC_TIME, 'fr_FR.UTF8');//Win Xampp : February, Linux Apache server : février
//setlocale(LC_TIME, 'fr_FR');//Win Xampp : February, Linux Apache server : February
//setlocale(LC_TIME, 'fr');//Win Xampp : f�vrier, Linux Apache server : February
//setlocale(LC_TIME, 'fra_fra');//Win Xampp : f�vrier, Linux Apache server : February

//setlocale (LC_ALL, 'french');//Win Xampp : f�vrier, Linux Apache server : February
//setlocale (LC_ALL, 'fr_Fr');//Win Xampp : February, Linux Apache server : February
//setlocale (LC_ALL, 'fr_FR.utf8');//Win Xampp : February, Linux Apache server : février

setlocale (LC_ALL,'french','fr_Fr','fr_FR.utf8');//Win Xampp : f�vrier, Linux Apache server : février

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Il est intéressant d’afficher le retour du set local, j’ai constaté chez Free que le setlocal peut être retenu sans être interprété. Chez Free c’est french qui fonctionne. Fr_FR.UTF8 est loin d’être universel. 

Partager ce message


Lien à poster
Partager sur d’autres sites

Bonjour @Fred, @roger, @Gilux et les autres,

 

Test version Github Fred 10304 2/11/2020 8:00

 

Date en français utf8 : OK

 

Tests supplémentaires sur la ligne setlocale() de index.php :

suppression totale : date en anglais , c'est normal !

suppression uniquement du paramètre 'fr_FR.utf8' (celui qui est nécessaire sur mon serveur pour le passage en utf8) : date en français accentué, conclusion ce sont bien les scripts avec md_detect_encoding qui positionnent les dates en utf8.

 

ça marche ! et ça m'étonne car j'avais fait ce type d'essai, mais sans le paramètre TRUE il est vrai.

 

Bonne journée confiné(e)

 

Sylvain

Partager ce message


Lien à poster
Partager sur d’autres sites

Testé à l'instant chez free.fr, après la 1ère ouverture du site, même warnings que roger :

Warning: file_get_contents(site/data/config.json): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php on line 123

Warning: file_get_contents(site/data/core.json): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php on line 123

Warning: file_get_contents(site/data/fr/module.json): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php on line 123

Warning: file_get_contents(site/data/fr/page.json): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php on line 123

Warning: file_get_contents(site/data/user.json): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php on line 123

Warning: file_get_contents(site/data/theme.json): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php on line 123

Warning: file_get_contents(site/data/admin.json): failed to open stream: Aucun fichier ou dossier de ce type in /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php on line 123

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php:123) in /var/www/sdb/b/e/free.test/core/core.php on line 1659

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php:123) in /var/www/sdb/b/e/free.test/core/core.php on line 1660

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php:123) in /var/www/sdb/b/e/free.test/core/core.php on line 1661

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php:123) in /var/www/sdb/b/e/free.test/core/core.php on line 1662

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php:123) in /var/www/sdb/b/e/free.test/core/core.php on line 1663

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sdb/b/e/free.test/core/class/jsondb/JsonDb.class.php:123) in /var/www/sdb/b/e/free.test/core/core.php on line 1725

Puis, aucun PB après l'installation, les dates s'affichent correctement.

Je vais faire un echo sur setlocale et donner le résultat + tard

  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 3 minutes, sylvainlelievre a dit :

ce sont bien les scripts avec md_detect_encoding qui positionnent les dates en utf8

 

Je suis d''accord avec ça ;)

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Invité
Répondre à ce sujet…

×   Collé en tant que texte enrichi.   Coller en tant que texte brut à la place

  Seulement 75 émoticônes maximum sont autorisées.

×   Votre lien a été automatiquement intégré.   Afficher plutôt comme un lien

×   Votre contenu précédent a été rétabli.   Vider l’éditeur

×   Vous ne pouvez pas directement coller des images. Envoyez-les depuis votre ordinateur ou insérez-les depuis une URL.


×
×
  • Créer...