Aller au contenu
Support de Zwii
  • 0
mszlosser

[RESOLU]Lenteur en mode Administrateur - Version 10.2.08

Question

Pour vérifier :

1) www.gpu-vision.com

2) Connexion

identifiant : demo

mot de passe : demo

 

Résultat :

L'application boucle durant 60000ms (1 minute).
Idem pour toute opération en mode Administrateur.

Le choix "Configurer le site" conduit à "Internal Server Error".
 

Pas de problème dans les autres modes : Visiteur, Membre, Editeur.
Pas de problème avec un serveur local.

L'hébergeur est online.net

 

Sinon le CMS ZWII est très intuitif c'est dommage que ce problème de connexion en mode Administrateur ne soit pas résolu dans la version 10.

Modifié par mszlosser

Partager ce message


Lien à poster
Partager sur d’autres sites

Messages recommandés

  • 0

Bonjour omega,

 

La réponse au premier ticket a pris en effet un peu plus de temps (1 jour) chez Obambu que chez EvxOnline (1 heure).

Le site gpu-vision.fr (EvxOnline) fonctionne sans ralentissement, je vais pouvoir commencer à le construire avec ZWII CMS dès la semaine prochaine.

Le site gpu-vision.com (Obambu) devrait être opérationnel dans les prochains jours cars le transfert du nom de domaine peut prendre quelques jours (5-10 jours).

 

L'interface cPanel d'Obambu est en effet très conviviale mais l'interface plesk d'EvxOnline plus dépouillée me convient très bien aussi.

 

Ne reste plus qu'à observer les 2 sites sur une période d'un an. 😉

 

Bonne journée.

Michel

Modifié par mszlosser

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@mszlosser

Bonjour
merci pour ce retour , donne nous ton ressenti lorsque les deux sites seront opérationnels

vérifie bien que les sites soient en http/2 en mode https (sécurisé)

j 'avais une lenteur chez Obambu qui a été résolu par ticket en passant de http/1 en http/2
Bon Dimanche

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour omega,

 

<<j 'avais une lenteur chez Obambu qui a été résolu par ticket en passant de http/1 en http/2>>

Comment activer le protocole http/2 chez Obuntu quand on n'a pas accès à Apache httpd ?

 

Bonne journée.

Michel

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonsoir Michel,

il faut voir si il est activé (dans la console de firefox ou autre navigateur tu vois cela) , s 'il n'est pas il faut leur demander (si tu vois une lenteur sur ton site https)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour !

 

Je teste ZWICMS hébergé chez AMEN.FR (mutualisé de base).

 

Je viens de tester plusieurs choses à propos de cette lenteur en mode connecté (jusqu'à 6 secondes d'attente !).

 

Ma conclusion est que dès qu'on coche Mise à jour auto, le problème survient en 10.2.08...

 

Dès que cette option est décochée, le site fonctionne de manière satisfaisante, que l'on soit connecté ou pas.

 

J-L

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

 

Chez Online.net ce n'est pas 6s mais 60s !!!

Il est même impossible d'accéder en temps normal au menu "Configurer le site".

Par contre vers 18h00 tout semble fonctionner normalement mais cela ne dure qu'une heure ou deux.

J'ai fait l'essai en décochant "Mise à jour auto" mais cela n'a rien changé en temps normal.

 

Bonne journée.

Michel

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour omega,

 

Pourquoi le certificat est auto-signé chez Obambu ?

Comment faire pour obtenir un certificat signé comme chez EvxOline par exemple ?

 

Bonne journée.

Michel

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

http/2 permet un téléchargement plus rapide des données en limitant les requêtes.

Pour vérifier l'implémentation de cette technologie chez votre hébergeur il existe une extension FF : https://addons.mozilla.org/fr/firefox/addon/http2-indicator/

Un éclair bleu s'affiche fans la barre d'adresse si le serveur est http/2 :

image.png.d19b943bc027558d64da27704b36e9f8.png

Il y a un préalable, il faut une connexion https

Chez Obambu, les certificats sont générés automatiquement pour les domaines et les sous-domaines.

 

Il y a 5 heures, mszlosser a dit :

Par contre vers 18h00 tout semble fonctionner normalement mais cela ne dure qu'une heure ou deux.

Visiblement il y a un problème avec la baie de serveur, vous avez contacté le support ?

 

Il y a 6 heures, Balzac_40 a dit :

Dès que cette option est décochée, le site fonctionne de manière satisfaisante, que l'on soit connecté ou pas.

La recherche de la mise à jour n'est effectuée qu'une fois par jour, si vous vous débrouillez en PHP, il faudra inclure des traceurs sous la forme d'écho autour des fonctions d'update pour localiser le timeout :

 

image.thumb.png.73b455a41e396073b607a3bb3dc710e9.png

 

Comme on peut le voir, il n'y a aucune requête hors connexion avec un compte admin.

Un echo après  2639 et un autre après 2642 par exemple.

 

La fonction de mise à jour consiste à lire un fichier distant contenant un numéro de version qui est comparé à une variable interne. Cette fonction met en jeu une lecture d'url qui pose problème à certains hébergeurs comme free dont l'accès est bloqué vers l'extérieur. La requête n'est active qu'une fois par jour, sauf bug non identifié.

 

Placer des traceurs dans helper.class.php peut aussi aider à identifier le problème :

 

	public static function urlGetContents ($url) {
		// Ejecter free.fr
		if (strpos(self::baseUrl(),'free.fr') > 0 ){
			return false;
		}
		if(function_exists('file_get_contents') &&
				ini_get('allow_url_fopen') ){
				$url_get_contents_data = @file_get_contents($url); // Masque un warning éventuel
			}elseif(function_exists('fopen') &&
				function_exists('stream_get_contents') &&
				ini_get('allow_url_fopen')){
				$handle = fopen ($url, "r");
				$url_get_contents_data = stream_get_contents($handle);
			}else{
				$url_get_contents_data = false;
			}
		return $url_get_contents_data;
	}

 

 

 

 

  • Merci 2

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonsoir Fred,

 

Tout est Ok pour le site gpu-vision.fr hébergé chez EvxOnline :

- plugin http/2

- certificat signé

- redirection http -> https

- mise à jour version 10.2.08 -> 10.2.09

 

Reste à faire la même chose avec le site gpu-vision.com hébergé chez Obambu (transfert du domaine en cours).

 

Online.net est en train de faire les vérifications.

Je vais décocher l'option sur le site Online en fin d'après-midi et tracer la connexion.

 

Merci pour toutes ces infos.

 

Bonne soirée,

Michel

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 21 minutes, mszlosser a dit :

Online.net est en train de faire les vérifications.

Je vais décocher l'option sur le site Online en fin d'après-midi et tracer la connexion.

 

Bonjoir,

online.net, online.fr, scaleway.com... sont des marques du groupe Iliad, tout comme free.fr, les serveurs de ces premiers sont peut-être configurés spécialement comme le sont ceux de ce dernier ?

C'est à vérifier, notamment en ce qui concerne les fonctions PHP

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 1 heure, Fred a dit :

Pour vérifier l'implémentation de cette technologie chez votre hébergeur il existe une extension FF : https://addons.mozilla.org/fr/firefox/addon/http2-indicator/

Un éclair bleu s'affiche fans la barre d'adresse si le serveur est http/2 :

image.png.d19b943bc027558d64da27704b36e9f8.png

Il y a un préalable, il faut une connexion https

Chez Obambu, les certificats sont générés automatiquement pour les domaines et les sous-domaines.

 

 

Merci, @Fred, c'est beaucoup plus clair avec le éclair bleu ! 

 

http2.thumb.jpg.809df1e452bbff10f27efb61b2cdbadb.jpg

 

Mais sot je suis : il existe aussi ces extensions pour Chrome !  😷

 

Modifié par McGregor

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 1 heure, Fred a dit :

Pour vérifier l'implémentation de cette technologie chez votre hébergeur il existe une extension FF

 

A savoir :

 

HTTP/2 Indicator par Brandon Siegel

An indicator showing HTTP/2 support in the address bar.

 

La sécurité de cette extension n’est pas contrôlée par le programme des extensions recommandées de Mozilla. Assurez-vous que vous pouvez lui faire confiance avant de l’installer.

 

Permissions

Ce module a besoin de :

    Accéder aux onglets du navigateur
    Accéder à l’activité du navigateur pendant la navigation
    Accéder à vos données pour tous les sites web

 

Pour quelles raisons cette extension qui détecte le http2 sur les sites visités a besoin d'accéder à mes données pour tous les sites web ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

un moyen simple pour voir si vos pages sont chargées avec le protocole hhtp/2 il faut aller dans examiner l ' élément de Firefox (par exemple) et aller sur l'onglet Réseau

image.png.1713e2c9783aa424907811812e1decf8.png

Modifié par omega
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 2 heures, omega a dit :

un moyen simple pour voir si vos pages sont chargées avec le protocole hhtp/2 il faut aller dans examiner l ' élément de Firefox (par exemple) et aller sur l'onglet Réseau

Pas si simple quand même.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour,

 

Le nom de domaine gpu-vision.com a été transféré ce jour chez Obambu (la demande a pris une semaine environ).

 

Le passage en mode sécurisé (https) et au protocole HTTP/2 n'est pas automatique aussi j'ai fait un ticket pour demander la procédure à suivre.

 

Dans peu de temps je devrais pouvoir tester la réactivité des 2 sites avec les outils de test fournis en ligne par  https://tools.keycdn.com/
 

Bonne journée,

Michel

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 2 heures, mszlosser a dit :

Le passage en mode sécurisé (https) et au protocole HTTP/2 n'est pas automatique aussi j'ai fait un ticket pour demander la procédure à suivre.

Bonjour @mszlosser et ceux qui suivent ce post,

 

Pour information j'ai fait moi aussi la demande à mon hébergeur, phpnet, pour passer en http/2. La réponse a été rapide comme souvent chez cet hébergeur :

" Votre offre mutualisée ne vous permet pas d'activer http/2. Il faut migrer vers un abonnement performance ou bien un serveur dédié pour avoir le protocole HTTP/2.".

 

Bonne journée

Sylvain

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour Sylvain,

 

Concernant le protocole HTTP/2 :

- EvxOnline, pas de problème avec l'offre mutualisée "Perso SSD" --> https://gpu-vision.fr

- Obambu, pas de problème avec l'offre mutualisée "Evolution"      --> https://gpu-vision.com

 

Dans les 2 cas le certificat SSL (https) est inclu dans l'offre.

 

Voir https://tools.keycdn.com/http2-test

pour la vérification.

 

Je peux maintenant comparer ces 2 offres en terme de performances.

 

Bonne journée,

Michel

Modifié par mszlosser

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bonjour

attention à ne pas confondre HTTP/2 et https

le https, site sécurisé fonctionne en http/1 et http/2

mais le protocole http/2 permet un chargement plus rapide du site en https

en ce qui me concerne chez Obambu j 'étais en HTTP/1 et j 'avais constaté une certaine lenteur , il mon passé en HTTP/2 dans le premier prix

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Le 09/09/2020 à 11:28, mszlosser a dit :

Je crois que le plus simple pour savoir si un site est servi en HTTP/2 c'est d'aller :

https://tools.keycdn.com/http2-test

 

Merci Michel, c'est effectivement le méthode le plus simple. Le test confirme que chez Obambu, je suis en http/2. 😃

Modifié par McGregor

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...