Aller au contenu
Support de Zwii
  • 0
zwoui

[RESOLU] renommage page d'accueil : erreur php

Question

Bonjour,

 

Version ZWII : 11.0.171.dev

Lors du renommage du titre de la page intitulée par défaut "Accueil", PHP renvoie une erreur :

Notice: Undefined index: position in core/class/helper.class.php on line 77

L'action est néanmoins correctement enregistrée.

 

Cordialement.

 

PS : utilisateur habitué de CMS avec BD à la recherche d'un outil simple d'emploi pour la mise en place d'un nouveau projet, j'ai découvert ZWII il y a quelques temps. Testé et rapidement séduit, je l'ai adopté pour sa simplicité, sa souplesse et sa puissance.
Vraiment original !

Merci aux contributeurs !

 

Modifié par zwoui

Partager ce message


Lien à poster
Partager sur d’autres sites

1 réponse à cette question

Messages recommandés

  • 0
Il y a 8 heures, zwoui a dit :

Bonjour,

 

Version ZWII : 11.0.171.dev

Lors du renommage du titre de la page intitulée par défaut "Accueil", PHP renvoie une erreur :

Notice: Undefined index: position in core/class/helper.class.php on line 77

L'action est néanmoins correctement enregistrée.

 

Cordialement.

 

PS : utilisateur habitué de CMS avec BD à la recherche d'un outil simple d'emploi pour la mise en place d'un nouveau projet, j'ai découvert ZWII il y a quelques temps. Testé et rapidement séduit, je l'ai adopté pour sa simplicité, sa souplesse et sa puissance.
Vraiment original !

Merci aux contributeurs !

 

Bonjour et bienvenue,

Merci pour vos encouragements et pour le retour de bug.

La version 11 est corrigée, cf le github version 11.172 le renommage de la page d'accueil n'entraîne plus de warning.

Il faudra certainement purger le fichier page.json de la structure sous l'ancien nom ou si vous testez de le supprimer et de repartir au propre.

Cordialement

PS : merci de modifier le sujet et d'indiquer [RESOLU]

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

  • Contenu similaire

    • Par zwoui
      Bonjour,
       
      Version zwii 11.0.174.dev
       
      Une fois la langue du contenu à traduire en "mode manuel" paramétrée depuis la page "Gestion des langues" située à http://.../?i18n, un sélecteur de langues s'affiche dans la barre d'outils de l'espace privé. Si une langue autre que celle définie par défaut (fr) est choisie, il devient alors impossible d'ajouter un nouveau contenu via le symbole + qui déclenche http://.../?page/add
      PHP boucle sur http://.../?erreur404, et le navigateur indique pour finir "La page n’est pas redirigée correctement"
       
      En revanche le choix d'une langue de contenu à traduire "en mode automatique" fonctionnement correctement.
       
      Cdlt,
×
×
  • Créer...