Aller au contenu
Support de Zwii

Messages recommandés

il y a une heure, roger a dit :

Autre chose constatée (passé totalement inaperçue car peu de gens construise leur zwii avec l'option "Ne pas charger un exemple de script") les pages spéciales pourtant si importantes pour n'importe quel site web (même ceux avec une unique page à la construction d'un site) n'existent tout simplement pas!!!! car elle ne sont pas incluses justement dans le fichier de base qui installe un zwii! et donc le menu administratif où l'on choisi en haut sur la gauche ou dans les pages administratives quelles sont les pages 403, 404, mentions légales du site ou celle de maintenance à afficher à un visiteur....

 

C'est bien pour ça que l'option a été inversée, installant désormais par défaut un exemple de site, et qu'il est annoncé : "Ne pas charger l'exemple de site (utilisateurs avancés)", donc un utilisateur avancé doit être capable de créer lui même les pages spéciales, ce qui est logique

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 4 heures, roger a dit :

n'existent tout simplement pas!!!!

C'est justement l'idée, il faut les créer puisque le site exemple n'est pas installé.

J'ajouterai aussi que le les pages d'erreur d'origine, 403, 404 et maintenance s'affichent quand même, je n'ai pas supprimé les pages par défaut.

image.thumb.png.3e14d6bf03df3da572440010af190fac.png

 

Seul truc qui te donne raison, il ne devrait pas y avoir de lien de recherche dans le pied de page.

Partager ce message


Lien à poster
Partager sur d’autres sites
Le 15/09/2020 à 13:13, omega a dit :

si vous recherchez le mot Espace , il ne trouve pas la galerie Espace

 

C'est encore le cas, la recherche par titre fonctionne partiellement, pour la recherche du mot "galeries", ça match :

 

349014894_Capturedu2020-09-1714-14-29.png.9e43e2f0e5990b6ba88bdb01e17c7f0e.png

 

Mais pas pour la galerie "espace" :

 

959565856_Capturedu2020-09-1714-15-19.png.7e72d986cf1c4c9be2be1d6560633426.png

 

Ni pour la galerie " paysages" :

 

758167391_Capturedu2020-09-1714-15-58.png.f83cf98328ad4321dffbc70016632085.png

Partager ce message


Lien à poster
Partager sur d’autres sites
Il y a 3 heures, Gilux a dit :

l'option a été inversée

 

A ce propos, je pense que le contenu de la bulle d'aide devrait être changé :

 

Capture-install.png.05326836d4cd10b846bdf33eb9eb28ab.png

 

Peut-être en précisant que certaines pages, les spéciales, doivent être créées ?

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 25 minutes, Fred a dit :

il ne devrait pas y avoir de lien de recherche dans le pied de page

 

Il sufirait de créer une page recherche par défaut, comme les 403, 404 et maintenance

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 27 minutes, Gilux a dit :

 

A ce propos, je pense que le contenu de la bulle d'aide devrait être changé :

 

Capture-install.png.05326836d4cd10b846bdf33eb9eb28ab.png

 

Peut-être en précisant que certaines pages, les spéciales, doivent être créées ?

La bulle a été supprimée ce matin.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 21 minutes, Gilux a dit :

 

Il sufirait de créer une page recherche par défaut, comme les 403, 404 et maintenance

Pas vraiment, les pages d'erreur sont générées par core.php, je vais procéder au plus simple c'est à dire supprimer la page de recherche du pied de page.

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, Fred a dit :

La bulle a été supprimée ce matin.

 

Ah ? OK 😉 Je suis sur la beta d'hier...

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 1 minute, Gilux a dit :

 

Ah ? OK 😉 Je suis sur la beta d'hier...

Un oubli d'hier soir commité ce matin 😉

  • Haha 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Suite au fil de discussion relatif à des problèmes de gestion de données signalé ici :

 

J'ai effectué quelques modifications dans la gestion des données pour la rendre plus robuste.

Le détail est dans ce commit et le suivant à savoir :

  • classe jsonDb : un séparateur en surnombre supprimé
  • dans le noyau Zwii :
    • mise en cache des module en plus des page ( une lecture puis accès en RAM, écriture directe)
    • réécriture du code lisant les donnnées json afin d'utiliser la classe jsonDb
    • remplacer un message d'erreur exit par une exception en cas d'erreur d'import de version 9

Étant entendu que les données de site sont lues  en mémoire plutôt que sur le disque, ces modifications sont de nature à accélérer les sites volumineux (hors et avec connexion).

 

A vos test !

 

Partager ce message


Lien à poster
Partager sur d’autres sites

J'ai téléchargé ce matin même la version mise à jour. Tout fonctionne à merveille si ce n'est la fonction de recherche  qui n'arrive toujours pas à rechercher dans les galeries et les noms des images d'une galerie (normal on en as déjà parlé ailleurs).

@Fred je te fais le retour des test par mp.

Super la fonction de duplication des pages, ça ouvre de sacrées perspectives et un gain de temps appréciable.

 

J'ai testé toutes les modifications apportées sauf celles ci:

Correction:

  • Menu : déplacement de la classe "active".
  • Installation : bug si le masque de saisie est validé vide.
  • Classe jsonDb, suppression de la réinitialisation de la structure de données en cas d'absence du fichier.

Partager ce message


Lien à poster
Partager sur d’autres sites

Merci @roger

Il y a 1 heure, roger a dit :

Correction:

  • Menu : déplacement de la classe "active".
  • Installation : bug si le masque de saisie est validé vide.
  • Classe jsonDb, suppression de la réinitialisation de la structure de données en cas d'absence du fichier.

Pour le menu, c'est une redondance qui a été signalée il y a longtemps.

Le second est un bug signalé par @McGregor il y a un mois, tout est ok.

Pour le dernier, il faudra me croire sur parole, la reproduction de l'erreur est un peu complexe. De toute manière, ce n'est à la classe de procéder à la correction d'une structure de données absente, le core de Zwii s'en charge depuis la v10.

 

On se rapproche de la sortie de la 10.3

 

  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites
il y a 25 minutes, Fred a dit :

On se rapproche de la sortie de la 10.3

Si les autres "testeurs" ne trouvent pas d'erreurs sur cette dernière version, bien je crois que tu tiens le bon bout pour la publier rapidement tellement elle apporte de sacrée avancées cette v1300;

Bon boulot de ta part Fred pour toute les corrections apportées. 👍

  • J'aime 2

Partager ce message


Lien à poster
Partager sur d’autres sites

Une dernière correction publiée ce matin corrige la validation d'un formulaire en erreur après un rafraîchissement de l'écran.

Exemple, ajout d'une galerie clic sur plus sans la nommer, la notification s'affiche, F5 et la galerie était créée.

 

Le bug avait été traité dans le code du module mais il s'avère que son origine est générale, je suis donc revenu sur les correctifs appliqués et ai effectué la correction au niveau du core.php

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...