Aller au contenu
Support de Zwii
  • 0
sylvainlelievre

[RESOLU] Warning sur modification de page

Question

Bonjour @Fred,

 

Suite à la maj vers Zwii 10.02.01, j'ai sur tous mes sites le problème suivant :

 

Quand je veux modifier une page j'ai une série de messages warning comme celui-ci :

 

Warning: is_file(): open_basedir restriction in effect. File(module/._redirection/._redirection.php) is not within the allowed path(s): (/home/users3/f/fgo8585:/home/temporaire/upload/fgo8585:/home/temporaire/sessions/fgo8585:/tmp:/usr/local/lib/ZFramework:/dev/urandom) in /home/users3/f/fgo8585/www/core/module/page/page.php on line 321

 

Apparemment un problème au moment de l'établissement de la liste des modules.

 

Merci d'avance

Sylvain

 

 

Modifié par sylvainlelievre

Partager ce message


Lien à poster
Partager sur d’autres sites

9 réponses à cette question

Messages recommandés

  • 0

Bonjour Sylvain,

 

Je ne reproduis pas cette erreur, la fonction concernée balaie la liste des fichiers de modules pour l'affichage du select, fonction qui n'a pas changée entre 10.2.00 et 10.2.01.

 

il faudrait que tu vérifies la fonction open_basedir dans les paramètres de php.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je ne vois rien d'anormal sur open_basedir, phpinfo indique ceci en local ou master :

/home/users3/f/fgo8585:/home/temporaire/upload/fgo8585:/home/temporaire/sessions/fgo8585:/tmp:/usr/local/lib/ZFramework:/dev/urandom

 

D'autre part sur le même hébergement j'ai encore 3 sites que je n'ai pas mis à jour :

  • site en 10.01.04 : pas de warning en modification de page
  • site en 10.02.01 mais une version de dev, non mise à jour ce matin : pas de warning
  • et blogv3 qui est 10.02.00 dev34 : pas de warning non plus
Modifié par sylvainlelievre

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Il doit y avoir un problème avec le package de mise à jour réalisé à partir de mon mac. Tu peux tenter une mise à jour à partir du github ?

 

Quoi qu'il en soit sur les 5 sites mis à jour pas de problème par contre il y a un tas de saloperies cachées qui ont été copiées à la racine, j'ai donc désactivé la mise à jour.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'ai trouvé, regarde ton dossier, il y a des fichiers cachés dedans ! Il suffisait de lire :

File(module/._redirection/._redirection.php)

Mon package est doit être pourri ! Je découvre MacOs !!!

 

Désolé pour le nettoyage

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 38 minutes, Fred a dit :

Mon package est doit être pourri ! Je découvre MacOs !!!

En effet, vive Mac !

Entretemps j'ai viré les dossiers  core et module qui contenaient des fichiers "excédentaires" et j'ai mis à la place les core et module du Github. Fonctionnement OK, tout rentre dans l'ordre !

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Jette un œil quand même sur les autres dossiers, il y a des merdes aussi à la racine.

 

Mac a des avantages mais la mise en route n'est pas simple, déjà les raccourcis et des trucs que je découvre comme ceci.

 

Info ajoutée, tu peux indiquer [RESOLU] ?

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 19 minutes, Fred a dit :

Jette un œil quand même sur les autres dossiers, il y a des merdes aussi à la racine.

Il y en a partout ! c'est pour ça que j'ai été obligé de supprimer les dossiers core et module.

 

D'autre part dans ton archive sur Github il me manquait un fichier : core/vendor/tinymce/plugins/codesample/plugin.min.js

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 2 heures, sylvainlelievre a dit :

Il y en a partout ! c'est pour ça que j'ai été obligé de supprimer les dossiers core et module.

 

D'autre part dans ton archive sur Github il me manquait un fichier : core/vendor/tinymce/plugins/codesample/plugin.min.js

Oui tant qu'à faire 😕

Tu iras plus vite avec la touche DEL

Le paquetage est fait mais je n'ai pas d'accès FTP là de suite.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 2 minutes, Fred a dit :

Le paquetage est fait mais je n'ai pas d'accès FTP là de suite.

Pas de soucis j'ai tout rétabli sur mes 3 sites en production.

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...