Aller au contenu
Support de Zwii
  • 0
ljoets

Problème d'installation chez OVH (mutu)

Question

Bonjour,

Je n'arrive pas à installer zwii sur un hébergement mutualisé OVH.

Je suis en PHP 7.0.

La page d'accueil m'affiche ceci :

image.png.a1bdaf610b3884f1e0bff748d2649130.png

Que puis-je faire ?

Merci

Modifié par ljoets

Partager ce message


Lien à poster
Partager sur d’autres sites

7 réponses à cette question

Messages recommandés

  • 0

Bonjour

bienvenue sur le forum

désolé de ne pas pouvoir t ' aider , essaye toutefois de vider ton cache dans le navigateur
Florence nouvelle inscrite sur le forum pourra peut être 'aider elle vient d 'installer zwii sur Ovh

Bruno

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@ljoets C'est assez difficile de dire pourquoi ça coince, sans remontée d'erreur, est-il possible d'accéder aux logs d'erreurs du serveur mutualisé chez ton hébergeur OVH ?

 

Ton pb ressemble à un pb de droits insuffisants...

En tout cas ta version de PHP est conforme aux exigences du CMS, je le teste en local sur PHP 7.3, et en ligne sur PHP 5.4 chez un hébergeur gratuit, et je n'ai pas de pb d'utilisation

Si tu penses que cela peut venir du fichier .htaccess, simplifie au maxi le contenu de ce fichier en ne laissant que ceci :

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

Tu verras alors si l'une des lignes de ce fichier peut être responsable, mais j'en doute, car en principe un pb venant du .htaccess bloque complétement le site (erreur 500)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bon, alors effectivement, j'ai ça dans les logs :

[Fri Apr 17 13:18:50 2020] [crit] [client 88.137.109.203] [host zwii.xxxxxx.net] (13)Permission denied: AH00529: /homez.671/xxxxxx/zwii/core/.htaccess pcfg_openfile: unable to check htaccess file, ensure it is readable and that '/homez.671/xxxxxx/zwii/core/' is executable, referer: http://zwii.xxxxxx.net/?accueil

J'ai donc chmod +x -R /core / /module/ et /site/

Par contre, j'ai toujours des 404 sur des pages comme /config par exemple...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 26 minutes, ljoets a dit :

Permission denied: AH00529: /homez.671/xxxxxx/zwii/core/.htaccess pcfg_openfile: unable to check htaccess file

Ton fichier .htaccess n'est pas lisible par le serveur, sans doutes a-t'il été modifié sur une station windows, si oui, dans ce cas les fin de lignes écrites par cet os sont problématiques sur un serveur Apache (car je suppose que c'est un serveur Apache qui est utilisé) et il a pu également être enregidtré avec le statut de lecture seule, ce qui correspondrait à l'erreur ci-dessus transmise

Essaye alors de reprendre le fichier vierge présent dans l'archive que tu as téléchargé pour l'envoyer à la place de celui, corrompu, présent sur ton espace web ches ovh

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Bon, ça fonctionne.

Mon erreur a été de déposer le zip sur mon hébergement, puis de le décompresser directement sur le serveur via l'accès ssh.

Cela pose visiblement des problèmes de droits dans l'arborescence créée.

La bonne méthode est donc de dézipper le fichier en local, puis d'envoyer le tout par FTP.

Concernant le fichier .ovhconfig, voici ce qui fonctionne pour moi :

app.engine=php
app.engine.version=7.0
http.firewall=none
environment=production
container.image=stable

Merci

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Je confirme cette solution, j'ai eu un soucis avec ma mise à jour.

J'ai deux site chez eux, je ne savais pas installer la mise a jour sur le premier, mais bien sur le deuxième. j'ai donc collationner les deux config et j'ai adapté la config du site défaillant.

 

Pour se faire, j'ai changé la valeur du app.engine.version en 7.3 et non 7.0

 

Bonne chance à vous...

Partager ce message


Lien à poster
Partager sur d’autres sites

  • Contenu similaire

    • Par jasongouzien
      Bonjour je voulais savoir, lorsque j'ai mis un "lorem ipsum" pour tester si le texte était responsive avec mon pied de page, je me suis aperçu d'un bug !
      Vous pouviez regarder le code source, pour voir d'ou proviendrai le bug > page en question.
       

    • Par jasongouzien
      Bonjour à tous,
      Je viens de regarder dans les paramètres de Zwii,
      mais je ne trouve plus l'option pour activer le pied de page fixe.
      Avez-vous une idée ?
       
      Amicalement, Jason.
    • Par jasongouzien
      Bonjour j'ai aperçu un petit problème concernant le module : "edit".
      Quand le pied de page est en position fixe la page d'édition n'est pas totalement complète.
       
      Version de Zwii : 10.2.09.
      Site utilisant Zwii : https://jason.gouzien.org/
       
      Image avec le pied fixe :

       
      Image avec le pied non fixe :

       
×
×
  • Créer...