Aller au contenu
Support de Zwii
  • 0
Iron

[RESOLU] Thème / Footer : les colonnes du contenu personnalisé s'affichent en lignes

Question

Je rebondis sur ce sujet intéressant.

 

Je voudrais un pied de page personnalisé mais avec 3 colonnes, comme ceci :

 

piedpage.jpg.b42f7bf0f74161c9b19633ecf23829b6.jpg

 

3 colonnes qui permettraient donc de mettre des infos perso.

 

Le hic, c'est que ça marche pas, ça met les 3 textes les uns en dessous des autres.

 

@Fred comment réussir à faire ça ? Merci

Modifié par Iron
  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites

11 réponses à cette question

Messages recommandés

  • 0

Il faut éditer le custom.css et y insérer :

#footerText div {	
  	display: inline-flex;
	float: left;
}

C'est une solution à moitié satisfaisante, le navigateur ne cesse d'insérer des <br> dans la div, et je n'ai pas encore trouvé comment l'en empêcher

@Gilux aura peut-être une solution avant moi.

 

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

La correction sera publiée ce soir 9.2.20 en même temps qu'un warning dans main.php.

Merci de modifier le sujet et d'ajouter  [RESOLU]

  • J'aime 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Merci @Fred.

ça fonctionne nikel ! Je m'attendais pas à que ça soit un bug. Mais c'est cool c'est corrigé😍

 

1999831009_piedpagecorrig.thumb.jpg.8d1275239e1bf307d3ef714fa0fab749.jpg

 

 

EDIT :

 

Par contre, le redimensionnement via Smartphone garde les textes les uns à coté des autres :

piedpagesmartphone.jpg.7f81735fa519274e0de5c63f018fbf15.jpg

 

Bon, on est d'accord que ce pied de page est "extrême", mais il serait plus judicieux que les 3 colonnes soient pour le coup, les unes en dessous des autres pour la lisibilité sur Smartphone (sinon ça va tronquer des lignes un peu longues et ça fait pas beau).

 

Désolé de t’embêter @Fred encore avec ça 😋

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Iron, hum j'aurais dû tester la config smartphone, effectivement, les blocs doivent être en ligne pour le coup.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Fred, oui je vérifie souvent dans les 2 affichages.

On veille au grain Fred pour toi ! T'inquiètes, tu peux pas penser à tout. 😜

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

En attendant une autre solution, common.css, tu peux ajouter ce qui est en surbrillance :

 

image.png.9ba593dcd6ec8b7fb8879e4c08b2f63c.png

 

Cela dit il faudra que je trouve pourquoi il y a des <br> en plus. Là je sèche.

  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Merci pour la solution en attendant ! 👌

Pour les <br>, peut être que nous aurons quelqu'un du forum pour nous trouver la solution. 🤞

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'ai trouvé !!!!

 

RIen à voir avec le CSS !

 

A corriger dans core.php

 

	/**
	 * Affiche le texte du footer
	 */
	public function showFooterText() {
		if($footerText = $this->getData(['theme', 'footer', 'text']) OR $this->getUrl(0) === 'theme') {
			echo '<div id="footerText">' . $footerText . '</div>';
		}
	}

Tu peux noter ton sujet comme résolu. Je publierai l'update demain.

  • J'aime 1
  • Merci 1

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...