Aller au contenu
Support de Zwii et Yocto
  • 0
mulanee

[résolu] Zwii chez free, dernière version

Question

Bonjour,

Attiré par le programme alléchant de Zwii, je me suis inscrit ici.

Je cherche un CMS simple sans database, pour créer un blog d'articles sur free.fr avec des photos et des videos .

Je suis chez Free sans database (pour l'instant, à force d'attendre ça viendra peut-etre un jour).

Je cherche une version qui fonctionne chez free, j'ai trouvé ce post, est-ce la dernière version?

 

http://mickaphoto.free.fr/ZwiiCMS-8.1.0-Free.zip

 

D'autre part le plugin n'est pas joignable.

http://forum.zwiicms.com/index.php?/files/file/45-zwii-chez-free/

 

Merci.

 

edit:le lien ne fonctionne pas

 

Modifié par mulanee

Partager ce message


Lien à poster
Partager sur d’autres sites

Messages recommandés

  • 0

Bonjour mulanee,

Je te souhaite la bienvenue sur notre espace communautaire.

 

Les liens que tu cites au dessus ne fonctionnent plus ainsi que le lien pour cette version là de Zwii chez free ont été retiré du téléchargement par leur propriétaire.

 

Actuellement tu peux télécharger la toute dernière version de ZwiiCMS ici:

https://zwiicms.com/public/archive/ZwiiCMS-9109.zip

 

Pour son installation chez Free il te faudra vérifier à la base de ton espace web chez eux qu'un dossier nommé "sessions" est bien présent sinon il te faudra les créer manuellement.

Essaie ainsi et reviens nous donner le résultat au cas ou tu n'aurais pas pu installer cette version là.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 31 minutes, roger a dit :

Bonjour mulanee,

Je te souhaite la bienvenue sur notre espace communautaire.

 

Les liens que tu cites au dessus ne fonctionnent plus ainsi que le lien pour cette version là de Zwii chez free ont été retiré du téléchargement par leur propriétaire.

 

Actuellement tu peux télécharger la toute dernière version de ZwiiCMS ici:

https://zwiicms.com/public/archive/ZwiiCMS-9109.zip

 

Pour son installation chez Free il te faudra vérifier à la base de ton espace web chez eux qu'un dossier nommé "sessions" est bien présent sinon il te faudra les créer manuellement.

Essaie ainsi et reviens nous donner le résultat au cas ou tu n'aurais pas pu installer cette version là.

 

Merci, je vais essayer comme ça.

Néanmoins je crois qu'il va falloir modifier le .htaccess au moins pour forcer la version de php en 5.6 je présume.

De plus j'ai parcouru le forum sans trouver de réponse définitive, faut-il vraiment tout uploader dans / ou peut-on uploader dans une sous-directory comme /zwii par exemple?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 11 minutes, mulanee a dit :

Néanmoins je crois qu'il va falloir modifier le .htaccess au moins pour forcer la version de php en 5.6 je présume.

 

il y a 12 minutes, mulanee a dit :

tout uploader dans / ou peut-on uploader dans une sous-directory comme /

 Concernant le premier point j'ai chez Free une version installée en 2018 et dans son .htaccess cette instruction:

# Active la dernière version de PHP5 
<ifDefine Free>
 PHP56 1
</ifDefine>

je ferais un essai cet aprem chez ce fournisseur pour installer la dernière version officielle et verrai si ça marche toujours.

 

Sur cet espace de test chez Free, mes Zwii y sont installés dans leur propres dossiers.

 Tu envoies simplement le dossier du cms décompressé à la racine de ton espace chez Free (bien entendu tu peux changer le nom de ce dossier comme par exemple:  ZwiiCMS1, MonZwii etc... et autant de dossier du cms que tu veux y installer de Zwii)

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 3 minutes, Fred a dit :

@roger pourrait proposer une mise à jour à télécharger pour Free ?

C'est ce que je vais tenter de regarder cet aprem (car il me semble que je suis le seul maintenant à posséder un copte chez Free),

🛠️ Je ferais un essai depuis la dernière version officielle sortie pour être certain que les V9.x.xx y fonctionnent tout aussi bien que les anciennes versions en V8. 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

J'ai installé.

  • Il y a un problème avec le .htaccess fourni> Erreur 500 - Erreur interne du serveur , que ce soit dans la sous directory ou dans la racine.
     
  • Un .htaccess déjà existant à la racine (qui fonctionne par ailleurs), en désactivant le .htaccess fourni donne:

Warning: file_get_contents(.htaccess): failed to open stream: No such file or directory in /var/www/sdb/c/6/nejlabzt/Zwii/core/core.php on line 1498

Warning: Cannot modify header information - headers already sent by (output started at /var/www/sdb/c/6/nejlabzt/Zwii/core/core.php:1498) in /var/www/sdb/c/6/nejlabzt/Zwii/core/core.php on line 1091

Ce .htaccess:

 

ErrorDocument 404 /error.php
ErrorDocument 403 /error.php
# Spécification des jeux de caractères des documents (ajoutez les extensions que vous utilisez)
AddCharset utf-8 .css .xml .po .php .js

# activation php5 (free.fr)
<ifDefine Free>
 PHP56 1
</ifDefine>

# Protection du fichier .htaccess
<Files .htaccess>
Order Deny,Allow
Deny from all
</Files>

# Protection du fichier wp-config.php
<files wp-config.php>
order Deny,Allow
deny from all
</files>

# Désactivation de l'affichage des répertoires
Options All -Indexes

# Inactivation des rewrite rule de WordPress sur FREE.
<IfDefine !Free>
# BEGIN WordPress

# END WordPress
</IfDefine>

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 6 minutes, mulanee a dit :

Il y a un problème avec le .htaccess fourni> Erreur 500 - Erreur interne du serveur , que ce soit dans la sous directory ou dans la racine.

je suis en train de faire les essais:

 

changes tout le .htaccess de la version officielle en ceci:

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0
# Bloque l'accès à la liste des fichiers
Options -Indexes
# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

 normalement tu va arriver sur la seconde erreur que je cherche à résoudre:    à savoir que le chemin vers le fichier install du zwii n'est pas trouvé (page 404) et bien que rajoutant le point d'interrogation manquant....

➡️ L'adresse de la page d'installation devrait être écrite ainsi /ZwiiCMS-9109/?install

free.thumb.png.81da23c7009168818247ab2a3a99383f.png

 

 

Je continue donc les essais pour essayer de proposer une solution (Free n'étant pas mon fournisseur mais juste un "vieux compte" que j'ai chez lui depuis des lustres)

 

Une vieille version que j'ai encore en ligne montre que Free (bien que l'on ne peut toujours pas activer la redirection d'url) fait tourner comme il faut un zwii installé dans une sous dossier

(une v8.2.5) ➡️ http://lechti64.free.fr/ZwiiCMS-8.2.5/?accueil

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

EDIT en urgence :

 

Mettre le ? (aprés 4 essais infructueux) m'a enfin permis d'arriver à la page d'installation de la dernière version officielle (avec le .htaccess modifié comme expliqué au dessus)

free1.thumb.png.c52c1e2b784c91c5c3a4b5df7f5f46b6.png

 

Je poursuis le test pour voir si ça va installer la version correctement.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Installation réussie mais gros blème avec les urls, il faut rajouter le fameux ? avant  chaque nom de page appelé depuis le menu pour arriver sur la bonne page... et impossible d'accéder à la page de connexion (même en ajoutant de ? dans son adresse) pour régler le site.

 

➡️  http://lechti64.free.fr/ZwiiCMS-9109/?accueil

 

@Fred  et @mulanee

essayez en cliquant sur les liens du menu, puis à l'erreur 404 ajouter alors le fameux ? avant le nom de la page appelée pour voir.

 

Pour arriver à la page de connexion il faut écrire ceci comme adresse : http://lechti64.free.fr/ZwiiCMS-9109/?user/login/accueil

 

Donc bien ajouter le ? derrière le / aprés le nom du dossier du zwii   ➡️  http// nom du domaine /nom du dossier du zwii/?lapage

ou comme ici  nom du domaine /ZwiiCMS-9109/?user/login/accueil

 

Modifié par roger

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 22 minutes, roger a dit :

changes tout le .htaccess de la version officielle en ceci:


# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0
# Bloque l'accès à la liste des fichiers
Options -Indexes
# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

 

On ne dit pas de passer en php 5.6?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 3 minutes, mulanee a dit :

On ne dit pas de passer en php 5.6?

 Plus besoin, c'est inclus dans le index.php

 

par contre il faudra avec mon astuce du ? à ajouter bien expliqué au dessus aller dans la config du site pour désactiver l'url de redirection qui y est automatiquement cochée pour que le zwii derniere mouture fonction chez Free

 

free2.thumb.png.d3c65d3f2be2f7ec6c72d46e0cf5a892.png

 

free4.thumb.png.7f9edf896a874b8580c1a3690ce19e58.png

 

je pense que @Fred sera plus calé que moi pour te dire où il faudrait modifier cette histoire de redirection automatiquement activée dans la version que je viens d'installer.

 

En tout cas il est possible "provisoirement" d'installer à l'arrache la toute dernière version du cms en modifiant juste le .htaccess et avec un peu de gymnastique des doigts pour ajouter le fameux ? arriver à la config du zwii pour désactiver cette option; ce que je viens de faire et qui me donne maintenant un zwii dernière mouture chez Free si vous suivez le lien ci dessous

 

http://lechti64.free.fr/ZwiiCMS-9109/?accueil

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 21 minutes, roger a dit :
il y a 37 minutes, mulanee a dit :

On ne dit pas de passer en php 5.6?

 Plus besoin, c'est inclus dans le index.php

 

Ca ne marche pas chez moi, il me dit qu'il veut du php 5.6

 

edit:rectification, ça fonctionne, je me suis mélangé les pinceaux dans tous mes .htaccess

Je continue l'install

edit2:la case de réécriture d'url n'était pas cochée

Modifié par mulanee

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Il y a un problème avec le gestionnaire de fichier, la page est vide.

Quand on veut uploader un média il y a un message d'erreur.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Chez free voici le htaccess complet :

# activation php5 chez Free
<ifDefine Free>
 PHP56 1
</ifDefine>

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

Tu ne pourrais pas faire d' update auto vu que désormais il est écrasé à chaque mise à jour.

 

.htaccess

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 5 heures, mulanee a dit :

edit:rectification, ça fonctionne, je me suis mélangé les pinceaux dans tous mes .htaccess

J'ai essayé les deux solutions, dont celle qui contient l'instruction dans le .htaccess pour le php chez free comme je te l'ai expliqué plus haut

 

Il y a 8 heures, roger a dit :

Concernant le premier point j'ai chez Free une version installée en 2018 et dans son .htaccess cette instruction:


# Active la dernière version de PHP5 
<ifDefine Free>
 PHP56 1
</ifDefine
Il y a 6 heures, roger a dit :

changes tout le .htaccess de la version officielle en ceci:


# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0
# Bloque l'accès à la liste des fichiers
Options -Indexes
# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

 

Et même sans cette instruction (donc juste le code cité au dessus) et bien le zwii fonctionne cchez Free comme le montre mon dernier lien fourni.

 Le .htaccess utilisé chez moi pour ce site qui contient la dernière version officielle de zwii:

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0
# Bloque l'accès à la liste des fichiers
Options -Indexes
# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting

En tout cas super que tu ai pu l'installer chez toi, les petits "bobos" ultérieurs se régleront au fur et à mesure.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 4 heures, mulanee a dit :

Il y a un problème avec le gestionnaire de fichier, la page est vide.

Quand on veut uploader un média il y a un message d'erreur.

Même problème relevé sur la version que j'ai installé cet après midi.

De plus j'ai été obligé de rajouter le fameux ? pour accéder au pages et quand je suis retourné dans la config du site, la redirection d'url était cochée alors que je l'avais désactivé (Free ne gérant toujours pas la redirection d'url).

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 4 heures, roger a dit :

Même problème relevé sur la version que j'ai installé cet après midi.

De plus j'ai été obligé de rajouter le fameux ? pour accéder au pages et quand je suis retourné dans la config du site, la redirection d'url était cochée alors que je l'avais désactivé (Free ne gérant toujours pas la redirection d'url).

 

 

Aucun problème chez free.fr, l'url rewriting est désactivé par défaut, l'install se déroule sans problème et le rfm est ok !

 

rfm.jpg.907e71dacb73e028f6728bdb840712d8.jpg

 

blog1.jpg.2de21e41c01d28149bc84a32f9359cb4.jpg

 

blog2.jpg.eb5c40772ad9e42c41729be78e66b94d.jpg

 

Contenu du .htaccess :

<ifDefine Free>
 PHP56 1
</ifDefine>

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers + Désactive l'option de substitution automatique
Options -Indexes -MultiViews

Version de Zwiicms installée 9.1.09 10/6/2019

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 10 heures, mulanee a dit :
  Il y a 11 heures, roger a dit :
Il y a 11 heures, mulanee a dit :

On ne dit pas de passer en php 5.6?

 Plus besoin, c'est inclus dans le index.php

 

N'importe quoi pourvu qu'ça mousse !

Bien évidemment qu'il faut ajouter :

 PHP56 1

Dans le htaccess chez free.fr, sinon on se retrouve avec du php 4, le fichier index de zwiicms ne fait que contrôler que la version de php est conforme :

/**
 * Vérification de la version de PHP
 */
if(version_compare(PHP_VERSION, '5.6.0', '<')) {
	exit('PHP 5.6+ required.');
}

mais n'a jamais eu pour rôle de modifier la version de php sur le serveur des pages perso de free.fr 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 8 heures, Gilux a dit :

N'importe quoi pourvu qu'ça mousse !

en réponse un test en live avec les deux instructions écrites dans le .htaccess (Free est capable d'afficher le zwii avec ou sans la déclaration du php à cet endroit)

 

Free gérant depuis déjà quelques temps chez eux  le PHP en version 5.x et passera prochainement en PHP 5.6 et PHP 7.3 comme en atteste cette pâge (non officielle mais bien connue des Freenautes) ==>  http://les.pages.perso.chez.free.fr/migrations/php5v6.io

 

Citation

La mise en production de cette nouvelle version sera progressive, et les anciennes versions (4.4.3 et 5.1.3) seront maintenues sur les serveurs une fois le basculement vers la nouvelle version effectué. Les utilisateurs devront alors vérifier que leurs scripts sont compatibles et éventuellement migrer vers de nouvelles versions de CMS. Parfois, il faudra réécrire ces scripts pour les adapter au nouvel environnement.

citation prise depuis la page web ci dessus

et depuis la page officielle de chez Free, depuis 2015 nous pouvons lire...pour le PHP5.6  ==> https://www.freenews.fr/freenews-edition-nationale-299/services-web-180/pages-perso-free-ajout-support-php-5-6

 

d'où la nécessité de vérifier les sources et faire nos essais en conséquence...pour que çà  b548096abc1f9704d8cee7003f5a68aa(1).jpg.93f41568fc0f1479e867458606a27cc2.jpg

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 2 heures, roger a dit :

d'où la nécessité de vérifier les sources et faire nos essais en conséquence...pour que çà  b548096abc1f9704d8cee7003f5a68aa(1).jpg.93f41568fc0f1479e867458606a27cc2.jpg

Oui, et bien vérifie ceci :

En supprimant 

<ifDefine Free>
 PHP56 1
</ifDefine>

du .htaccess, et en se connectant au site en ligne chez free, voici ce que Zwiicms affiche :

PHP 5.6+ required.

Un simple

phpinfo();

permet de voir ceci :

phpinfo-free.png.9f2b482220fffa73e929bc36677ff0d5.png

 

Ceci permettant de constater que php 5.6 n'est pas la version par défaut, mais que celle-ci est php 4.4.3

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 5 minutes, Fred a dit :

Il y a donc un pb avec htaccess

Plus globalement c'est avec free.fr qu'il y a un, voir plusieurs pbs avec des versions php largement obsolètes et bridées. Mais bon, c'est gratos à vie, faut pas trop faire la fine bouche.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Il y a 5 heures, roger a dit :

en réponse un test en live avec les deux instructions écrites dans le .htaccess (Free est capable d'afficher le zwii avec ou sans la déclaration du php à cet endroit)

Cet après midi étant relativement calme au bureau, je viens de prendre le temps de visionner ta vidéo, dans tes 11'11'' de demo tu ne rends pas compte que ton espace chez free contient un fichier .htaccess de 8 octets à la racine :

roger2.png.6c5f25e671cb23c9111ea8e928652bb0.png

et 8 octets correspondent exactement à :

 PHP56 1

et donc que ce fichier .htaccess de 8 octets présent à la racine prime sur ceux présents dans tes sous-dossiers, dans l'un desquels est installé le Zwiicms de ta démo, tu peux alors évidemment y ajouter ou y enlever l'instruction sans qu'aucun effet ne se produise !
Si ce n'est de la malhonnêteté, ce que je ne pense pas, c'est au moins de l'ignorance dont tu fais preuve, refait le test en condition réelle : 1 espace web chez free => 1 (et 1 seul) site à la racine, et dis-nous quoi...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

@Gilux je te redonne le htacces qui va bien en PJ. Pour faire fonctionner le gestionnaire de fichier chez Free, il faut modifier la configuration de /core/vendor/filemanager/confog/config.php et commentet cette ligne

/*mb_regex_encoding('UTF-8');*/

Ci-joint le fichier.

config.php

.htaccess

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
il y a 2 minutes, Gilux a dit :

Si ce n'est de la malhonnêteté, ce que je ne pense pas, c'est au moins de l'ignorance dont tu fais preuve, refait le test en condition réelle : 1 espace web chez free => 1 (et 1 seul) site à la racine, et dis-nous quoi...

 

 

il y a 5 minutes, Gilux a dit :

refait le test en condition réelle : 1 espace web chez free => 1 (et 1 seul) site à la racine

Je ne met aucun zwii à la racine de cet espace free car cet espace ne me sert uniquement que pour tester des versions de zwii (en plus d'autre cms), donc je suis obligé de les mettre tous dans un sous dossier pour ne pas écraser une précédente version d'un zwii testé là bas

 

il y a 5 minutes, Gilux a dit :

dans tes 11'11'' de demo tu ne rends pas compte que ton espace chez free contient un fichier .htaccess de 8 octets à la racine :

C'est la taille donnée par mon FTP de même que si tu regardes bien tu as une drôle d'erreur sur ta capture d'écran!!!

 

A la minute 3.19 comme le prouve ma capture d'écran prise ici de ma vidéo au dessus, ce fichier .htaccess fait exactement 255 octets

_hat.thumb.png.bf79e8d5d097ffa53bec44a81b52ab56.png

 

il y a 14 minutes, Gilux a dit :

tu peux alors évidemment y ajouter ou y enlever l'instruction sans qu'aucun effet ne se produise !

Je ne triche jamais quand je fais une démo en live car une vidéo montre directement les opérations effectuées, donc je n'ai aucun interet à "truquer" une vidéo avec un faux fichier...

 

Voici donc en pièce jointe mon .htaccess en ligne chez free pour cette version là, exactement le me fichier qu'à donné Fred en exemple et il pèse sur mon pc 227 octets pas le me poids que chez Free!!!

..htaccess

 

Donc je ne pense pas faire preuve d'ignorance à ce sujet là.

Pour preuve mon php info chez Free actuellement est en version 5.6.34 vérifiable facilement par tous ici ==>  http://lechti64.free.fr/phpinfo.php

 

Oui quand on "est à la page" et bien on active ou met à jour toute chose y compris chez free, donc devoir me justifier chaque fois sur ce que j'écris ou affirme devient lassant à la fin, surtout que c'est facilement vérifiable comme cette histoire de PHP avec simplement un fichier placé  ici à la racine de mon espace web chez free et dont vous pouvez vérifier par vous me que je ne raconte pas de "bêtise" avec le lien que je fourni juste au dessus et qui vous mènera alors vers ceci:

php232.thumb.png.45243906db84ee6f06350f16257332a1.png

 

Je ne prend pas à la légère tout ce qui se dit sur moi, donc si une chose doit être mise au point je le fait avec preuve à l'appui.

Fin de cette discussion pour moi car elle n'aide pas à la résolution d'un problème donné.

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...