Aller au contenu
Support de Zwii
  • 0
Marie-Anne

Bug htaccess version 9.1.07

Question

Hello les amis, depuis la mise à jour 9.1.07, le htaccess est vidé des ajouts faits et dès que je veux  mettre mes optimisations ça me donne une erreur 500 🤣🤣

 

Mon fichier HTACCESS qui fonctionné 

 

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting
<ifModule mod_rewrite.c>
    RewriteEngine on
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*)$ index.php?$1 [L]
</ifModule>

RewriteEngine On
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]

RewriteCond %{HTTP_HOST} !^www\.
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Turn on IE8-IE9 XSS prevention tools
Header set X-XSS-Protection "1; mode=block"

<IfModule mod_headers.c>
Header set X-Frame-Options "SAMEORIGIN"
<FilesMatch "\.(appcache|atom|bbaw|bmp|br|crx|css|cur|eot|f4[abpv]|flv|geojson|gif|gz|htc|ic[os]|jpe?g|m?js|json(ld)?|m4[av]|manifest|map|markdown|md|mp4|oex|og[agv]|opus|otf|pdf|png|rdf|rss|safariextz|svgz?|swf|topojson|tt[cf]|txt|vcard|vcf|vtt|wasm|webapp|web[mp]|webmanifest|woff2?|xloc|xml|xpi)$">
Header unset X-Frame-Options
</FilesMatch>
</IfModule>

Header set X-Content-Security-Policy "allow ‘self’; script-src *lafermedupaquisfleury.fr report-uri /report_XSS;"

# prevent mime based attacks
<IfModule mod_headers.c>
Header set X-Content-Type-Options "nosniff"
</IfModule>

# Protege le fichier htaccess
<files .htaccess>
order allow,deny
deny from all
</files>

# Encodage des caractères
AddDefaultCharset utf-8

<IfModule mod_deflate.c>
AddOutputFilterByType DEFLATE application/font-woff text/html text/plain text/xml application/xml application/xhtml+xml text/css text/javascript application/javascript application/x-javascript
</IfModule>

# BEGIN Expire headers
<IfModule mod_expires.c>
ExpiresActive On
ExpiresDefault "access plus 7200 seconds"
ExpiresByType image/jpg "access plus 2592000 seconds"
ExpiresByType image/jpeg "access plus 2592000 seconds"
ExpiresByType image/png "access plus 2592000 seconds"
ExpiresByType image/gif "access plus 2592000 seconds"
AddType image/x-icon .ico
ExpiresByType image/ico "access plus 2592000 seconds"
ExpiresByType image/icon "access plus 2592000 seconds"
ExpiresByType image/x-icon "access plus 2592000 seconds"
ExpiresByType text/css "access plus 2592000 seconds"
ExpiresByType text/javascript "access plus 2592000 seconds"
ExpiresByType text/html "access plus 7200 seconds"
ExpiresByType application/xhtml+xml "access plus 7200 seconds"
ExpiresByType application/javascript A2592000
ExpiresByType application/x-javascript "access plus 2592000 seconds"
ExpiresByType application/x-shockwave-flash "access plus 2592000 seconds"
</IfModule>
# END Expire headers

# BEGIN Cache-Control Headers
<IfModule mod_headers.c>
<FilesMatch "\.(ico|jpe?g|png|gif|swf|css|gz)$">
Header set Cache-Control "max-age=2592000, public"
</FilesMatch>
<FilesMatch "\.(js)$">
Header set Cache-Control "max-age=2592000, private"
</FilesMatch>
<filesMatch "\.(html|htm)$">
Header set Cache-Control "max-age=7200, public"
</filesMatch>
# Disable caching for scripts and other dynamic files
<FilesMatch "\.(pl|php|cgi|spl|scgi|fcgi)$">
Header unset Cache-Control
</FilesMatch>
</IfModule>
# END Cache-Control Headers

# KILL THEM ETAGS
Header unset ETag
FileETag none

# Masquer les informations du serveur
ServerSignature Off

 

 

La seule solution reste que j’écrase avec mon fichier de la version précédente pour que cela fonctionne 😋

Bizarre de ne pas pouvoir modifier le fichier htaccess ^^

Modifié par Marie-Anne
  • Triste 1

Partager ce message


Lien à poster
Partager sur d’autres sites

4 réponses à cette question

Messages recommandés

  • 0

Bonsoir,

Il me semble, de mémoire, que certains avaient signalés que le .htaccess devenait incohérent car il reprenait ce que le .htaccess en place intégrait, ou quelque chose dans ce genre : la solution proposée et adoptée avait été de carrément remplacer le .htaccess... ce n'est peut-être pas tout à fait ça mais ce comportement résulte d'une discussion antérieure pour répondre au problème du moment.
Maintenant le problème est tout autre.

Peut-être que dans le cas d'une nouvelle installation et bien le .htaccess de zwii est tout simplement mis en place et dans le cas d'une mise à jour la question au moment de la mise est jour est posée pour remplacer ou pas le .htaccess trouvé ? Celui qui l'a modifié le sait évidemment et répond Non et celui qui ne sait pas de quoi on parle répond Oui (on lui met un petit message indiquant que s'il ne sait pas de quoi il s'agit il clique Oui).

Ou encore le .htaccess trouvé est sauvegardé et à la fin il y a un message qui indique "Votre .htaccess a été remplacé et sauvegardé à tel endroit"

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0

Lors des mises à jour, si on le livre pas le htaccess et la réécriture d'url est active, on se retrouve avec un cumul de paramètres.

Donc Zwii était paramétré pour que le htaccess soit livré lors des mises à jour auto.

 

Ton fichier ne doit pas avoir les droits en écriture c'est pour cela qu'il est verrouillé.

 

Cela-dit, je le trouve bien tordu ce htaccess

 

Partager ce message


Lien à poster
Partager sur d’autres sites
Invité
Ce sujet ne peut plus recevoir de nouvelles réponses.

×
×
  • Créer...