Aller au contenu
Support de Zwii

Rechercher dans la communauté

Affichage des résultats pour les étiquettes 'zwiicms'.



Plus d’options de recherche

  • Rechercher par étiquettes

    Saisir les étiquettes en les séparant par une virgule.
  • Rechercher par auteur

Type du contenu


Forums

  • Support de Zwii
    • Informations et nouveautés
    • Ateliers de développement
    • Un bug découvert ?
    • Questions sur l'installation et l'utilisation
    • Trucs et astuces
    • Support des téléchargements
  • Communauté
    • Votre site

Catégories

  • Versions bêta
  • Modules
    • Modules officiels
    • Galeries
  • Modifications et astuces
  • Thèmes
  • Tutoriels

Rechercher les résultats dans…

Rechercher les résultats qui contiennent…


Date de création

  • Début

    Fin


Dernière mise à jour

  • Début

    Fin


Filtrer par nombre de…

Inscription

  • Début

    Fin


Groupe


À propos de moi


Site internet

5 résultats trouvés

  1. Bonjour, Il s'agit de l'ex-version 10 sans la gestion multi-langues qui s’installera, sur une v9 (et non une v8) ou un dossier vierge. Cette version stocke toujours les données dans des fichiers json, mais elle a la particularité de fonctionner comme une base de données. Alors que le Zwii de la v9 lisait et écrivait toutes les données en une fois ; même celles inutiles ; cette v10 n'accède qu'aux données nécessaires. Il en résulte un temps de traitement accéléré qui sera surtout visible pour les gros sites. De même, elle fonctionnera sans problème de ralentissement derrière un proxy web. Le script core.php est allégé, les classes templates et helper qui sont indispensables au fonctionnement de Zwii sont chargées dans core/class On y trouve également les classes : mailer, sitemap et jsondb. Il n'y aura pas d'autres améliorations ou ajouts de fonctionnalités avant sa sortie, je laisse passer la période des fêtes pour la publication. L'archive ci-dessous est estampillée 10.0.013, le git est susceptible de disposer d'une version légèrement plus récente sous ce lien. A priori cette version est utilisable en production (après copie de sauvegarde). ZwiiCMS-beta-v10.119.zip
  2. Bonsoir, J'ai testé favicon-switcher sans pouvoir activer le mode sombre qui va bien sur Firefox pour faire un test, il faut peut-être que celui-ci soit activé au niveau de l'OS. Pour une installation de test, c'est très simple, il suffit d'éditer core.php et de modifier la fonction showfavicon avec le script fourni en exemple : <link rel="icon" media="(prefers-color-scheme:dark)" href="favicon-dark.png" type="image/png" /> <link rel="icon" media="(prefers-color-scheme:light)" href="favicon-light.png" type="image/png" /> <script src="https://unpkg.com/favicon-switcher@1.2.0/dist/index.js" crossorigin="anonymous" type="application/javascript"></script> Evidemment, il faut créer deux images avec les noms et formats corrects. Si vous arrivez à le faire fonctionner, je ferai un intégration avec une modification du l'écran config pour le choix de la seconde favicon. @roger, tu devrais retester la méta image, elle est bien générée. En ce qui concerne le JS dans RFM, il est traité comme un fichier éditable selon config.php c'est sûrement pourquoi l'extension est renommée. Ensuite si tu veux le charger, proprement, il existe le dossier vendor qui permet cela, regarde vendor/imagemap pour voir comment ça marche (et la variable $output de core.php)
  3. Pour info, je viens de mettre le site https://www.precyplan.org à jour avec toujours autant de plaisir. Merci pour ce fabuleux outil qu'est zwii !
  4. Juste un petit truc sympa dont tout le monde parle et dont pas mal " produisent " pour le zwii ce qui plais à l'utilisateur final.... La version officielle a comme éditeur de texte " TinyMCE " Une version est proposée avec CKEditor... D'autre versions de l'éditeur de texte sont en cours d’élaboration dont certains très avancés à ce jour. Et tous je ne doute pas seront ou sont déjà compatibles avec un zwii, ci dessous ce que mes oreilles ont ouï ces derniers temps... Markedown, BBcode+ ( un scoop pour qui sait me décrypter ), ContentTools et consorts Ne serait il pas possible d'adjoindre à Zwii la possibilité de choisir son propre éditeur de texte depuis la configuration ce celui ci, sachant que les éditeurs de texte sont des " modules fonctionnels " facilement téléchargeables sur le forum ( pour peu qu'ils soient mis à jour avec les versions du zwii ) et installables dans n'importe quelle version d'un zwii.... De base , le cms serait proposé avec son éditeur de texte officiel, mais un utilisateur qui aurait alors téléchargé sur le forum un autre " module éditeur " aurait alors la possibilité de l'activer dans son interface administrative du Zwii, ne l'obligeant pas ainsi à télécharger une version spéciale du zwii qui aurait son éditeur préféré par défaut déjà intégré dans cette version d'un zwii. Beaucoup de cms basique comme l'est zwiicms proposent justement ce genre de choix en regard des "plugins" ou "modules" à télécharger chez eux, ce serait un sacré plus pour ton cms Rémi je pense. Si cela pouvait aissi être couplé à des " thèmes préconçus " se serait le top.
  5. Dans le core.php au niveau de la mise à jour à vérifier à l'installation je retrouve ceci : n'aurait il pas fallut préciser dans la version commentée avant son installation que celle ci est la 8.1.2 ? Ici :
×
×
  • Créer...