Aller au contenu
Support de Zwii et Yocto

PeterRabbit

Modérateurs
  • Compteur de contenus

    2 264
  • Inscription

  • Dernière visite

Réputation sur la communauté

453 Excellent

À propos de PeterRabbit

Visiteurs récents du profil

1 331 visualisations du profil
  1. PeterRabbit

    [Module] Zwiiper, le retour

    @augras, je crois que tu connais mieux ce plugin que moi : quand je ne suis plus dans les choses, je les oublie très vite (mon boulot m'a fait une mémoire LIFO). Je viens de survoler mon mode d'emploi et je comprends maintenant pourquoi tu parles de "Banner" : ça me semblait clair à l'époque, mais au temps pour moi... C'est le même Swiper, c'est seulement la position qui change.
  2. PeterRabbit

    [Module] Zwiiper, le retour

    @augras "Banner" ? Mon plugin peut s'installer en bannière ou dans une page, même si j'ai largement eu le temps de l'oublier. Sur mon site d'essais, il est en bannière, c'est tout. J'ai bien traduit "Swiper", d'autant que je sais qu'il te plaît. Je réponds dans ton sens depuis le début et je suis en phase avec les barres latérales, Je réexplique. Remplace le contenu de "swiperslides.inc.php" par celui-ci, et essaie : tu pourras revenir en arrière. <div class="swiper-container swiper-container-horizontal" id="swiper"> <div class="swiper-wrapper"> <div class="swiper-slide">Slide 1</div> <div class="swiper-slide">Slide 2</div> <div class="swiper-slide">Slide 3</div> <div class="swiper-slide">Slide 4</div> <div class="swiper-slide">Slide 5</div> <div class="swiper-slide">Slide 6</div> <div class="swiper-slide">Slide 7</div> <div class="swiper-slide">Slide 8</div> <div class="swiper-slide">Slide 9</div> <div class="swiper-slide">Slide 10</div> </div> Je l'ai essayé pour te faire une copie d'écran. Avec un peu de css, ça peut faire un joli bandeau défilant sans aucun besoin d'image. Et sans flèches de navigation. Il suffit de remplacer "Slide x" par le texte que tu veux avec éventuellement des <br> pour passer à la ligne. Ça je n'ai pas essayé, mais je compte sur toi maintenant. 😄
  3. PeterRabbit

    Version 9.0.0 à tester !

    @augras Ça fait un moment que je fais de la publicité pour les barres latérales. 😄 La seule vraie restriction, depuis que @cybertaf a remplacé l'éditeur de code de TinyMCE, c'est la largeur max (1/3 de la page). Je n'ai pas essayé, mais je pense que tu peux y mettre Swiper, puisque les barres latérales sont des pages (presque) comme les autres. Tiens-moi au courant.
  4. PeterRabbit

    [Module] Zwiiper, le retour

    Non non. Suis le lien ci-dessus et regarde le source comme je t'y encourageais. Copie les divs du <body> dans "swiperslides.inc.php". Pas besoin d'images pour faire défiler du texte.
  5. PeterRabbit

    [Module] Zwiiper, le retour

    Non, @augras, Swiper ne veut pas absolument une image : les démos du site le montrent, et le code source le confirme, pas besoin d'image du tout : Avec un peu de css ce serait mieux... 😶 Mais à l'époque, il y avait des demandes pour un slider. Ceci explique cela. 🙂
  6. PeterRabbit

    déplacement en bloc de Zwii

    @roger En effet, j'ai dit une connerie : pour moi, la non activation de la réécriture des URL a fini par s'associer à Free et à son impossibilité d'activer cette fonction que j'active systématiquement. Mais ça ne change rien (enfin, j'espère tout en craignant le pire) au conseil que j'ai donné.
  7. PeterRabbit

    déplacement en bloc de Zwii

    Je comprends, @jean17. Le .htaccess mini suffit pour une installation à la racine : il fait ce que les commentaires expliquent, ce qui empêche entre autres qu'on puisse explorer tes répertoires comme je l'ai fait pour les besoins de la copie d'écran ci-dessus. Par rapport à la manip que je t'ai expliquée pour avoir un .htaccess tout neuf, ça ne prend pas vraiment pas beaucoup de temps : comme je t'ai expliqué, il suffit de le remplacer par le modèle d'origine pour une installation à la racine. Pour ce qui est des chemins dans "data.json", ça ne prend pas beaucoup plus de temps avec la fonction "Remplacer" de ton éditeur (CRTL-H). Pour une installation à la racine d'un site préparé dans un sous-répertoire, voici ce qu'il faut faire : Éditer "data.json". Avec CTRL-H mettre le nom du répertoire d'origine dans la case "Rechercher" (avec le slash et l'antislash), comme ceci : /nom de ton répertoire\ Ne rien mettre dans la case "Remplacer par". Lancer le remplacement. Même si on peut revenir en arrière (CTRL-Z), travaille sur une copie pour ne pas tout perdre bêtement. 😉
  8. PeterRabbit

    déplacement en bloc de Zwii

    Non non : le contenu du ".htaccess" minimum suffit pour une installation à la racine de l'hébergement. Après, tu peux le mettre où tu veux, le renommer ou le supprimer, c'est pareil : ça n'empêchera pas ton site de fonctionner malgré un avertissement éventuel... mais tu n'auras plus de protection, et sans d'autres ".htaccess" dans les répertoire sensibles, tout serait aussi accessible que ça : Je t'ai expliqué ce que je ferais pour reprendre la main sur ton site. Mais, sauf à interpréter que tu me remerciais de t'avoir donné la solution à ton problème, je ne sais pas grand chose de la suite... 🙄
  9. PeterRabbit

    déplacement en bloc de Zwii

    Sans ".htaccess" ? Je crois que c'est moi qui ai du mal à comprendre : ce fichier assure la première protection de ton site. Fais une copie de "data.json" — renomme-le simplement "data.json0", par exemple. Remplace le fichier ".htaccess" par un modèle d'origine — il suffit de peu pour le corrompre — et refais l'installation. Une fois que ton nouveau site sera gaillard, fais la manip inverse pour le "data.json", et rectifie les liens le cas échéant.
  10. "Mon gosier de métal parle toutes les langues" — de Baudelaire à Google, il n'y a qu'un pas — mais je ne connaissais pas l'expression "qui claque sa mère"... 😕 PS : Tant qu'à passer le plumeau, change aussi les dates des pages exemples : il n'y a guère qu'RJ — et peut-être RG — qui y étaient en 2015 ! Juste l'année : laisse "février", mais ajoute "août" pour les histoires d'accents.
  11. PeterRabbit

    déplacement en bloc de Zwii

    Tu as essayé de vérifier ton fichier .json ("site/data/data.json" pour une 8 ou "site/data/core.json pour une 9) ? Je te renvoie à nouveau aux tutos que nous avons créés avec @Xav7800. Regarde le dernier (la petite voiture jaune avec le capot ouvert). Mais je "suis ton ticket" 😄 N'hésite pas.
  12. PeterRabbit

    Version 9.0.0 à tester !

    Sauf que ce n'est pas ça. Mais si tu sais quelque chose sur le mystère que j'ai signalé ci-dessus, je suis preneur. Je pense d'ailleurs que @roger devrait avoir le même problème que moi, étant chez Ionos et @cybertaf aussi, sur ses sites Obambu. Pour l'instant je ne peux pas envoyer d'autres détails sur ma configuration : Obambu est aux abonnés absents depuis une heure. C'est la première fois qu'ils font le coup.
  13. @cybertaf Warum nicht ? Mais est-il nécessaire de violenter maman pour autant ? 😶
  14. PeterRabbit

    Version 9.0.0 à tester !

    Si... que tu as des cheveux ! 😃
  15. PeterRabbit

    déplacement en bloc de Zwii

    Bonjour @jean17. As-tu modifié l'URL de base dans le fichier ".htaccess" à la racine de ton installation ? # Cache le PHPSESSID de l'url SetEnv SESSION_USE_TRANS_SID 0 # Bloque l'accès à la liste des fichiers Options -Indexes # Attention, surtout ne rien modifier ci-dessous ! # URL rewriting <ifModule mod_rewrite.c> RewriteEngine on RewriteBase /nouveau répertoire/ RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule ^(.*)$ index.php?$1 [L] </ifModule> Ce qu'explique @Xav7800 dans son excellent tuto sur la mise en ligne d'un site depuis une installation locale s'applique aussi à ton cas de figure. PS : Je ne vois pas bien comment le premier site pouvait fonctionner dans un sous-répertoire sans réécriture des URL...
×