• 0
Manu64

.htaccess - https

Question

Manu64    7

Bonjour à tous.

 

Avez-vous pensé au https sur vos sites ?
Pour ceux qui utilisent OVH, le certificat est gratuit.

 

Modification du .htaccess dans <if_module.....

 

RewriteCond %{SERVER_PORT} ^80$ [OR]
RewriteCond %{HTTPS} =off
RewriteRule ^(.*)$ https://nom-de-domaine.extension/$1 [R=301,L]

Partager ce message


Lien à poster
Partager sur d’autres sites

16 réponses à cette question

Messages recommandés

  • 0
LaNamandine    0

Bonjour j'ai un hébergement chez OVH et un certificat SSL Let's Encrypt mais lorsque j'ajoute ce code j’ai l'erreur 500 ci dessous

 

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at postmaster@domaine.fr to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

et le fichier log contient ceci :

[Wed Jan 02 21:26:29 2019] [alert] [client ip] [host domaine.fr] /homez.90/ph/www/.htaccess: Invalid command '\xef\xbb\xbf#', perhaps misspelled or defined by a module not included in the server configuration

 

Comment faire pour résoudre ce problème 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
EBS01    20

Bonjour,

 

Dans ton message d'erreur il est noté

Invalid command '\xef\xbb\xbf#

Avec quel logiciel as-tu édité le fichier htaccess ?

Il semblerait qu'il y ait des caractères incorrects (\xef est par exemple le caractère ï en unicode)

 

Jérôme

  • Thanks 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
LaNamandine    0

Merci @EBS01 pour ta réponse.

Lorsque j'ouvre mon fichier htaccess à partir de FileZilla, il s'ouvre avec le bloc note. J'ai réessayé avec un éditeur de code et tout fonctionne !!!

Mais je n’ai pas trouvé ce que le \xef vient faire dans mon htaccess. Peut être à cause du bloc note...

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
LaNamandine    0

Oui le voici, j'ai la version 8.4.8 de Zwii

# Cache le PHPSESSID de l'url
SetEnv SESSION_USE_TRANS_SID 0

# Bloque l'accès à la liste des fichiers
Options -Indexes

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting
<ifModule mod_rewrite.c>
	RewriteEngine on
	RewriteCond %{HTTPS} =off
	RewriteRule ^(.*)$ https://domaine.fr/$1 [R=301,L] 
	RewriteBase /
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule ^(.*)$ index.php?$1 [L]
</ifModule>
Modifié par LaNamandine

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
EBS01    20

Non le fichier en lui même que je puisse l'ouvrir avec un de mes éditeurs de texte.

 

Modifié par EBS01

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
EBS01    20

Je ne vois rien de particulier (c'est bien le fichier qui pose problème ?) mais tu peux essayer de l'encoder en "UTF-8 without BOM" (avec notepad++ par exemple) car les 3 caractères en question sont bien des caractères invisibles en "Unicode BOM" mais que Apache voit (et ne reconnaît pas) lors de l'utilisation de ton htaccess

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
LaNamandine    0
il y a une heure, LaNamandine a dit :

Merci @EBS01 pour ta réponse.

Lorsque j'ouvre mon fichier htaccess à partir de FileZilla, il s'ouvre avec le bloc note. J'ai réessayé avec un éditeur de code et tout fonctionne !!!

Mais je n’ai pas trouvé ce que le \xef vient faire dans mon htaccess. Peut être à cause du bloc note...

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
EBS01    20

C'est sur que c'est un problème d'encodage, c'est pour cela que je te demandais de le convertir en UTF-8 without BOM.

Comme je suis sur mon téléphone, je ne peux pas te le faire ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
Manu64    7

Pour être sûr de bien resppecter le format BOM UTF-8, vous pouvez utiliser "Sublim text" - Ce n'est pas totalement "free" mais ils ne t'harcèlent pas de pop-up.
La version portable est disponible.

Tschuss et merci.

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Contenu similaire

    • Par danyelguero
      Bonjour,
       
      J'ai installé un serveur web apache pour un nouveau site avec zwii.
      Mes sites web sont en backend derrière un haproxy qui renvoi tout les requêtes 80 et 443 en 443,
       
      Le problème avec mon nouveau site zwii est qu'il est vu avec du contenu mixed (http et https), j'ai pourtant bien fait pointer mon serveur web dans la section backend en port 80.
       
      Est-ce un comportement normal ou j'ai oublié quelques chose?
       
      Merci d'avance pour vos retours

    • Par Manu64
      Bonjour à tous.
      Je constate une erreur de sécurité sur le forum. Pas de redirection https en 301 !
      Est-ce normal ?
    • Par pcmid
      Je viens d'installer un certificat let's encrypt sur mon hébergement mais comment faire pour forcer le site à passer en https://