• 0
ClementL

Problème Affichage Page SiteMap

Question

ClementL    1

Bonjour à toutes et à tous,
Je suis nouveau ce forum, j'utilise Zwii pour le site d'une association ; et j'en suis pleinement satisfait, simple, efficace et léger !
J'ai une question car j'ai constaté un modeste bug d'affichage sur une de mes pages. Peut-être erreur de manipulation de ma part...
Le lien Plan de Site en footer me dirige vers le fichier XML brut direct ... 

Le lien du site : https://www.comitehistoriquehersincoupigny.fr

Le visuel est joint

D'avance merci pour vos réponses et éclaircissements, j'ai peut-être loupé une étape... ;-)
Cordialement

Clément

Capture d’écran 2018-11-24 à 14.12.12.png

  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

5 réponses à cette question

Messages recommandés

  • 0
PeterRabbit    371

Bonjour @ClementL. C'est bien de constater que Zwii peut rendre les services pour lesquels il a été conçu. 

 

Moi aussi, je dois avoir loupé une étape : le plan du site ne fait pas appel à un service extérieur ni à du xml. Si j'ai bien compris, tout se fait à la volée dans "core/module/sitemap", non ? o.O

 

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
ClementL    1

Bonjour PeterRabbit

 

Merci, ta réponse m'a éclairé !

 

Je pense comprendre... et je me rappelle ce que j'ai du faire ; j'ai généré un sitemap.xml pour la Google Search Console (xml obligatoire de mémoire) via un générateur de sitemap ; et je l'ai placé à la racine du site... du coup comme, je suis en réécriture d'URL, et que le lien sitemap du footer pointe vers www.monsite.fr/sitemap, il m'ouvre le XML... logique :-(
Que faire maintenant... réflexion

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
PeterRabbit    371

Supprimer ton fichier -- ou juste le déplacer ou le renommer -- et faire confiance à Zwii.

En fait, je ne sais rien du service en question, mais est-il essentiel à partir du moment où il y a tout ce qu'il faut out of the box ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
ClementL    1
il y a 5 minutes, PeterRabbit a dit :

Supprimer ton fichier -- ou juste le déplacer ou le renommer -- et faire confiance à Zwii.

En fait, je ne sais rien du service en question, mais est-il essentiel à partir du moment où il y a tout ce qu'il faut out of the box ?

 

SearchConsole, c'est Google Search Console, ça permet de contrôler et de maintenir la présence d'un site dans les résultats de recherche Google. C'est un bon outil pour le référencement ; simplement, le sitemap proposé par zwii est en .php, or la Search Console ne prend en charge que le format standard .xml ; d'où ma génération ; mais, c'est moi, j'ai placé ce sitemap.xml en racine, sans percuter que cela aurait une incidence avec le sitemap.php réécrit en /sitemap (réécriture d'url) ; je vais déplacer le sitemap.xml dans un autre dossier et normalement cela devrait se régler...
Je suis vraiment passé à côté d'une chose toute "bête"... 
 

Merci pour l'échange ! ;-)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
PeterRabbit    371

Merci à toi. Décidément, il faudra que je sorte de mon terrier ! xD

Mais si ça marche, publie tout de même pour d'éventuels utilisateurs qui auraient le même problème, édite ton sujet et ajoute [Résolu] au début du titre.

Modifié par PeterRabbit
  • Like 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant