cybertaf

Configuration réécriture URL sous Nginx

Message ajouté par cybertaf

Messages recommandés

pwepwe973    6


5bf731e8d64bf_Capturedcran_2018-11-22_22-39-49.thumb.png.76b4786dd39e93e17a02bdda5c5f19de.png



Bonjours a vous :grin:
 

Après la mise à jours vers la version 8.4.8 quand je cliquais sur les liens du site j'avais une erreur 404 sur toute les pages, sauf quand je faisais appelle à la pages  index.php comme ceci "www.adresse.fr/index.php" ou "www.adresse.fr/"  la pages s'affichait.
Ou en tapant la variable (?la_pages_voulu) comme ceci "www.adresse.fr/?accueil ou www.adresse.fr/index.php?accueil"  la pages s'affiche la aussi.

mais si je clic sur les lien dans le site "www.adresse.fr/accueil" erreur 404, donc j'ai été vérifier le fichier .htaccess que j'ai comparé à l’ancienne version


j'ai remarqué que après la mise à jours les lignes  suivant avais été ajouté au .htaccess

# Attention, surtout ne rien modifier ci-dessous !
# URL rewriting
<ifModule mod_rewrite.c>
	RewriteEngine on
	RewriteBase /
	RewriteCond %{REQUEST_FILENAME} !-f
	RewriteCond %{REQUEST_FILENAME} !-d
	RewriteRule ^(.*)$ index.php?$1 [L]
</ifModule>

 Cela m'a permis de comprendre que la page était appelé via www.adresse.fr/?accueil (www.adresse.fr/index.php?accueil)  et réécrite vers www.adresse.fr/accueil

Et comme la réécriture d'URL sur mon serveur se fait via une interface de gestion avec le plugin pour nginx. (sous openmediavault)

J'ai ajouté ces lignes à nginx via mon interface de gestion.

if (!-e $request_filename) {
    rewrite  ^/(.*)$ /index.php?$1  last;
    break;
}

et voila tout refonctionne correctement.

Si vous avez ce soucis après la mise à jours cela peut être du à ceci. je ne sais pas si c'est la bonne rebique pour ce message désolé par avances 

 

Cordialement SYLVAIN

Modifié par pwepwe973

Partager ce message


Lien à poster
Partager sur d’autres sites
cybertaf    119

Merci de ton retour, je ne comprends pas comment la réécriture d'URL ait pu s'activer, le zip livré ne contient pas le code nécessaire.


Heureux que tu aies trouvé une solution.


Je déplace le sujet dans "bouts de code".

  • Thanks 1

Partager ce message


Lien à poster
Partager sur d’autres sites
pwepwe973    6
Le 23/11/2018 à 11:09, cybertaf a dit :

Merci de ton retour, je ne comprends pas comment la réécriture d'URL ait pu s'activer, le zip livré ne contient pas le code nécessaire.


Heureux que tu aies trouvé une solution.


Je déplace le sujet dans "bouts de code".

 

Je t'en prie c'est rien c'est tout a fait normal ça peu aider

moi non plus je ne sais pas je me suis retrouver avec des erreur 404.
 

Modifié par pwepwe973

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Contenu similaire

    • Par Marie-Anne
      Hello à tous
      Suite à la mise à jour voici deux points intéressants à résoudre 
       
      - Si on clique sur blog : page 500 , ça disparaît avec le changement de nombre d'articles à afficher.
      - Maintenant la Date de publication devient obligatoire, mais elle se vide à chaque visualisation de la page 
      en mode modification.
       
      Sinon nikel 
    • Par pwepwe973
      Bonjour j'ai contacté que parfois en installant des plugins cela crée des code html dupliqué dans la page


         je ne sais pas d’où cela peu venir je me dis que cela peu alourdir les pages

      Cordialement @pwepwe973