• 0
stratego

retour experience mise a jour

Question

stratego    10

Bonjour,

 

apres la mise à jour de la 8.3.x vers le version 8.4.3 : 

 

Plus de lien vers "connexion"

Probleme avec l'url rewriting : les pages sont indisponibles sauf si on rajoute le ? 

Etant donné qu'il n'y a plus de lien vers "connexion", impossible de désactiver l'url rewriting - donc site planté

Partager ce message


Lien à poster
Partager sur d’autres sites

28 réponses à cette question

Messages recommandés

  • 0
PeterRabbit    371

C'est tout de même étonnant que l'installation de la 8.4 pose autant de problèmes. o.O

Cette fois, j'ai fait une installation manuelle pour en avoir le cœur net.

 

Désolé, mais tout s'est bien passé, comme hier pour la mise à jour automatique vers la 8.42.

Le lien "Connexion" est à sa place habituelle, la réécriture des URLs n'est pas activée par défaut et elle fonctionne parfaitement, dans un sens comme dans l'autre, bref le site semble opérationnel out of the box.

A part incriminer la qualité relative des connexions ou des hébergements, comment expliquer ce genre de situation improbable ?

 

@cybertaf a raison : on efface tout et on recommence. Si certains fichiers se sont corrompus en chemin, remplacer .htaccess pour désactiver la réécriture des URLs faute de lien vers la page de configuration risque de ne pas changer grand chose. Et Zwii est si vite installé...

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
PeterRabbit    371

Je maintiens mon hypothèse, @stratego : ton hébergeur n'est pas le meilleur des gratuits. Te me l'avais fait découvrir, mais j'en suis vite revenu, pour quelques bizarreries, justement. Comme ils ont supprimé mes comptes, vu que je n'y faisais plus rien, je ne peux donc pas confirmer. Dommage.

 

Depuis que PingFiles a cassé ses disques durs, j'ai essayé Infinityfree. La rapidité, voire la possibilité de se connecter dépendent du nombre d'utilisateurs, mais il fait ce qu'il doit faire : je viens d'installer la 8.43 sans aucun problème.

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
stratego    10

C'est juste un espace test.

 

Cela se produit chez un hébergeur belge ( CE informatique) et chez LWS

 

L'hebergeur n'a rien a voir avec le probleme

 

D'ailleurs au départ le site a été fait sur cet hébergement sans problème, c'est une fois la mise à jour exécutée que le part en Cacahuete

Modifié par stratego

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
PeterRabbit    371

Bon bon... Tu voudrais regarder quelque chose ? Édite "data.json", cherche "loginLink" et vérifie sa valeur.

 

PS : Et tu as essayé d'installer à la main ?

PS' : Ou de confectionner un lien vers "?user/login/accueil", pour voir ?

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
cybertaf    119

J'ai au moins un site chez LWS, j'effectuerai la mise à jour ce soir pour voir ce que ça donne.

La consultation du fichier error.log à la racine peut révéler des informations.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
PeterRabbit    371

Pour ne pas te donner l'impression que je suis de parti pris – que serait la France sans les belges ? xD –, je continue les essais : mise à jour de 8.314k vers 8.43 sans problème chez Infinityfree (il vaut mieux faire ça le matin, chez eux).

 

Avec la version 7.8, "data.json" se corrompait dès qu'il y avait un petit problème de transmission des données et ce n'est pas pour te vexer que je maintiens que ça peut arriver : j'ai fait le ménage chez mes gratuits hier matin et un certain nombre de fichiers ne sont pas rentrés du premier coup – un peu moins chez Infinityfree que chez Webhost. 

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
cybertaf    119

La mise à jour 8.4.2 modifie le mode de fonctionnement du pied de page qui est désormais dans des blocs. Il n'y a donc aucune erreur de ce coté, il faut les initialiser dans le thème puis footer.

Il est donc vrai que lorsque le lien de connexion n'est pas mis dans le menu, cela peut poser problème bien qu'il soit toujours possible de se connecter. La prochaine update initialisera le lien de connexion par défaut afin de l'éviter.
Le problème décrit vient de l'URL rewriting, le fichier htaccess contient certainement une erreur ou l'option n'est pas supportée.
Comme l'explique @PeterRabbit, se connecter sur cette adresse http://linux-pc.byethost15.com/?user/login/accueil et restaurer le footer.
 

Modifié par cybertaf

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
stratego    10
il y a 26 minutes, PeterRabbit a dit :

PS' : Ou de confectionner un lien vers "?user/login/accueil", pour voir ?

 

Ca, ca fonctionne :hushed:

 

"loginLink":"1"

 

apparemment pas de error.log a la racine :frown:

 

Merci pour votre aide :grin:

 

  • Like 2

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
creatifmen    21

Hello @stratego l'hypothèse de @PeterRabbit est totalement correct attention aux hébergeurs gratuit..
pour savoir si un cms fonctionne correctement c'est faire un test en local.

utiliser xampp par exemple.

xampp-win32-5.6.38-0-VC11  version php 5.xx
             

wampserver3.1.0 ,wampserver3.1.4       ne fonctionne pô correctement avec zwii 8.4.xx

A+

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
mrv    0

Salut, pour le problème de lien de connexion, si c'est dans le footer, j'ai eu le coup mais c'était juste que dans : Thème -> Pied de page le bloc copyright s'était mis en masqué après la mise à jour. Il m'a donc suffit de l'afficher.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
mrv    0
Il y a 4 heures, stratego a dit :

@cybertaf Qu entends tu par restaurer le footer?

 

Le footer est bien présent mais n'apparait pas une fois hors connexion

Avez-vous testé la solution que je propose ci-dessus ?

 

Rappel : Thème -> Pied de page -> bloc copyright -> afficher

Modifié par mrv

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
cybertaf    119
Il y a 5 heures, stratego a dit :

@cybertaf Qu entends tu par restaurer le footer?

 

Le footer est bien présent mais n'apparait pas une fois hors connexion

Le footer c'est le pied de page dont les réglages sont dans le thème.

Copyright doit être activé dans un des blocs pour être visible.

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
PeterRabbit    371
Il y a 2 heures, stratego a dit :

@creatifmenje suis bien d'accord si tu te fais un site...mais si tu fais un site pour quelqu'un d'autre.  Il faut pouvoir lui montrer avant d'acheter un hebergement et un NDD

 

@cybertaf m'a conseillé Obambu. Pour 9.94€ TTC par an (ou moins, si tu prends sur 2 ou 3 ans), avec un nom gratuit et pas à coucher dehors (lenomdetonsite.fr.fo), et surtout un formulaire contact qui fonctionne (ce que tu n'as pas là où tu es, sauf défaut de mémoire), franchement, pour faire un site d'essais et montrer tes réalisations à tes clients... o.O

Modifié par PeterRabbit

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
stratego    10
Il y a 2 heures, mrv a dit :

Avez-vous testé la solution que je propose ci-dessus ?

 

Rappel : Thème -> Pied de page -> bloc copyright -> afficher

 @mrv

J'y vois pas ce que tu dis(voir pièce jointe)

Image 2.png

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
mrv    0
il y a 26 minutes, stratego a dit :

 @mrv

J'y vois pas ce que tu dis(voir pièce jointe)

Image 2.png

 

Es-tu certain d'utiliser la dernière version de Zwii (8.4.3) car chez moi, voici la page en question (j'ai entouré en rouge la valeur que j'ai du modifier de "masqué" à "bloc central") :

 

Screenshot_20181115_180512.png

 

PS : en regardant mieux ta capture, je m'aperçois que tu n'as pas de checkbox "Lien de connexion" or chez moi, il a toujours été présent. Est-il plus bas dans la page ?

 

PS 2 : Si un autre membre pouvait confirmer que mon screenshot correspond bien à la version actuelle de Zwii ...

Modifié par mrv

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
stratego    10
Il y a 13 heures, cybertaf a dit :

@stratego ta version de Zwii n'est pas la dernière...

 

C'est bien ce que j'écrit dans mon premier post

 

J'utilise la 8.3.13.

 

Cela n’empêche...après la mise à jour ça part en sucette

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant