• 0
creatifmen

bug ZwiiCMS-8.2.9 004 sans proportion images

Question

creatifmen    13

hello je crois que j ai trouver un nouveau bug quand l'ont veut redimensionner une images

sans conserver les proportions ,l'option Conserver les proportions ne fonctionne pas..

voila si ça peut aider..

a++belle soirée creatif

bug.jpg.48735f24ae20618ecc62bd9a329a3250.jpg

Partager ce message


Lien à poster
Partager sur d’autres sites

27 réponses à cette question

Messages recommandés

  • 0
cybertaf    78

Bonjour,

Je viens de faire la mise à jour de TinyMCE vers la version 4.8.2 (2018-08-09) mais le problème n'est pas réglé.

La proportion reste bloquée à l'affichage, même en corrigeant les dimensions dans le code HTML.
Quelques modifications des paramètres d'init.js ne corrigent pas le problème.

Ce sera une correction à apporter pour la prochaine mise à jour, à explorer.
En attendant je recommande ce qui est le plus logique, c'est à dire, redimensionner les images avant de les importer.

 

PB à suivre.
 

  • Thanks 1

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
CroqueWeb    99
Le 18/08/2018 à 14:18, McGregor a dit :

demande que les développeurs actualisent TinyMCE ou simplement le plugin "Image" pour leur prochain release

Inutile ! TinyMCE n'est pas le responsable, il écrit parfaitement les tailles entrées dans l'interface d'ajout/modification d'image.

 

Le 18/08/2018 à 15:57, cybertaf a dit :

Je vais intégrer la correction dans le Zwii 8.3, il y aura une version d’essai dès que c’est prêt. 

Y'a pas de correction possible !

L'impossibilité d'afficher une image de façon disproportionnée est due à une propriété présente dans common.css :

img {
	max-width: 100%;
	height: auto;
}

Mais cette propriété est indispensable pour le reste du site, donc, si vous voulez dimensionner une image sans respecter ses proportions, faites-le en local avec votre logiciel qui va bien ;)

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
CroqueWeb    99

disproportion.thumb.png.8d3d24dd19029209d1cb4dbccc2987b2.png

Affichage disproportionné après suppression de la propriété CSS de img ci-dessus indiquée

Modifié par CroqueWeb
précision

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
CroqueWeb    99
Le 18/08/2018 à 14:36, creatifmen a dit :

en attendant ont install ckeditor

Ce qui n'a pas eu pour conséquence de régler ton problème, hein ?

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
CroqueWeb    99
Il y a 3 heures, cybertaf a dit :

Le plus propre est certainement de supprimer l'option dans la config de TinyMCE.

Bien sur que non ! Y'a que @creatifmen qui affiche des images aplaties dans son site ;)

Laisse Tiny tel quel, ce sera plus simple pour le mettre à jour.

Et puis, au final, est ce un bug de ZwiiCMS-8.2.9 004 ? Ou d'un autre Zwii ?

-> Non ! L'adaptabilité des sites web à des règles imparfaites, mais c'est pour l'instant les seules disponibles.

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
cybertaf    78
il y a 17 minutes, CroqueWeb a dit :

Supprime le puis affiche ton site, contenant des zimages, dans différentes résolutions, tu m'en diras des nouvelles :)

Et bien j’ai testé sans noter de pb sinon que la non proportionnalité fonctionne. Si tu as un exemple :)

Modifié par cybertaf

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
CroqueWeb    99

 

il y a 58 minutes, cybertaf a dit :

Et bien j’ai testé sans noter de pb sinon que la non proportionnalité fonctionne

 O.o

Affiche donc une image "normalement" CAD que tu ne veux pas afficher aplatie ou déformée, ce que 99.999% des personnes qui placent des image sur leur site expectent, donne lui si tu le souhaites une taille définie....

il y a une heure, cybertaf a dit :

Si tu as un exemple

Affichage dans un smartphone Samsung Galaxy Note 3

<p>Taille d'origine 1600x774 px :<br /><img src="/ZwiiCMS-831/site/file/source/saturn.jpg" alt="" width="1348" height="652" /></p>
<p>&nbsp;</p>
<p>Réduite à 800x 388 px<br /><img src="/ZwiiCMS-831/site/file/source/saturn.jpg" alt="" width="800" height="388" /></p>

1.png.d2f977d8bc3654e77a755e112b2fd030.png

r1.thumb.jpg.13b5fd478e3b9fb50e75f531d6cbdb1d.jpg

 

2.png.61bd2cd1b64bdd5e3c75eebd54a05eae.png

r2.thumb.jpg.08cb20a80fd767960c5357b07f881f5c.jpg

 

r3.thumb.jpg.ddc16fc5ad804a0f7e380542196fe03f.jpg

 

il y a une heure, cybertaf a dit :

la non proportionnalité fonctionne

Mais plus la proportionnalité.

Le 01/09/2018 à 06:26, cybertaf a dit :

En quoi 


height: auto 

est indispensable ?

 

En ça !

 

 

 

 

 

 

Partager ce message


Lien à poster
Partager sur d’autres sites
  • 0
cybertaf    78

Voilà qui est bien plus précis. 

 

Le parametrage du CSS n’est pas bon de toute manière avec ou sans     auto. 

 

La proportionnalité doit fonctionner ET l’affiache sur un écran de taille réduite. 

 

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant