cybertaf

Améliorer l'éditeur de code

Messages recommandés

CroqueWeb    73
il y a 1 minute, PeterRabbit a dit :

Non, c'est le même petit désagrément dans les deux cas.

 

Oui, j'ai aussi remarqué quelques caprices de ce plugin

Le problème de jQuery c'est que les scripts fonctionnant bien, ne fonctionne plus, ou mal, après une mise à jour de la bibliothèque

Partager ce message


Lien à poster
Partager sur d’autres sites
PeterRabbit    283

@CroqueWeb @omega

 

A vérifier : Pour un chargement plus rapide, il est recommandé de placer les appels de scripts au bas de la page. Les lignes 9-12 de "core/vendor/tinymce/plugins/codemagic/codemagic.htm" appelant près de 250 Ko de scripts, je me suis dit que cela ne coûtait rien d'essayer...

<script type="text/javascript" src="../../../../../core/vendor/jquery/jquery.min.js"></script>
<script type="text/javascript" src="includes/codemirror/codemirror.js"></script>
<script type="text/javascript" src="includes/batched_scripts.js"></script>
<script type="text/javascript" src="includes/codemagic.js"></script>

.Je les ai donc placées après la ligne 45.

J'ai multiplié les essais depuis et jusqu'à présent — je croise les doigts — je n'ai pas eu à m'y prendre à deux fois. o.O

 

PS : Le cache de Chrome joue des tours, il faut le purger avant chaque essai. C'est comme ça que j'ai fini par constater qu'on ne peut pas se servir de la version de Codemirror embarquée dans la 8.29 : le code s'affiche, mais on ne peut pas positionner le curseur où on veut. Quelques Ko de grattés, cétait trop beau.

Modifié par PeterRabbit (Voir l’historique des modifications)

Partager ce message


Lien à poster
Partager sur d’autres sites
PeterRabbit    283
Il y a 18 heures, CroqueWeb a dit :

Après tests concluants des actuels intéresses, je proposerais une version de "codemagic" traduite en français que j'utilise déjà

 

Tu vas peut-être pouvoir faire péter ta trado @CroqueWeb ! :beer: xD

Partager ce message


Lien à poster
Partager sur d’autres sites
omega    25
Il y a 7 heures, PeterRabbit a dit :

@CroqueWeb @omega

 

A vérifier : Pour un chargement plus rapide, il est recommandé de placer les appels de scripts au bas de la page. Les lignes 9-12 de "core/vendor/tinymce/plugins/codemagic/codemagic.htm" appelant près de 250 Ko de scripts, je me suis dit que cela ne coûtait rien d'essayer...


<script type="text/javascript" src="../../../../../core/vendor/jquery/jquery.min.js"></script>
<script type="text/javascript" src="includes/codemirror/codemirror.js"></script>
<script type="text/javascript" src="includes/batched_scripts.js"></script>
<script type="text/javascript" src="includes/codemagic.js"></script>

.Je les ai donc placées après la ligne 45.

J'ai multiplié les essais depuis et jusqu'à présent — je croise les doigts — je n'ai pas eu à m'y prendre à deux fois. o.O

 

PS : Le cache de Chrome joue des tours, il faut le purger avant chaque essai. C'est comme ça que j'ai fini par constater qu'on ne peut pas se servir de la version de Codemirror embarquée dans la 8.29 : le code s'affiche, mais on ne peut pas positionner le curseur où on veut. Quelques Ko de grattés, cétait trop beau.

 

Bonjour Peter ,

:fearful: je pense que la météo est bonne chez toi et que les énergies sont positives
rien à faire de mon coté , le radon est peut être pour quelque chose ...:D

je ré essayerai lors d 'une prochaine installation de zwii.

Bon weekend

Partager ce message


Lien à poster
Partager sur d’autres sites
PeterRabbit    283

@omega Quand tu essaieras, mets mon petit cadeau codemagic.png.6bb744d0b6caefac703141395dc6a628.png dans "codemagic/images" à la place de l'icone d'origine (Clic droit > Enregistrer l'image sous" > codemagic.png). :)

 

blob.png.b26fb614b0e29680f4d02387fb64ee8b.png

 

Il n'y a pas qu'en Bretagne qu'il y a du radon : le gymnase de mon lycée est ventilé en permanence parce qu'il y en a trop. Les origines celtiques de la Bigorre, peut-être ? o.O

 

Modifié par PeterRabbit (Voir l’historique des modifications)

Partager ce message


Lien à poster
Partager sur d’autres sites
CroqueWeb    73
Il y a 9 heures, PeterRabbit a dit :

Tu vas peut-être pouvoir faire péter ta trado @CroqueWeb ! :beer: xD

Le 19/04/2018 à 16:14, CroqueWeb a dit :

 

Après tests concluants des actuels intéresses

Partager ce message


Lien à poster
Partager sur d’autres sites
CroqueWeb    73

C'est clair que @omega a fait mieux que ce que j'envisageais de faire ;)

"Improvedcode" ressemble beaucoup à "codemagic" duquel l'auteur du premier s'est sans doutes inspiré, le second étant déjà ancien, utilisant jquery en version 1

Partager ce message


Lien à poster
Partager sur d’autres sites

Créer un compte ou se connecter pour commenter

Vous devez être membre afin de pouvoir déposer un commentaire

Créer un compte

Créez un compte sur notre communauté. C’est facile !

Créer un nouveau compte

Se connecter

Vous avez déjà un compte ? Connectez-vous ici.

Connectez-vous maintenant

  • Contenu similaire

    • Par Carambozilla
      Bonjour et merci pour ce joli CMS qui; à priori, me convient parfaitement de par sa simplicité et sa légèreté. Le graphisme de base est également très agréable.
      Cependant, j'ai un problème avec le module du blog.
      J'ai téléchargé le bout de code qui permet d'afficher une pagination lorsqu'on dépasse plus de 10 articles.
      Je vois bien la pagination et lorsque je clique sur "2" dans l'interface d'édition, pas de problème, la deuxième page se charge.
      Par contre, si je sors de l'interface d'administration, si je clique sur "2", j'obtiens le message suivant : Erreur 403 - Vous n'êtes pas autorisé à accéder à cette page... 
       
      J'ai pourtant créé les billets tests après avoir copié les codes.
      Quelqu'un a-t-il une idée ?
      Merci par vance pour vos éclaircissements.