Rechercher dans la communauté

Affichage des résultats pour les étiquettes 'blog'.



Plus d’options de recherche

  • Rechercher par étiquettes

    Saisir les étiquettes en les séparant par une virgule.
  • Rechercher par auteur

Type du contenu


Forums

  • Annonces
    • Règlement du forum
    • Informations et nouveautés
  • Support de Zwii
    • Bugs, questions et tests
    • Suggestions
    • Version de développement
  • Communauté
    • Vos sites sous Zwii
    • Support des téléchargements
    • Tutoriels et bouts de code

Catégories

  • Versions officielles en beta
  • Versions non officielles
  • Modules
  • Modifications et astuces

8 résultats trouvés

  1. bonjour, je souhaite utiliser ce super CMS uniquement pour ajouter une page BLOG à mon site (qui lui n'est pas en CMS). 1) Peut on définir le nombre d'article par page ? actuellement il change de page au bout de 10 articles. 2) Peut-on désactiver les commentaires sur le blog ? (aucun utilisateur ne va s'inscrire c'est juste un blog basique) EDIT : j'ai supprimé les lignes dans article.php c'est bon 3) Peut-on enlever "?blog" de tout les urls ? j'ai renommé zwii en "blog" mais la du coup ça me fait "monsite.fr/blog/?blog/mon-premier-article" 4) il y a un plugin pour le partage de post sur facebook ? Merci beaucoup
  2. Bonjour je viens m ' apercevoir que lorsque que l 'on modifie le titre d 'un blog , le ou les commentaires associés sont supprimés. Zwii V8.1.2 ce problème est il connu ? y aura t 'il une nouvelle version pour éviter de perdre ces données ? quelqu 'un peut il vérifier que le problème ne vient pas uniquement de mon site ? A Bientôt Bruno
  3. Problème d'accès sur le blog

    Bonjour et merci pour ce joli CMS qui; à priori, me convient parfaitement de par sa simplicité et sa légèreté. Le graphisme de base est également très agréable. Cependant, j'ai un problème avec le module du blog. J'ai téléchargé le bout de code qui permet d'afficher une pagination lorsqu'on dépasse plus de 10 articles. Je vois bien la pagination et lorsque je clique sur "2" dans l'interface d'édition, pas de problème, la deuxième page se charge. Par contre, si je sors de l'interface d'administration, si je clique sur "2", j'obtiens le message suivant : Erreur 403 - Vous n'êtes pas autorisé à accéder à cette page... J'ai pourtant créé les billets tests après avoir copié les codes. Quelqu'un a-t-il une idée ? Merci par vance pour vos éclaircissements.
  4. Celà fait un moment qu'un patch à été pondu pour réparer un soucis de pagination présent dans le module " News " depuis la sortie du Zwii en version 8 Ce patch fonctionne parfaitement pour ce module et peut aussi être appliqué pour les mêmes motifs qu’évoqués ci dessus au module " Blog " qui lui non plus n'a pas de pagination en bas de page si le nombre de plus de 10 articles est dépassé lors de l'édition d'une page de blog. Bien que la pagination apparaisse en copiant les ligne de code suivantes dans : /module/blog/view/index/index.php <div class="pagination"> <?php echo $module::$pages; ?> </div> sous la ligne <?php endforeach; ?> Dés que l'on clique sur le bouton pour aller sur la page n°2, on se retrouve sur une page avec erreur 403 qui correspond à un manque d'autorisation pour voir la dite page n°2 J'ai prévenu Rémi personnellement pour ce bug important car cela fait déjà plusieurs semaines, voir mois que nous travaillons là dessus et n'arrivons pas à trouver la bonne ligne de code qui ferait marcher ce module blog; Et il n'y a pas que le module "blog" qui est touché par ce bug, dans une version spéciale pour le zwii, il y a un module " nouvelles " qui fonctionne exactement sur la me architecture que celle du blog... donc si on répare le bug de l'un il va s'en dire que l'autre en bénéficiera aussitôt pour le plus grand bien de tous . Voici un lien d'un site de test pour que vous puissiez constater les " dégats "... http://lechti64.org/ULTIMATE-Tinymce/accueil Il y a trois onglets aprés la page d'accueil: un onglet " Blog " , un onglet " Nouvelles " ( tout deux touchés par le bug ) et un onglet " News " ( patché qui lui fonctionne parfaitement ) Alors si vous avez des idées, on est preneurs nous.... A vos crayons ceux qui veulent essayer une ultime fois de nous aider car moi je crois que mes neurones vont finir par flamber depuis le temps que nous sommes sur ce bug là.
  5. Nous avons dans le zwii un module blog dans lequel les dates de publications des articles sont écrites sous la forme la plus simple que permet le code php, fonctionnel mais pas vraiment esthétique Mais que diriez vous de pouvoir montrer à vous éditeurs les fameuses dates de parution de vos articles de la façon la plus jolie qui soit, c'est à dire le nom des jours et moi en toutes lettres ainsi que l'horodatage des articles visuellement plus agréable à l’œil? Juste pour vous montrer visuellement l'effet produit comme dans les pub à la télé, vous savez le truc du genre Avant / Après Avant Après Avant Après Çà vous plais cette façon de présenter la date de vos écrits de manière plus contemporaine ? Entrons donc dans la partie la plus intéressante pour le faire !!! Vous allez vous rendre là où est hébergé votre cms zwii et rechercher deux petits fichiers à modifier pour obtenir ce résultat. Ses fichier se trouve dans le module du blog situé dans ce dossier du zwii.. ( /module/blog/view/index/ & /module/blog/view/artricle/ ) 1° dans le dossier " index " ouvrir le dossier nommé index et recherchez dedans le fichier index.php ( /module/blog/view/index/index.php ) - recherchez vers la ligne n° 8 <?php echo helper::translate('le'); ?> <?php echo date('d/m/Y H:i', $article['publishedOn']); ?> 2° - remplacez son contenu par <?php echo helper::translate('a &eacute;crit le'); ?> <?php setlocale(LC_TIME, 'fr_FR.UTF8'); echo strftime('%A %d %B %Y', $article['publishedOn']); ?> <?php echo helper::translate('&nbsp;&nbsp;vers'); ?> <?php setlocale(LC_TIME, 'fr_FR.UTF8'); echo strftime('%H:%M', $article['publishedOn']); ?> 3° dans le dossier " article " ouvrir le dossier nommé index et recherchez dedans le fichier index.php ( /module/blog/view/article/article.php ) - recherchez la ligne n° 5 <?php echo helper::translate('on'); ?> <?php echo date('d/m/Y H:i', $this->getData(['module', $this->getUrl(0), $this->getUrl(1), 'publishedOn'])); ?> 4° - remplacez son contenu par <?php echo helper::translate('a &eacute;crit le'); ?> <?php setlocale(LC_TIME, 'fr_FR.UTF8'); echo strftime('%A %d %B %Y', $this->getData(['module', $this->getUrl(0), $this->getUrl(1), 'publishedOn'])); ?> <?php echo helper::translate('&nbsp;&nbsp;vers'); ?> <?php setlocale(LC_TIME, 'fr_FR.UTF8'); echo strftime('%H:%M', $this->getData(['module', $this->getUrl(0), $this->getUrl(1), 'publishedOn'])); ?> ATTENTION !!! Le code de remplacement n'est pas le même pour le fichier index.php du blog que pour l'article.php d'un article, alors ne copier pas deux fois le m^me code de remplacement par soucis d'économiser du temps , vous seriez déçu du résultat. Respectez l'ordre des modifications en copiant/collant les codes contenus dans les deux boite de dialogue ci dessus, c'est primordial pour la réussite de votre modification. Bien entendu, n'oubliez pas d'accepter le changement de vos modifications sur chaque fichier quand vous les remettez dans leur dossiers respectifs sur votre ftp. Voila, voilou si ceci vous plais, à vous de jouer.
  6. Problème de traduction

    Bonjour, j'aime beaucoup votre CMS et l'esprit qui anime votre communauté. @Roger nounours J'ai cru comprendre que vous proposez des patchs quand on vous signale un problème. Serait-il possible de régler un défaut de traduction dans la date des posts du blog ? En effet; il y a "on" juste avant la date. En français, on dirait plutôt "le", ou rien du tout. Ce n'est qu'un détail, mais c'est dommage. Merci d'avance !
  7. Bonjour à tous, je suis en train de bosser sur un blog. Petite question, je vois que lorsque je dépasse 10 articles par blog, il ne m'affiche que les derniers articles saisis. Pourriez-vous m'indiquer où je peux trouver la commande qui bloque ceci car je souhaiterais que tous les articles soient listés et non uniquement les 10 derniers. Merci beaucoup. Wilo
  8. Le Fouilli de Jéjé

    Hello la communauté, migration de mon blog perso vers Zwii effectué et dispo à l'adresse : http://www.lefouillidejeje.com/ Y a pas ch..er, c'est quand moins prise de tête que Wordpress ! Longue vie à Zwii Wilo