Dagda

Membres
  • Compteur de contenus

    12
  • Inscription

  • Dernière visite

Réputation sur la communauté

3 Neutre

À propos de Dagda

  • Rang
    Apprenti
  1. Salut la compagnie Alors, je reviens vous voir ici pour vous donner quelques détails de l'évolution de la chose ! Pour rappel : Mon besoin de Zwii était simple, faire de la galerie pour simplifier la visualisation du dossier "FTP" /public qui me sert de stockage pour les photos que je postes sur les forums. Le dossier en question est http://www.dctech.fr/public/ Ma problématique, le sujet de ce topic, était que Zwii ne proposait pas de choix de lien externe à l'arborescence Zwii, juste un menu déroulant avec des liens vers les dossiers choisis (mais qui restent malgré tout dans l'arborescence Zwii) C'est chose faite avec l'aide de PeterRabbit que je remercie encore une fois. Mais ça ne s'est pas arrêté là et nous avons été plus loin sur deux points principalement. Le premier point était le choix des photos à afficher dans les galeries créées. En effet, mes dossiers sont ... chargés avec plusieurs photos de projets différents dans un même dossier, et comme je le disais plus haut, je ne peux pas changer l'arborescence puisque les photos sont référencés sur des forums. Donc, maintenant j'ai la possibilité de choisir les photos à afficher dans les galeries, ou plus précisément, je sélectionne les photos que je ne souhaite pas afficher (plus simple à coder selon PeterRabbit). Le second point, plus simple au demeurant, était au niveau du .htaccess de l'arborescence Zwii. Comme Zwii a été placé directement à la racine du site, le .htaccess bloquait l'accès au dossier /public et donc à la classique arborescence "FTP" qui me sert pour trouver les liens des photos à mettre sur les forums que je fréquente. Bon, ce fut simple de placer un .htaccess autorisant l'accès (le listing du dossier) dans le dossier /public, mais un bête retour à la ligne bloquait le résultat ... Bref, donc, j'ai actuellement un "site" avec galeries permettant de voir "esthétiquement" des photos sélectionnés tout en pouvant utiliser ce dossier /public comme avant. Voilà pour la petite histoire Encore merci PeterRabbit pour ta patience avec moi D.
  2. Et voilà, ça fonctionne. Merci beaucoup monsieur PeterRabbit D.
  3. Ah, alors, non ! Je n'ai pas fait de copier coller de ton code, j'ai juste changer le "select" en "text" ... et je viens de comparer et je constate qu'en effet, il y a deux trois bricoles en plus de changé Je vous dirais ce soir donc ... D.
  4. Sauf que, le "?" n'apparait pas dans le module nouvelle galerie, la case est décalée. Et de fait, tu l'expliquais plus haut mais je l'ai mal interprété Sauf que ... je n'avais pas changer config ... enfin si, mais je ne l'ai pas transféré ... du coup ça marche, mais toujours la même problématique de case décalée ... D.
  5. Or donc ! Ça fonctionne - voici le test : http://www.dctech.fr/?galeries/billot Qui pointe sur le dossier - http://www.dctech.fr/public/Billot/ Détails : Il faut bien noté "public/..." et pas "/public/..." ... pas de slash au début du lien. Mais : Rentrer le lien ne peut se faire qu'en éditant un module créé, on ne peut pas le faire à la création (je suppose que ça doit être la même modif dans un autre fichier, je devrais trouver). A suivre D.
  6. Ah bah cool ça Je tiens au jus la communauté ce soir D.
  7. Rentrer le chemin à la main ne me pose pas de problème. Je testerais ce soir, je n'ai pas de client FTP au taff. Merci à toi en tout cas D.
  8. J'y ai pensé à ça ... mais ça ferait des doublons, surtout que j'ai des dossiers que je remplis au fur et à mesure, donc avec des mises à jours régulières ... si il faut que je transfert 2 fois les photos, va y avoir des oublis D.
  9. J'ai jeté un œil ... mais je ne trouve pas où intervient les liens du menu déroulant ...
  10. Voici le "site" - http://dctech.fr/?dc-tech Et la partie stockage FTP - http://dctech.fr/public/ Depuis 2014 j'y met les photos de mes réalisations et autres que je décris sur des forums. Donc, sur chaque messages comportant une photo sur les dit forum, il y a un lien de ce type - http://dctech.fr/public/Photos/2018/LaFleche/500-07m.jpg Je dois bien avoir 3 à 4000 liens référencés sur plusieurs forums ... d'où le fait de ne pas pouvoir déplacer le dossier dans la structure Zwii. Donc oui, faudrait bidouiller dans "module/galerie" mais je ne sais pas trop où ... faut que je regarde un peu plus, je ne suis pas programmeur mais je sais mettre les mains dans les codes pour faire ce genre de petites modifications D.
  11. Merci pour cette réponse rapide ! Mais ce n'est pas tout à fait ça, je me suis mal exprimé ... La redirection, j'ai trouvé, pas de problème. Ce que j'aimerais, c'est que lorsque je fais une galerie photo, je puisse pointer sur le dossier "public", sauf qu'il n'est pas dispo dans le menu déroulant pour choisir les photos ... il n'y a que les liens de la structure Zwii, on ne peux pas aller pointer sur un dossier externe à la structure Zwii. D.
  12. Bonjour à tous, Premier message sur ce forum. Je viens d'installer Zwii sur mon hébergement qui me sert pour du stockage de photos dans le but d'avoir une interface plus sympa que la bête arborescence "FTP" . J'ai un dossier "public" sur la racine du site contenant des photos. J'ai installé Zwii à la racine du site. Sauf que je n'arrive pas à avoir accès à ce dossier dans Zwii du fait qu'il n'est pas dans la structure initiale. Est-ce qu'il existe un moyen (modification d'un fichier / code) pour pouvoir intégrer de la galerie d'image venant de ce dossier ? Je précise que le dossier "public" contient principalement des photos qui sont utilisées pour être affichées sur des forums, je ne peux donc pas déplacer le dossier, sinon tout mes messages sur plusieurs forums se retrouveraient sans photos. Merci à vous. D.