Aller au contenu
Support de Zwii et Yocto

Toute l’activité

Ce flux se met à jour automatiquement     

  1. Dernière heure
  2. Je viens de DL le module, je le testerais + tard
  3. J'ai pas testé ce module, mais il semble que l'option "recherche par mot entier" soit ici mais pas dans recherche_v4
  4. Quel filtrage "mot entier" ? Je teste le .zip ci-dessus
  5. Aujourd’hui
  6. Bien meilleure je sais pas, différente en tout cas, et facile à mettre en oeuvre :)
  7. Merci beaucoup Pour réaliser un peu la même chose, j’avais customisé le module "Gallery". Ta solution semble bien meilleure (même si je ne l'ai pas encore testé).
  8. Bonjour @Fred Mise à jour : dans cette nouvelle version j'ai incorporé l'option "recherche par mot entier". Pour les notifications je ne vois rien, sur le serveur le dernier fichier d'erreur remonte au 21/6. Je n'arrive pas à afficher les notifications (warnings ?). Je laisse tomber cette correction vu que j'avance rapidement sur la réécriture globale du module suite à tes derniers conseils. Bonne journée Sylvain module_search.zip
  9. Bonjour @Gilux Merci pour tes tests. Pour le premier point je ne vois pas le hic : en testant avec des mots de 3 lettres, le filtrage "mot entier" semble fonctionner... Pour l'avenir du script en version Zwii 9.1, pas de soucis. Comme c'est lancé par un include et que l'on peut le déclarer dans la partie "script dans body", ça pourra toujours fonctionner. Par contre si la structure d'enregistrement des pages change dans l'avenir (Zwii 9.2 ?) je ne sais pas si je maintiendrais le script ET le module... Bonne journée Sylvain
  10. @Fred Merci pour l’info. Je me suis aperçu avoir omis de mettre une modification. J’ai donc modifié le premier post. Personnellement, je préfère la solution avec un fichier « couverture.jpeg » à insérer dans le dossier ciblé.
  11. Hier
  12. OK, j'ai testé 😉 La recherche fonctionne bien par expression et par mot, une limite cependant, en dessous de 4 lettres le résultat affiche des mots incluant la recherche, ex : pour la recherche 'mon', le résultat affiche : monsieur, mondial, monnaie, montrer... Mais aussi à l'intérieur d'un mot, comme ...monieux pour harmonieux C'est pas grave, on ne cherche pas souvent des mots de 3 lettres Les recherches des visiteurs ne se font plus dans les pages privées, du moins les résultats n'affichent plus ceux des pages privées, super ! Là, t'es en train d'en faire un module pour ZwiiCMS, on ne pourra alors sans doutes plus afficher le formulaire de recherche dans une barre latérale ? Si oui, c'est bête, car c'est comme ça que je l'utilise
  13. J'utilise désormais Laragon comme serveur Web qui ne passe sur aucun warning ou notice, il se peut que ces notices soient masquées dans les paramètres. Sinon tu devrais les trouver dans error.log Je vais terminer mes modifs sur le code du footer et puis je me mettrai sur les deux ateliers.
  14. Hello, Ça se gère au niveau de l'input dans la saisie des données, il faut un paramètre true ex : ' homePageId' => $this->getInput('configHomePageId', helper::FILTER_ID, true), Je regarderai ton code lorsque j'aurai terminé le footer.
  15. Reste encore à améliorer mais déjà : selection au clic et affichage au survol (moyen) Ajouter à la fin module/gallery/view/edit/edit.js.php Je suis pas un champion du jquery/javascript : $(this).text() ne semble pas fonctionner ... var CoverList = $("td.col4"); // ajout de la class vignette et definition de l'url de l'image mais $(this).text() ne fonctionne pas CoverList.addClass("vignette").attr("style", "--background: url('" + directoryOldDOM.val() + "/" + $(this).text() + "')"); CoverList.click(function(){ //selection de l'image dans le formulaire LORSQU'ON CLICK $("#galleryCoverPicture").val($(this).text()); // definition de l'url de l'image mais $(this).text() ici fonctionne ... $(this).attr("style", "--background: url('/" + directoryOldDOM.val() + "/" + $(this).text() + "')"); }); et dans votre fichier custom.css .vignette { position: relative; cursor: pointer } .vignette:hover:after { content: ""; width: 150px; height: 120px; background-image: var(--background); background-size: contain; position: absolute; top: -120px; left: 0 }
  16. Je n'arrive pas à reproduire les messages d'erreur sur search ligne 63... Ni sur mon test dev9.1, ni sur un nouveau site de test où je suis parti de 0 (version 9.1.12 puis maj vers 9.1.13) en ajoutant le module/search et en ajoutant la bonne ligne dans core.php. A l'occasion si tu peux confirmer le problème... merci Sylvain
  17. Bonjour @Gilux, c'est maintenant fait dans la version v4. Si tu peux faire les tests.... Bonne journée Sylvain
  18. J'ai essayé également de démarrer sans modules, mais même résultats. J'ai essayé de démarrer derrière le proxy de mon entreprise mais sans succès. Par contre IE et Chromium PC ne renvoient pas d'erreurs. C'est donc bien un problème firefox incompatible avec le site. edit:pour ne pas dire site incompatible avec Firefox
  19. Bonjour @Fred Je regarderai ça un peu plus tard... Pour le moment j'ai repris la version "script de recherche" pour avancer sur l'option de recherche 'mot entier uniquement'. : Fait Je reprendrai ensuite le module de recherche pour le corriger, puis mettre l'option, puis réécrire... Bonne journée Sylvain
  20. La dernière semaine
  21. Bonsoir Sylvain, Il y a un problème avec les noms de variables non déclarés qui gênèrent des notifications :
  22. Tu as essayé ? about:support
  23. J'ai essayé sur plusieurs machines, win10, Linux, sans succès Mon firefox est portable. Ca ne marche pas sur androïd + chrome. Ca marche sur edge.
  24. @augras c'est terminé, il faudra juste prendre en compte de nouvelles marges / paddings dans cette config. Le nom du réseau social par défaut sera changé si tu as une idée de vrai compte à proposer, par forcément FB d’ailleurs. De même je suis à l’écoute des remarques sur les libellés. Au niveau de la numérotation, cette version sera numérotée 9.2, le support des langues sera pour plus tard, 9.3 logiquement. Bonne fin de week-end et surtout n’oubliez pas de vous hydrater 😂
  25. Si tu synchronises tes terminaux, tu as peut-être une extension qui gène. Tu devrais tenter deux choses : - démarrer FF sans les modules - télécharger un FF portable pour vérifier qu’en le problème n’en vient pas du profil.
  26. Bonjour Il te faut créer un formulaire que tu ouvres aux visiteurs. A la réception, c’est à toi de créer le compte compte à la main.
  27. Bonjour La fonctionnalité n’est pas implantée nativement, il doit exister un plugin.
  28. Idem sur mon téléphone (chrome). Je passe par un vpn qui pointe sur la France, mais même déconnecté même résultat.
  1. Charger plus d’activité
×
×
  • Créer...